No LiveTraffic until Hotspot Wi-Fi connection — TomTom Community

No LiveTraffic until Hotspot Wi-Fi connection

CMHOCMHO Posts: 9 [Apprentice Seeker]
My TomTom Go 520 is using the same email as the MyDrive app on iPhone. They are blue-tooth paired. Good 4G reception on the road. But I couldn't get Live Traffic from day 1 for a year, until last week.

I turned on Hotspot on the iPhone and let TomTom use it as a Wi-Fi source. In just a few minutes, Live Traffic is there! Bingo! But how come?

Over a year, TomTom support ignored me, or just emailed me with outdated instructions, even asked me to enter "Manage community content", which does not exist, in order to "Saving a Copy of Your Favourites on Your Computer" (mine is a Mac).

Do I have to use Hotspot and Bluetooth connections whenever I use GO 520 on the road?

Answers

  • DougLapDougLap Posts: 3,443 Superuser
    edited June 7
    Hi @CMHO

    Could you check the following please whilst out of range of your Wifi.

    Tap Menu
    Tap Settings
    Tap Bluetooth
    Tap The Paired Phone

    Do you have an option Data for Traffic and other services Selected ie Blue

    Have you got the MyDrive App open on your phone whilst you are driving. It can be in the background but is required for this to work. If not turn it on and then see if the Traffic now connects. You should not need the Hotspot as well.

    On my GO6200 the above is what id required if the inbuilt Sim is not connecting to the TT servers. ..

    If you Turn your Phone Hotspot On then this allows your Phone to Share the data without the App. This is what makes me think you may not be running MyDrive on the phone.

    Doug
  • YamFazManYamFazMan Posts: 15,371 Superusers
    edited June 7
    Hi
    @CMHO

    On my GO 520
    Tap 4Dot (.... Menu) --> Bluetooth
    Add Phone
    _____________________

    (1)... Tap (?) Follow the on screen instructions to pair Bluetooth If required install & Sync the MyDrive App on the Phone
    Or
    (2)... (Scroll up to... If your not interested in using the 'MyDrive App' and its features)
    Note the next page of info is off the bottom of the screen
    Tap Not interested in all of theses features

    On Most of my devices (And when using my Windows Phone, no MyDrive App for Windows Phones)

    I use Option (2)
    ______________________

    On the iPhone with Bluetooth turned on
    Tomtom GO 520 appears under Other devices
    Tap the offered Tomtom GO 520
    Agree to 'Pair' on both devices
    If required Agree to Allow Contacts & Favourites to sync
    Tap Done

    irl40hoj48xf.jpg
    rlco4je8zqth.jpg
    Live Traffic over Bluetooth
    bzv4gephk6fb.jpg

    ATB YFM
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    edited June 10
    DougLap wrote: »
    Hi @CMHO

    Could you check the following please whilst out of range of your Wifi.

    Tap Menu
    Tap Settings
    Tap Bluetooth
    Tap The Paired Phone

    Do you have an option Data for Traffic and other services Selected ie Blue

    Have you got the MyDrive App open on your phone whilst you are driving. It can be in the background but is required for this to work. If not turn it on and then see if the Traffic now connects. You should not need the Hotspot as well.

    On my GO6200 the above is what id required if the inbuilt Sim is not connecting to the TT servers. ..

    If you Turn your Phone Hotspot On then this allows your Phone to Share the data without the App. This is what makes me think you may not be running MyDrive on the phone.

    Doug

    I did everything you said. About the option "Data for Traffic and other services Selected". Yes, it's Blue, but "Unable to connect". I tried turning it on/off, there is no corresponding Bluetooth pairing line on the iPhone. On the contrary, On the road, the "Unable to connect" changed to "Connecting..." at all time.

    I tried on/off for Hands-free calls and Smartphone messages, they can change and "connected" within a few seconds. At the same time, the iPhone's Settings>Bluetooth has 2 lines of TomTom 520 turning Connected respectively.
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    YamFazMan wrote: »
    Hi
    @CMHO

    On my GO 520
    Tap 4Dot (.... Menu) --> Bluetooth
    Add Phone
    _____________________

    (1)... Tap (?) Follow the on screen instructions to pair Bluetooth If required install & Sync the MyDrive App on the Phone
    Or
    (2)... (Scroll up to... If your not interested in using the 'MyDrive App' and its features)
    Note the next page of info is off the bottom of the screen
    Tap Not interested in all of theses features

    On Most of my devices (And when using my Windows Phone, no MyDrive App for Windows Phones)

    I use Option (2)
    ______________________

    On the iPhone with Bluetooth turned on
    Tomtom GO 520 appears under Other devices
    Tap the offered Tomtom GO 520
    Agree to 'Pair' on both devices
    If required Agree to Allow Contacts & Favourites to sync
    Tap Done

    irl40hoj48xf.jpg
    rlco4je8zqth.jpg
    Live Traffic over Bluetooth
    bzv4gephk6fb.jpg

    ATB YFM

    Thanks. One of your screen showed that the "Data for Traffic & other services" are "unable to connect". Mine too, except on the road, it changed to "Connecting..." at all time.

    Hotspot gives Live Traffic within a minute.
  • bigbig Posts: 1,574 Superuser
    CMHO wrote: »
    One of your screen showed that the "Data for Traffic & other services" are "unable to connect". Mine too, except on the road, it changed to "Connecting..." at all time.
    That picture was likely taken at home, where the TomTom presumably is connected via WiFi. When a Wifi connection exists it is used in preference to the bluetooth connection so in that case the TomTom will indeed say it is unable to connect to the phone.

    The quickest way to solve connection problems with an iPhone is to delete all the existing GO520 connections from the phone and the satnav, restart both, and then try to pair again. It doesn't always work, but it most often does.
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    edited June 12
    big wrote: »
    CMHO wrote: »
    One of your screen showed that the "Data for Traffic & other services" are "unable to connect". Mine too, except on the road, it changed to "Connecting..." at all time.
    That picture was likely taken at home, where the TomTom presumably is connected via WiFi. When a Wifi connection exists it is used in preference to the bluetooth connection so in that case the TomTom will indeed say it is unable to connect to the phone.

    The quickest way to solve connection problems with an iPhone is to delete all the existing GO520 connections from the phone and the satnav, restart both, and then try to pair again. It doesn't always work, but it most often does.

    Yesterday I tried the way you suggested. I reset the GO520. I restarted iPhone. I paired them ok. Bluetooth Hands-free Call and Smartphone Messages were connected easily. But the same problem with Data for Traffic& other Services, OUTDOOR, 10 km in 30 minutes, Connecting. Life Traffic? Still not available. I guess it's the poor TomTom Service on the server (cloud) side in Australia. Or my GO520 previously used on another email address? I don't know. TomTom keeps their silence.
  • DougLapDougLap Posts: 3,443 Superuser
    Hi @CMHO

    As you have mentioned you have changed email address I suggest you contact Customer Support and get them to check your account settings to make sure Traffic etc are authorised

    Doug.
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    DougLap wrote: »
    Hi @CMHO

    As you have mentioned you have changed email address I suggest you contact Customer Support and get them to check your account settings to make sure Traffic etc are authorised

    Doug.

    I did, even before posting here. The cust support told me to factory reset the GO520. Their instruction to do backup didn’t work, and later told me it’s automatically backuped in their cloud, which I could not recover because I needed to use another email. TomTom supports didn’t know what they were doing.
  • DougLapDougLap Posts: 3,443 Superuser
    edited June 12
    Hi @CMHO

    Okay. If you want to recover all your previous data then can you tell us if you can still log into your old email account on My Drive because TT have not yet deleted it. If you can then have a look a tYamFazMan's posts that explain how you can save your My Places and then you can restore it to your unit in the new account.

    Now that your unit is logged into the new account did they confirm that Traffic was set up okay at their end..

    Can you try and see if you can connect it to your phones Hotspot and see if traffic will work then.

    Doug
  • DougLapDougLap Posts: 3,443 Superuser
    edited June 12
  • YamFazManYamFazMan Posts: 15,371 Superusers
    edited June 12
    Hi
    @big
    @CMHO

    To end the confusion with my previous post I have repeated the process

    On my GO 520
    Tap 4Dot (.... Menu) --> Bluetooth
    Add Phone
    _____________________

    (1)... Tap (?) Follow the on screen instructions to pair Bluetooth If required install & Sync the MyDrive App on the Phone
    Or
    (2)... (Scroll up to... If your not interested in using the 'MyDrive App' and its features)
    Note the next page of info is off the bottom of the screen
    Tap Not interested in all of theses features

    On Most of my devices (And when using my Windows Phone, no MyDrive App for Windows Phones)

    I use Option (2)
    ______________________

    On the iPhone with Bluetooth turned on
    Tomtom GO 520 appears under Other devices
    Tap the offered Tomtom GO 520
    Agree to 'Pair' on both devices
    If required Agree to Allow Contacts & Favourites to sync
    Tap Done
    _________________________

    Edit...
    Wi-Fi is definitely TURNED OFF
    I am not using the MyDrive App
    Just a simple Bluetooth Connection

    3oiohmablncj.jpg
    My iPhone showing as connected
    konqtpylckos.jpg
    I have no Idea why the 'Data for Traffic & other services'
    Was showing as could not connect in my first post ???

    I am not using the MyDrive App
    Therefore 'Smart-Phone Messaging' is unable to connect

    p486878s3ubp.jpg
    Live Traffic over Bluetooth
    kce5yr0jdli3.jpg
    ATB YFM
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    DougLap wrote: »
    Hi @CMHO

    Okay. If you want to recover all your previous data then can you tell us if you can still log into your old email account on My Drive because TT have not yet deleted it. If you can then have a look a tYamFazMan's posts that explain how you can save your My Places and then you can restore it to your unit in the new account.

    Now that your unit is logged into the new account did they confirm that Traffic was set up okay at their end..

    Can you try and see if you can connect it to your phones Hotspot and see if traffic will work then.

    Doug

    Thanks Doug. I already input some addresses to My Places so not bother to restore. But it's good to hear that they are now in the TT cloud, though I am not comfortable about the privacy issue.

    Yes, my GO520 is now logged into the new account after factory reset. Traffic doesn't work. Tried whole night.
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    Data for Traffice is still "Unable to connect". The iPhone Settings > Bluetooth has 2 TomTom GO 520 entries under MY DEVICES; none under OTHER DEVICES.

    Today, on the road, Hotspot connection didn't give Live Traffic in the 2 hours drive. There was none. No matter it's under Hotspot or purely Bluetooth. No traffic info. That's Sydney everywhere.
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    I also tried adding another iPhone, but not syncing Contacts and Favourites. It's the same, i.e. the Live Traffic doesn't work. It's always Connecting... or Unable to Connect.
  • VikramKVikramK Posts: 8,345 TomTom Moderator
    edited June 14
    Hi CMHO

    Have you tried pairing your TomTom with a different phone model just to see if the problem is related to the Bluetooth..

    From our end, I see that the services are active.

    I will send a heads up to our customer service.

    Regards
    Vikram
  • CMHOCMHO Posts: 9 [Apprentice Seeker]
    Yes, I have different iPhone models, though no latest.
Sign In or Register to comment.

Who's Online31

Bembo
Bembo
dhn
dhn
kumo
kumo
Oskar-2
Oskar-2
Red-Zeppelin
Red-Zeppelin
Tanina
Tanina
Tubi56
Tubi56
+24 Guests