Rider 550- Bluetooth issues

ChillingbikerChillingbiker Posts: 2 [Apprentice Traveler]
edited January 27 in RIDER
Having problems with this TomTom rider 550
im using an iPhone 5se and scala rider q3 head set and using 02 network
i can get live traffic to work but when it comes to getting Siri to work well
thats just not happening
2 weeks ago traffic was working with help from TomTom advice
so I ask for help to get Siri to work
this week got Siri to work but no live traffic
everything is showing connected i.e. Bluetooth,4g
but traffic was still trying to connect
so when I parked up I turned off unit and phone and tried again
this time got traffic to work but no Siri ????
ive tried connecting TomTom 5/6 times with these 2 problems
and all I get back is how to connect phone with Bluetooth
will ive done this and still have problems
i owned the TomTom 450 and had no problems
so when this new rider 550 come out thought wow this looks brilliant
so I brought it from TomTom and had these 2 problems which I just can't seem to get working properly

any help

Comments

  • smudger64smudger64 Posts: 39 [Renowned Wayfarer]
    I brought a 550 and had the same issue. Just spoke to them and its a 'known problem'. No indication as to when its going to be fixed so its going back.

    You say you had a 450 and that worked ok? Were you able to connect both Bluetooth channels ok? I may just downgrade to that.
  • ChillingbikerChillingbiker Posts: 2 [Apprentice Traveler]
    Hi their
    With my rider 450 I have both channels working
    I'm debating on returning the 550
    It's a shame cos it's so quick and if they do get the software issue fixed it will be a good unit would be really cool to be able to use siri has well but at the moment so many issues need to be fixed
  • Kipper KendallKipper Kendall Posts: 10 [Legendary Explorer]
    I've shared this with others and it's sorted things

    Try a fresh start.

    https://en.discussions.tomtom.com/rider-51/rider-550-not-connect-sena-20s-and-iphone-1036323
  • JosseJosse Posts: 4 [Apprentice Traveler]
    Same thing : 400-Series worked well, 550 is a nightmare. Impossible to connect Iphone.
  • jyorkejyorke Posts: 4 [Apprentice Traveler]
    Hi All,
    Has anyone experiencing the following.
    I have just purchased a 550 (upgraded my 400) turned it on, bluetooth to my phone (P20 Pro) and scala q3 headset no issues, brill, happy man...
    UNTIL I power off the 550. Set the cradle up on my motorbike with the ignition, everything good, tested, bluetooth failed to connect to my phone.
    Phone thinks it is connected, the mydrive app has a red cross (not connected) on the 550 seeing bluetooth bouncing "connected" "not connected".
    After resetting bluetooth on phone, 550 and app. All connected again, but when turning off the 550, turning back on bluetooth fails to connect.

    I can't keep defaulting my bluetooth on my phone and 550 then having to re-learn everything headset, phone etc... nightmare.

    Thanks

    James
  • Triumphtiger98Triumphtiger98 Posts: 2 [New Seeker]
    edited March 1
    Hi i am also pi**ed about the new 550 i have tried to connect my sena 20s evo and my iphone 6s and rider 550 so i can listen to spotyfy, anwer a call and hear voice command from the rider 550 now the support say thats not posible beacause the my drive app doesen´t support that.Or is there someone here who has a different oppinion.
  • jyorkejyorke Posts: 4 [Apprentice Traveler]
    Just to keep you all in the loop,
    I have now tried 3 smartphones
    Sony Xperian Z5
    P20 Pro
    Mate 10 Lite

    Both P20 Pro and the Sony fail to reconnect after the first initial BT connection. I have to power off the Sony and to erase the BT settings from my P20 Pro and then add the P20 pro to the 550 until I power off the 550, then have to repeat this every time.
    However the Mate 10 lite (also made by Huawei) works every time without fail.
    I have requested additional help from Huawei to look at the p20 Pro, but I am not getting anywhere from TomTom.

    Come on TomTom support, can you give us some clues what the issues are?
    The Rider 550 is not a cheap satnav, without BT connectivity the main features for this it becomes rather useless.

    Please Support can you update us on the BT problems?

    THanks

    James
  • nospoonnospoon Posts: 1 [Apprentice Seeker]
    Same issue here, it's not reconnecting after being powered down. It's rather shocking that TomTom don't seem to be interested at all in fixing such a major issue. If I knew this beforehand I'd probably consider getting a different nav, from some company that gives a sh**.
  • RoadRiderRoadRider Posts: 170 [Exalted Navigator]
    edited April 18
    Welkom to the wonderful world of Bluetooth. ;)

    Many Phones have trouble with the new Bluetooth low energy connection the Rider 5x0 uses. Most Fitness trackers also use Bluetooth low energy and have the same problems with these phones. Searching the internet for solutions with these trackers for your Phone type can point you to the solution for your rider.

    As a alternative solution you can also pair the Rider 550 the Rider 4x0 way. To do so, do not use the pairing option in the MyDrive App. And setup Bluetooth tethering on your Phone. (sorry just like the Rider 4x0 no Sire or Google Now this way)

    (Many Phones also do not clear the hidden Cache. Searching the internet how to reset the hidden Cache or a full recovery for your phone solves many BT problems)
  • beemerbrucebeemerbruce Posts: 3 [Apprentice Traveler]
    I have a similar problem when my phone has wifi on. Now I turn off the phone's wifi before turning on the TomTom 550 (or waking it up from "sleep"). It connects reliably as long as the phone's wifi is off.

    Phone is a LG G7 Thin Q. Headset is a Sena 20S.
  • botherasbotheras Posts: 2 [Apprentice Traveler]
    I've just bought a 550, found this issue between my Nokia 8.1 and Sena/Shoei Neotec 2 system... Appears to be OK providing the phone is off WiFi before the 550 is switched off
  • smudger64smudger64 Posts: 39 [Renowned Wayfarer]
    Anyone got anything from Tomtom about a fix for this? I'm currently arguing for a full refund. They sell the 550 specifically as integrating with Siri. It doesn't. Better of to simply use the money to update to a new waterproof iphone and use tomtom on that
  • coullie411coullie411 Posts: 1 [New Traveler]
    Just used the 550 on first trip, no traffic updates, just filling stations and camera warnings, bit of a pain when you've spent all this money. Would think Tom Tom have an obligation to fix it or refund
  • smudger64smudger64 Posts: 39 [Renowned Wayfarer]
    Well I'm getting the run around from them so have just sent this message.

    'Hi
    I haven’t heard anything from your technical department.
    Since this issue is clearly NOT related to my device and is down the current software build (as admitted by your e-mail to me and is attached), you are obliged to offer me a full refund under EU regulation.
    This is for the following reasons;
    1 the Tomtom rider is specifically marketed as being designed to work with an iPhone
    2 I notified you within 28 days of purchase that there was an issue
    3 you informed me by e-mail that the issue is known to you and affecting other units
    4 you advised me you were working to fix it as a priority
    5 I have again raised the issue with you and have so far not received a satisfactory outcome. This is after giving you an excessively reasonable amount of time to rectify the fault.

    My next step will be report you to my local Trading Standards Office if I haven’t received a full refund within 7 days. This is because you have failed to protect my rights under EU regulation. You are also still marketing a defective product and making false claims about its functionality.

    I have retained a copy of all of my communications with you.

    Please be as kind as to escalate this to the correct team and not attempt to suggest further delays to my receipt of a full refund.

    Thank you '



    I'm getting a little bit irritated now.
  • TidusTidus Posts: 34 [Master Explorer]
    the rider from 400 version at least had a issues with bluetooth connectivity.. the buyers have been reporting them and requesting a solution and never have been solved.. for this reason I have returned/sell my riders (400 and 450) and as I can read now the 5xx haven't been solved at all..

    Sorry to told you this but, didn't expect to have it solved.. I accepted it.. but after I got a ticket because I was not aware of a radar.. I decided to sell it..
Sign In or Register to comment.

Who's Online47

bastle
bastle
capi59
capi59
Justyna
Justyna
Mickthefish
Mickthefish
Test9
Test9
+42 Guests