"An error has occurred" updating my XL's

iras Registered Users Posts: 4
Master Traveler
I'm trying to update both of my XL350's I get the same error on either one


Since it happens on BOTH of my XL's, I don't believe it has anything to do with the XL itself. I've tried uninstalling and reinstalling the Home software and get the same error. Both XLs work just fine, and I was able to update the maps with the previous update last quarter.

There's an article that talks about wiping the Tomtom and reloading everything, but there's nothing wrong with the Tomtoms - If the error was only on one of them then I'd believe the article.



  • kylegp
    kylegp Registered Users Posts: 2
    New Traveler
    Same issue for me with my Go 750. GPS signal also stopped working after the last update but support tells me to update via TomTom Home, which I can't do because I get this same error.

  • Karl_Z
    Karl_Z Registered Users Posts: 14
    Legendary Explorer
    Hi, @iras... I am getting the exact same error on my XL340, and I have tried formatting my device and reloading from scratch... no luck there, and now I have to rebuild my favourites list since that go wiped out (including the backup) during re-installation. So I'm also pretty certain it's a server-side issue at this point.
  • iras
    iras Registered Users Posts: 4
    Master Traveler
    I called Tomtom support. BIG MISTAKE. They had me delete the current map on the device, then load in a new map. EXCEPT - the new map of the US is now broken into about 6 zones, and you can only load in 1 zone - even though 5 of the 6 zones would fit easily on the device. So now instead of having the entire US on my device, I have about 10 states. I'd have rather had a map that was 3 months old instead of what they left me with. Horrible support - no warning that I would lose 3/4+ of the country.