CarPlay released, but not working? — TomTom Community

CarPlay released, but not working?

daletowedaletowe Posts: 43 [Renowned Wayfarer]
So I happened to update my apps on my iPhone, and noticed the new version of TomTom GO, with .... wait for it ... Apple CarPlay support was there and ready to download!

Hallelujah.

Good things come to those who wait (even if they wait extremely impatiently, with good reason).

Did the update, opened the App, followed the "new features" guidance, let it download an updated map, and excitedly went to Settings on my iPhone to move the "new" TomTom GO to the main CarPlay screen....

Except ... its not there. FAIL. sigh. Not really sure what I expected. A working App? Maybe? Too good to be true.
Tagged:
«1

Comments

  • RustlentomRustlentom Posts: 1 [New Seeker]
    The blue sea shading disappears when you zoom in.
  • JürgenJürgen Posts: 5,673
    Community Manager
    daletowe wrote: »
    Except ... its not there. FAIL. sigh. Not really sure what I expected. A working App? Maybe? Too good to be true.
    The app should be on the second screen.

  • JürgenJürgen Posts: 5,673
    Community Manager
    Rustlentom wrote: »
    The blue sea shading disappears when you zoom in.
    You need to install the map for ferry connections.
  • StuBFrostStuBFrost Posts: 9 [Master Explorer]
    I'm a beta tester and just installed the new version and also only have the beta version showing in CarPlay and not the new one (based on the icons)
  • JürgenJürgen Posts: 5,673
    Community Manager
    StuBFrost wrote: »
    I'm a beta tester and just installed the new version and also only have the beta version showing in CarPlay and not the new one (based on the icons)
    The app with the new icon comes as an update to the GO Mobile app. It's a staged roll-out so only a small number of users gets it offered right now. The rest to follow soon.
  • StuBFrostStuBFrost Posts: 9 [Master Explorer]
    Jürgen wrote: »
    StuBFrost wrote: »
    I'm a beta tester and just installed the new version and also only have the beta version showing in CarPlay and not the new one (based on the icons)
    The app with the new icon comes as an update to the GO Mobile app. It's a staged roll-out so only a small number of users gets it offered right now. The rest to follow soon.

    That's not what I meant. I downloaded the new Go app (v2) and as the apps are separate I should have 2 icons in CarPlay one for the beta and one for the new app but I only have the beta,
  • loekfloekf Posts: 30 [Prominent Wayfarer]
    edited June 2019
    Hopefully TT reads this thread. Not sure about the other one.

    Maps download for some countries is broken. For example: Spain (all regions), Switzerland, Russia (only one works) and there are more (specially SE/E Europe). They all return error 10106.

    Maps look about twice as big as for the old versions. Think Western Europe was 10-12 GB. Now you easily get > 20 GB.
  • daletowedaletowe Posts: 43 [Renowned Wayfarer]
    Jürgen wrote: »
    daletowe wrote: »
    Except ... its not there. FAIL. sigh. Not really sure what I expected. A working App? Maybe? Too good to be true.
    The app should be on the second screen.

    Nope.
  • daletowedaletowe Posts: 43 [Renowned Wayfarer]
    loekf wrote: »
    Hopefully TT reads this thread.

    I *highly* doubt that.
  • daletowedaletowe Posts: 43 [Renowned Wayfarer]
    daletowe wrote: »
    So I happened to update my apps on my iPhone, and noticed the new version of TomTom GO, with .... wait for it ... Apple CarPlay support was there and ready to download!

    Hallelujah.

    Good things come to those who wait (even if they wait extremely impatiently, with good reason).

    Did the update, opened the App, followed the "new features" guidance, let it download an updated map, and excitedly went to Settings on my iPhone to move the "new" TomTom GO to the main CarPlay screen....

    Except ... its not there. FAIL. sigh. Not really sure what I expected. A working App? Maybe? Too good to be true.

    So the fix for this is to re-start your iPhone. This had crossed my mind, but as I've never had to do that before to get an App to work, I didn't bother trying, until someone else pointed it out as the fix.

    Will try it out "on the road" tomorrow.
  • bertiebear99bertiebear99 Posts: 1 [Apprentice Seeker]
    Hi How do i get the route bar onto carplay screen when navigating? Also how do you enter addresses on car screen? Thanks
  • PalfermanPalferman Posts: 113 [Supreme Trailblazer]
    The route/traffic bar just isn’t there, thanks tomtom it was the only thing that was useful. I wouldn’t bother trying to enter addresses on car screen either just do it on the app before you leave
  • DougLapDougLap Posts: 6,338
    Superuser
    edited June 2019
    HI @bertiebear99

    The route bar does not appear in CarPlay mode. The cameras etc usually visible in the Route Bar are visible along the route and with Read Aloud Set are announced well in advance. If you create the route before you get in the car then the destination is in the Recent Destinations. In CarPlay Mode Tap the screen and a menu page appears. select Recent Destinations and select from the ones you prepared earlier.

    Doug.
  • PalfermanPalferman Posts: 113 [Supreme Trailblazer]
    As @DougLap rightly points out the cameras are indicated on the route map and are announced in advance if you’ve correctly set up the app. It’s just the traffic that’s worrying me. I need to check this
  • DougLapDougLap Posts: 6,338
    Superuser
    Hi @Palferman

    If you open the App you will see the Traffic in Red on the map as you see in Mydrive and on a PND. Also when I used it this evening it was showing the Delayed traffic getting out of our Local Sainsburys car park and I think It signalled 2 mins at one point but I am not sure of that .

    Doug
  • PalfermanPalferman Posts: 113 [Supreme Trailblazer]
    Hi @DougLap
    Look I’ve got no problem with the new app, it is absolutely stunning. On my iPhone it looks superb, it’s just what I wanted no argument. Like I’ve said don’t want any clutter just decent navigation and in my opinion the best traffic I’ve ever seen. Just a bit disappointed with the CarPlay bit without traffic bar I can’t see what’s going on ahead. All I’m saying is that without that bar I don’t really know what it’s doing, it might just do it in the background if so great I’ll be signing up no issue. I just like to see what’s going on around me with traffic in the area so I can make my own decisions. For many years I’ve had tomtom start Xl and most recently a GO5000 they’ve got me out of trouble on so many occasions I’ve lost count. My circumstances change about a year ago and I retired, I used to have a company car but obviously that had to go and I had to get my own. So I did and the car I bought had a built in satnav, it was a Garmin and to be be fair the routing is really good and as a plus for some reason it has a subscription to tomtom traffic for 3 years trouble is it’s not as intuitive as the traffic on my GO that’s why I want tomtom back
  • DougLapDougLap Posts: 6,338
    Superuser
    HI @Palferman

    I think it looks good as well. The proof will be when we have had time to really test it. The cameras are easy to see and well announced which was more than Google did the other day when I tested it. I don't like loads of icons all over the screen but it will be good if and when we can search our Poi files and store routes in the app.

    Regarding the other make you mentioned I have had a Camper version of theirs for nearly 3 years. It has only just stopped sending me 23 miles for a 9 mile journey, Unfortunately whilst that bits sorted on its new route it still goes past a Turning and directs me through a Shopping parades car park before returning to the junction it passed. It has directed me into a cul de sac. Also the traffic is not as good.

    ATB

    Doug
  • Carrera911Carrera911 Posts: 3 [Apprentice Traveler]
    I have installed the V2.0 versie with Carplay. When using Carplay on my Alpine ILX-702D, everything works fine except no sound !

    I tried everything, but nothing. When I use Apple Maps or Google Maps the sound is on, but TomTom no sound...

    Anyone have this same problem or can give me a solution to put the sound on in the Carplay mode ?
  • DougLapDougLap Posts: 6,338
    Superuser
    Hi @Carrera911

    Sound works very well on my VW’s CarPlay unit. Very clear and any radio or music playback on at the time is auto turned down when the TT gives directions.

    Check the sound settings in the app work when not attached to a CarPlay unit. If that does not sort it turn the phone off and on to see if that resolves it. I could not get the app to work after I downloaded it until I had turned my phone off and on.

    Doug
  • JürgenJürgen Posts: 5,673
    Community Manager
    StuBFrost wrote: »
    That's not what I meant. I downloaded the new Go app (v2) and as the apps are separate I should have 2 icons in CarPlay one for the beta and one for the new app but I only have the beta,
    This is probably a conflict between the beta GO Navigation app and the GO Navigation app downloaded from the App Store. Before this you had GO Mobile next to GO Navigation.
  • JürgenJürgen Posts: 5,673
    Community Manager
    edited June 2019
    @daletowe
    I would like to understand what is happening here. Before I forward this, have you tried quitting the app and re-opening it?

    And which version of iOS do you have? 3rd party navigation on CarPlay requires iOS 12.
  • Carrera911Carrera911 Posts: 3 [Apprentice Traveler]
    edited June 2019
    Yes, phone off/on was the solution...thanks ! =)
    DougLap wrote: »
    Hi @Carrera911

    Sound works very well on my VW’s CarPlay unit. Very clear and any radio or music playback on at the time is auto turned down when the TT gives directions.

    Check the sound settings in the app work when not attached to a CarPlay unit. If that does not sort it turn the phone off and on to see if that resolves it. I could not get the app to work after I downloaded it until I had turned my phone off and on.

    Doug

  • Franz_RiderFranz_Rider Posts: 7 [Master Explorer]
    Why is not possible to see traffic information directly on the car display, but only in the smartphone?
  • daletowedaletowe Posts: 43 [Renowned Wayfarer]
    Jürgen wrote: »
    @daletowe
    I would like to understand what is happening here. Before I forward this, have you tried quitting the app and re-opening it?

    And which version of iOS do you have? 3rd party navigation on CarPlay requires iOS 12.

    Hi, as already discussed, the "fix" for this is to restart your iPhone. This has worked for me, and the App now appears. I think this is the 1st time I've had to restart my phone to make an App work in ... well, ever.
  • daletowedaletowe Posts: 43 [Renowned Wayfarer]
    Why is not possible to see traffic information directly on the car display, but only in the smartphone?

    I think Apple imposes some limitation on what you can and can't display. I think they are trying to keep the look and feel of navigation the same (as Apple Maps) pretty much whatever App you use, although there obviously is some flexibility. It would be nice (but obviously unthinkable) if TomTom could actually engage the user community on this. But Brexit will happen before this.
Sign In or Register to comment.

Who's Online in this Category0