Live services not working. — TomTom Community

Live services not working.

Purchased October 2018. Roll over update done. In TomTom Home it is asking to purchase . Help urgently need access. Thank you
Tagged:

Answers

  • PempacatPempacat Posts: 8 [Neophyte Traveler]
    Getting error code 148. Unable to soft reboot - no drum roll.
  • PempacatPempacat Posts: 8 [Neophyte Traveler]
    edited June 2019
    PS Order number 40xxxxxxxx

    Mod edit: Please do not post any information on a public forum!
  • VikramKVikramK Posts: 11,155 Moderator
    edited June 2019
    Hi @Pempacat

    Welcome to the community!

    Just reviewed your account and the subscription. I see you already have an existing one for LIVE Services which is active will the first week of November 2019(Device serial no ending 581)

    Although the new order you placed will only extend your current subscription by another year. If you wish then contact customer service to get a refund on your recent order.

    With regards to LIVE Service not working I would recommend that you try the troubleshooting steps on this FAQ:

    https://uk.support.tomtom.com/app/answers/detail/a_id/10316

    Regards
    Vikram :)
  • PempacatPempacat Posts: 8 [Neophyte Traveler]
    Dear Vikram, thank you for taking the time to reply. I was at my wits end hence the panic buying, thinking maybe that would help. I will contact customer services as you suggest. Would you be able to provide the correct email address?

    I would however really like my live services back ....... I have been through the process on the link you kindly sent previously - but no joy. I am currently out of the country but while travelling to the airport although live services attempted to load it had a different error and then asks me to sign in with email and password. This then failed. This has been happening for months. Would a restore to factory settings potential help or just create a bigger problem? yours hopefully P.Cat.
  • PempacatPempacat Posts: 8 [Neophyte Traveler]
    Dear Vikram, I have checked my TomTom account on line and it says: "We could not find any installed service for your device". However, as you confirm I do have a subscription that is live. What do you advise?
    Thanks!
Sign In or Register to comment.

Who's Online in this Category1

JaxxKY
JaxxKY