SERVER BUSY - TomTom MyDrive Connect application OUTAGE!!!! - Page 4 — TomTom Community

SERVER BUSY - TomTom MyDrive Connect application OUTAGE!!!!

1246

Comments

  • brightjackbrightjack Posts: 0 [New Seeker]
    I kept getting this error when updating my device.

    Our servers are very busy right now
    Click Retry a few times until you are connected. If that doesn't work, close MyDrive Connect and start it again.


    I have a lifetime map included device, and it is EOL, but on MyDrive I can still see v10.25 map version is available to me, but "servers are very busy" happens when I update...
  • paulakparkerpaulakparker Posts: 2 [Apprentice Seeker]
    Over the last few weeks, I have tried multiple times to update my device using the MyDrive Connect. After several minutes, I get a message that there was a problem and to click retry several times and try again.

    The TomTom support page on their website says, "You may be currently experiencing issues updating your device using MyDrive Connect. We are working on a fix with high priority."

    Any idea when this will be resolved?
  • ZsoltZsolt Posts: 36,007 Superusers
    Seems like there is a general issue (https://uk.support.tomtom.com/app/home) and not related to your device in particular.
  • xwintechxwintech Posts: 78 [Supreme Navigator]
    Hi, paulakparker!
    74a4kr4ai4nf.png
    3e731hp4pmwb.png

    It seems like you are not alone here, I am experiencing this issue too. But you may try this steps and see if it works.
    1. Uninstall MyDrive Connect using RevoUninstaller (https://revouninstaller.com)
    2. If you are using Windows then:
    2.1 Open Run (Win+R)
    2.2 Type %temp% and press Enter
    2.3 A folder will open, select all (CTRL+A) and delete everything (SHIFT+DELETE)
    If some folder or files don't get deleted then skip them
    3. Reboot the computer
    4. Download and install MyDrive Connect (https://www.tomtom.com/en_gb/mydrive-connect)
    5. Sign in to your account and connect your navigation device
    6. Try to update your device

    If the option above worked, mark this as an answer, thanks!
  • YamFazManYamFazMan Posts: 15,796 Superusers
    edited May 2019
    Hi
    @brightjack

    Firstly try Logging OUT of MyDrive Connect (Screen Top Right) then log back in again with your Credentials... Simple but it has worked for some users

    On the rare occasions that I have a problem with MyDrive Connect
    I Un-install MyDrive Connect using the Revo Uninstaller (Windows PC )
    There must be a equivalent Deep un-install program for a Mac

    Download & install the free version of Revo Uninstaller
    Revo first Un-installs the Program... Then scans and removes all of the left over files a normal Un-install leaves behind
    Here...https://www.revouninstaller.com/revo_uninstaller_free_download.html

    (1)... Uninstall MyDrive Connect Using the Revo Uninstaller
    (2)... Clear your browsers cache (Optional, but I find it helps)
    (3)... Restart your PC (Not Turn Off & Turn On again)
    Reinstall MyDrive Connnect (Without your device connected)
    Connect & Turn on your device... Login to MyDrive Connect

    ATB YFM
  • EPICURIOSEPICURIOS Posts: 0 [Apprentice Seeker]
    WHY are your servers ALWAYS down !!!?
  • LAURE123LAURE123 Posts: 1,444 Superuser
    edited May 2019
    Hi @EPICURIOS

    If you use MyDrive Connect software.
    At the moment there are known problems with Tomtom servers. See here:
    https://discussions.tomtom.com/en/discussion/comment/1644775/#Comment_1644775

    You can try this:
    At first, with your device not connected to the PC:
    1/ In the MyDrive Connect (MDC) window at the top, to the left of the gear wheel (Settings), click on "Log out".
    2/ close the MDC window, right click on the MDC icon in the taskbar next to the clock, choose "Quit"
    3/ Open Windows "Task Management" and check if there is still a MDC process to kill it.
    ==> In your taskbar / Right-click in any open place / Task Management / "Processes" tab / if you find "TomTom MyDrive Connect.exe * 32" ==> Right-click / "End Process"
    4/ Open MDC again and "Log in", enter your email and password.
    5/ Try again to download an update.

    If it doesn't work, with your device Not connected to the PC:
    1/ Uninstall MDC, accept the removal of downloads in the popup window.
    2/ "Restart" your PC (Not Shut down or Sleep)
    3/ Download and install the last version MDC, take it here, at the bottom, the green button "Download for ... ":
    https://www.tomtom.com/en_gb/mydrive-connect/
    4/ Try again to download an update.

    I hope that one of the two proposals will work for you.

    Regards.
  • StuartDonaldsonStuartDonaldson Posts: 1 [New Traveler]
    the server is busy, try again. for a week?
  • StuartDonaldsonStuartDonaldson Posts: 1 [New Traveler]
    why can I not update? Server busy try again - for a week?
  • PaulRosePaulRose Posts: 1 [New Seeker]
    Much the same - same issues logging in but seem to have got through that. For the last five days unable to update 70kb QuickGPSfix file with servers very busy try again later message. I'm having to rely on my Garmin for now.
  • lindarobbins_2019lindarobbins_2019 Posts: 2 [Apprentice Traveler]
    I am the same - I have paid for the new 12 month subs last week and tried to update but have a message saying I need NAVCORE but cant find anything to upload and if I try to do without the NAVCORE I just get servers busy - FOR A WEEK NOW
  • QuinasQuinas Posts: 0 [Apprentice Seeker]
    Hello! I've been trying to download critical updates for my device for more than two weeks! Nothing. The same message always - our servers are very busy right now. I'm using the latest version of MyDrive Connect still I'm unable to do it while my device stopped seeng the GPS signals after April 6. Please advise.
  • Mousie05Mousie05 Posts: 3 [New Seeker]
    Seems to me that it's Repeat Repeat Repeat of info I've done most of all this and I can't get my SAT NAV working at all! I need it for a journey this week I've been trying this since after April on and off It's a nightmare !!! Please Help
  • DougLapDougLap Posts: 3,966 Superuser
    HI @Mousie05

    Have you tried a Factory Reset of the GO Basic if thats the unit you are referring too.

    Doug
  • Mousie05Mousie05 Posts: 3 [New Seeker]
    Hi Douglap

    Now on my tom tom screen its saying if the problem still occurs visit tomtom.com/support and search for 'No maps found' I can't see Factory Reset
  • Mousie05Mousie05 Posts: 3 [New Seeker]
    Sorry DougLap

    Mine is a Start 25
  • isabelvisabelv Posts: 0 [New Seeker]
    edited May 2019
    I have tried on sevral occasions to update my Tomtom start 25 on 'My Connect' but it repeatedly tells me to 'retry' as the 'sever is very busy'. Is it always busy? Please help.
  • tartangraemetartangraeme Posts: 1 [New Traveler]
    Hi Folks,

    had the same problem.
    tomtom via 62 connected to pc = ok
    When updating process started connection went broke and via 62 says "no map available."
    No connect possible.

    No update process startable.
    Took me 3 days to figure this one out.
    Nothing wrong with tom tom servers.

    Windows 10 deactivated a driver, after reactivating Update started straight away.

    include Foto of Driver.

    worked for me.

    Tartangraeme

    qwk1mverif0s.jpg
  • rebbyvidrebbyvid Posts: 1 [New Traveler]
    i had the server busy problem just after my drive updated , deleted and reinstalled my drive and all is ok now =)
  • martnmartn Posts: 2 [Neophyte Traveler]
    Hi, I am told I have to do a fresh upload of Device OS and maps as there is a timing change with sats on 26th April. I have been trying to do the update for a month now but I just get an error that your servers are busy. I see on the support page banner that there is an update issue at your end which you are fixing "with the highest priority". Any news when your "Highest Priority" will result in a fix.
  • martnmartn Posts: 2 [Neophyte Traveler]
    Hi Thanks. I tried these approaches before but with the device connected - that was obviously the secret. I did quit MDC but also saw in Task Manager that it left a process still running. I killed this process in Task Manager, restarted MDC without the device, connected the device and everything worked - thanks
This discussion has been closed.

Who's Online in this Category0