Start 25 "waiting for a valid GPS signal"

indigojc
indigojc Registered Users Posts: 1
New Seeker
edited December 2021 in Devices using MyDrive Connect
Device updated today with all suggested updates Still not connecting to GPS. Clock will not sync.
My Tomtom drive says "your device is uo to date".

Plain, its not working!
jc

Comments

  • francesmx
    francesmx Registered Users Posts: 6
    Apprentice Traveler
    I'm in the same position (with a Start 60). Everything up to date. I've reset. Still no signal. Clock won't sync.
  • francesmx
    francesmx Registered Users Posts: 6
    Apprentice Traveler
    Okay mine is working now. I had to go fully outside the house, try and set a route, and eventually I got a signal after a few minutes. My clock is now synced.

    Check you've got the latest firmware on your device. If you've got 12.075 (I think that's right but double check for your device), you should be okay. If it's still not working, it looks like you might have to do a factory reset.
  • VikramK
    VikramK Administrators Posts: 14,537
    Moderator
    Yes..

    There have been cases where our customers have reported GPS issues on the NAV3 devices post 6th April 2019.

    If these devices have the firmware version 12.075 installed then just take the device outside under the open sky- Do a soft reset and try planning a route.

    It should be able to get the GPS signal.

    Regards
    Vikram