TomTom services connection trouble

Nolzuk Registered Users Posts: 2
New Seeker
Got my new Go620 just mainly because it does not need a computer to update. I have it connected to wifi ok but if i try to sign in on the device it just says
”Oops we are having trouble accessing TomTom services. Please try again later”
I have tried later so any suggestions??


  • LAURE123
    LAURE123 Posts: 1,632
    edited April 2019
    Hi @Nolzuk

    For the message 'Oops, we are having trouble ... etc' watch this video to help you.
    Factory Reset ==> Main Menu (4Dots....)/Settings/System/Reset device

    If your Wifi internet connection is too weak or unstable (TomTom devices can only uses a 2,4gHz Wi-Fi connection) you may need to use a computer only for the internet connection by installing before the software MyDrive Connect (MDC).

    In both solutions (Wifi or with PC), all the management and the launching of the updates are done in the device.
    ==> Main Menu (4Dots....)/Settings/Updates and New Items

    To connect to your TomTom account and register your new device, it's also in your device.
    ==> Main Menu (4Dots....)/Settings/My Drive/ your email and passworld

    For updates, don't do them all at the same time. The NaVCore first alone, then the map alone, then the speed cameras, etc...
    During the download if you use Wifi, connect your device to a power source, a main charger (2A smartphone) or a PC only for power (with MDC not active)

    For more information see this FAQ and video:

  • DougLap
    DougLap Posts: 9,959
    edited April 2019
    Hi @Nolzuk

    It may be a Server problem so keep trying from time to time. In the meantime you could try a Factory Reset and start again to see if that helps.

    Tap Menu
    Tap Settings
    Tap System
    Tap Reset Device.

    If this still fails to work and you are still having trouble then ring Customer Support. List of number here.


  • Nolzuk
    Nolzuk Registered Users Posts: 2
    New Seeker
    Thank you for the replies.
    My wifi connection is excellent so no problems there. The only reason I went for this model was so I could update over wifi.
    Already tried to reset the device with the same result.
    Interestingly if i try to create a new account with the same email address it does know the email is already registered which confirms a communication with the server. It just never lets me log in.
    I will continue to try as I suspect server issues as posted.

    Thank you all.