Map deleted by update; can't re-install. Very frustrated



  • fuentemeca
    fuentemeca Registered Users Posts: 8
    Master Explorer
    I have got other things to do with my life than spend it updating my TomTom so I have bought a Garmin. Fingers crossed!
  • hdale94
    hdale94 Registered Users Posts: 1
    Apprentice Traveler
    Hello. I tried to update the map on a TOMTOM GO LIVE 1005. The update broke the map, and it would not let me reinstall it. I tried all the tips I could find on these forums, and I tried using 3 different computers, but nothing happened. I was about to call TomTom support, when I thought i could try updating on a older OS than Windows 10. I connected the GPS to a Windows 8.1 Laptop and tried to update in MyDrive Connect. This time the update worked completely fine on the first try.

    So if you are having similar problems, try to update it on a computer with another OS than the one you currently have.
  • conehead
    conehead Registered Users Posts: 3
    Apprentice Traveler
    i agree to awful customer service. I bought a diff model 3 days ago still can't get any response as to how the problem can be solve. worst company to deal with and worst support...
  • dhn
    dhn Posts: 33,389
    Did you call?

    United States
    Monday - Friday: 9:00 a.m. to 8:00 p.m. EST
  • rudenotto
    rudenotto Registered Users Posts: 4
    Apprentice Seeker
    "Device not responding" and "map update failed"
    I have go live 5100 (lifetime map updates and lifetime live services) and use mydrive connect (latest version) with a MacBook pro. Tomtom device has SD slot but no card in there.
    Trying to load latest Europe map but get the "device not responding" every time.
    Have reset device, drumbeats and factory reset, loaded latest mydrive connect, emptied cache in tomtom home folder.
    Tried to load smaller Europe map without buildings but still failing. Very frustrated.
    Have read I can load smaller map by loading map zone but I don't get the option, just get options to free up memory, chose smaller map or insert card.
    Any ideas anyone? I have read many many discussions and see many other people have some frustrating problem but I cannot find a solution. Help!
  • dhn
    dhn Posts: 33,389
    Call support to assist:
    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • rudenotto
    rudenotto Registered Users Posts: 4
    Apprentice Seeker
    Update - spoke to support. Lady advised that reason device is not responding is because the antivirus settings are such that it considers a virus is present (as the update takes so long) and it stops communication between the device and mydrive connect. Tomtom consider that it is my responsibility to liaise with the internet provider (UK PlusNet for me) and configure the antivirus settings so communication is not stopped. This is not as easy as it seems, unless someone can advise otherwise. Anyway, as I have lifetime map updates worldwide, I convinced Tomtom to put a UK only map on my account, which they did and it loaded quickly and the device updated ok, so no more problems. If I wish to load a Europe map at a later date, I will have this issue again. Overall, pleased with Tomtom's resolution.
  • Vincent52
    Vincent52 Registered Users Posts: 2
    Apprentice Traveler
    I've fixed mine. It repeatedly crashed on download to my Win7 PC and left my Start25 with no maps. I googled the error code reported by the PC and tried changing everything it suggested, all to no avail. I must have re-started the MyDrive program 50 times gradually increasing the download by a few % each time. I finally got as far 100% but with a corrupted map and then it repeatedly crashed again. It had many attempts at downloading a map to the device but kept crashing.
    Finally I loaded a fresh install on a Win10 laptop and had a very slow but uninterrupted download only to find that the map was reported as corrupt again and would not download to my device but then for the first time MyDrive reported an error message saying the map was too big for my device and giving me the option to choose a smaller map. Once I selected that it updated without any problem.
    Why oh why can't the code be properly debugged so the Win7 version gives the same option?
  • rudenotto
    rudenotto Registered Users Posts: 4
    Apprentice Seeker
    Was it a large map which should be loaded onto a memory card? Or internal tomtom memory?
  • Vincent52
    Vincent52 Registered Users Posts: 2
    Apprentice Traveler
    It obviously was a large map but I was given no choices at the start of the procedure. The update process removed all map info from my device and left it useless. All it needs is some sort of intelligence at the start of the process to avoid the inevitable crash. MyDrive knows my device has only internal storage so why can't it determine at the outset whether the download will fit? Why just crash with no error message? Very poor.
  • Sofia12
    Sofia12 Registered Users Posts: 3
    New Seeker
    Another 2 days of the same. Been using TomTom since the beginning of it. It used to be a great company. Nowadays the website is slow, annoying and with constant loops. MyDrive counter intuitive. Well tomorrow another try for costumer support, hope the number still works, as it is well hidden on the website (Netherlands) . I am finally sick and tired of TomTom, they reached a level at which they are just "one of those" companies. Ofcourse this always happens when you need the device so much. This has been my last TomTom.
  • Sofia12
    Sofia12 Registered Users Posts: 3
    New Seeker
    Go 500. I have had my share of devices and issues through the years. Yes, I have done the whole flowchart again and again, even reinstalled the devices firmware and the pc "software". This is not good at all.
  • Sofia12
    Sofia12 Registered Users Posts: 3
    New Seeker
    Been using a different brand the past years for hiking, 2 devices. Switching my carnav too for better integration.
  • roy.styles_un38
    roy.styles_un38 Registered Users Posts: 1
    Apprentice Seeker
    I have had my GO 5000 since Feb 2015. Time again came to renewed my subs for European Speed Cameras, I checked my payment had been received, assumed it was OK to do the latest update and it was then everything hit the fan AGAIN!
    Previously, I've had all of the same problems as other users above but to my surprise it would miraculously update when I least expected it to! Does that ring a bell???
    This time I managed to phone TomTom but not much help there, however, later when I examined the SD Card I discovered that no way could I delete any of its contents (all TomTom stuff). It would appear to delete but when I re-checked it, ALL of the stuff I'd deleted was actually still there!
    I concluded that SD card had gotten corrupted during a former update so I got hold of and installed a new 32 SD card, updated my device and all's well again, BUT what the devil caused the problem with the SD card is a question I cannot find the answer to!
    ?Does anyone want to buy a GO 5000 because, due to frustration before trying the new SD card, I bought a Garmin ??
  • DougLap
    DougLap Posts: 10,057
    Hi @roy.styles_un38

    Difficult to say what has happened to your SD card.

    The folders you could see on the card were Tomtom's files which are written to the Card when the Tomtom has formatted it for Tomtom use. You cannot see what's in the files but they will contain maps or cameras etc. The only way to have deleted the folders would have been to Reformat it in your PC to Fat32 then reinstall it when the folders would return as its is formatted on the GO5000.

  • SF331
    SF331 Registered Users Posts: 12
    Master Traveler
    I had the same problem with my 6100, the only way to cure it was to format the sd card in windows, then install a small rubbich map to the tomtom. them nsert sd card into tomtom, format it in the tome tom then download UK maps onto the sd card. I have had to do this twice now. the second time the tomtom told me that the battery was run down after I un plugged it from the car and it switched itself off.
    TomTom this needs sorting, the problem wasn't there untime the update!
  • Robin_Banks
    Robin_Banks Registered Users Posts: 1
    Apprentice Seeker
    edited July 2019
    I have had the same problem, as described by many on this thread, struggling for 6 or 7 hours today to update my GO 6000 to European maps which won't fit on the device's internal memory.

    The good news is that I succeeded in the end, the bad news is that I did 3 things at the same time so not 100% sure which solution resolved the problem.

    Using a Windows 10 PC.

    I had just formatted a different SD card (a Sandisk 32GB card instead of the 16GB Samsung EVO that I had been using on my earlier attempts) but I doubt that it was this that resolved the problem.

    I also turned off Windows Firewall (more probably the solution)

    And I connected via a VPN (Express VPN) thereby effectively bypassing my Netgear router's Firewall. (Also a probable solution)

    I expect that it was one or other or both of these Firewall changes that resolved the issue.

    Leaving at 5am tomorrow morning for a 3 week road trip around Europe so you can imagine the terror that was running through me of having a TomTom paperweight to guide me for the duration! (Or the more likely solution of having to shell out €200+ for a new Garmin)

    If it is the VPN that has made the difference rather than just the Windows Firewall I can suggest to people that there are some free options available and also some paid services that offer short term free trials that would be enough to get your maps updated.

    Hope this helps.
  • sickbunny
    sickbunny Registered Users Posts: 2
    Apprentice Traveler
    I had the same issue where the maps was wiped from my TomTom Go500 and when trying to update the aus map, the download would reach 59% then rolled back to 57%.
    After deleting the %localappdata%, I opened MyDrive Connect. It automatically continued to try to download.
    WAIT for the failed to download error msg window.

    Select "Network settings", under the CONNECTIONS tab select the second option "Use System Settings"
    Type in your normal username and password for logging into your internet - example: Im with iiNet and I typed in my username and password like I was logging into my iiNet account.
    MyDrive Connect will restart - log in and WAIT.

    The download automatically continued from where it left off and my 57% download was still stuck but then my download began to continue to 60% and then went all the way, then after the 100% download, my TomTom was updating and was successful in reaching 100%.
    I got my TomTom back

    I really hope this works for whoever reads this as it worked for me.
  • Ludit
    Ludit Registered Users Posts: 2
    Apprentice Seeker
    Spent two days trying to reload the uk map, after udate. It is now ruined and does not work. Fails at 91% each time. There are two options now a repair company and a plastic bag and a brick hammer
  • YamFazMan
    YamFazMan Posts: 21,169
    Welcome to the site....
    GO 20 ??? I can find a Start 20....
    What are the 1st 2 characters of the serial number of your device ??? The two letters define the Tomtom Model....

    Stay Safe... ATB YFM
  • ArdaAlpVia135
    ArdaAlpVia135 Registered Users Posts: 6
    Apprentice Traveler
    "Corrupt map\ Update freezing and getting stuck & unable to install any EU map"

    Last time, when I update my TomTom via 135 (with life time EU map support) my device says no map loaded but when connected to my drive it says corrupt map.

    Namely, each time, after chosen EU map dowloaded to PC during the installation phase either the operation stoped via error message ("Something has gone wrong. Check your computer for more information") or the processing suddenly jump from 3-5% to 100% then fails with error message or 'update success' prompt but nothing being installed, still TomTom mentions 'no map installed' and MyDriveConnect says map file is corrupted.

    I have tried everything recommend on this subject such as: uninstalling & installing MyDriveConnect software; deleting all folders including cache folder (I also tried to re-download the map by clearing the cache folder); OR logging out and logging back into the software; OR close& restart the software itself and softboot as well as reinstall the Via 135 by 3 times pressing the powerbutton after seeing the black screen; OR tring to download updates first on computer then to device ("download updates on my computer" option); OR trying to choose a smaller EU map; OR trying to install the map to microSD; OR disabling USB ports for power saving "USB Selective Suspend" mode; OR adjusting all firewall and virus options not to let them act as an intruder...etc (those steps are tried by the order written in suggestions; however here not writen in order but in random just to give you an idea)

    Uploading a smaller map, works just fine for some users but for me I am only able to choose among some parts of EU maps (still 2-3Gb) but I am not able to not choose a single country (in my case Turkey).

    Somehow my device refuses to install the any chosen map among any EU map parts offered as an alternative.

    I believe (as mentioned as Case 2 by TomTom experts) it is the certificate problem (During the update process map installation fails but the certificate gets installed, MyDrive Connect will not offer the same map for download.)

    I need the customer service to get the certificate removed, I am needing their tools in the backend to create scripts that will remove the certificate (as mentioned, once the certificate is removed the map will be offered as a download again in MyDrive Connect.)

    Is it possible to remove the malfunctioning certificates so that I can reinitiate the healthy download and update procedure?

    Can I able to choose a single map (in my case Turkey) within the limits of my lifetime EU update agreement?