Go 5200 UK device in Oz — TomTom Community

Go 5200 UK device in Oz

I purchased my Go 5200 device in the UK and have been happy with it. I have just recently emigrated to Brisbane, Australia. One thing I was expecting that my tomtom in built sim card wouldn't work and that turned out to be true.
I then seen there is a mydrive app for my android phone to connect my phone data to my tomtom instead. The connection was successful and I can answer calls from tomtom. However my Australian phone sim card doesn't seem to give me live traffic either. I also have tried a factory reset

Has anyone had a similar issue?

Best Answers

Answers

  • swconnellswconnell Posts: 8 [Apprentice Traveler]
    Thanks Doug,

    I thought that would definitely happen with the inbuilt sim card as they are region specific. I did think however that a local SIM card data through my phone would work. I will try hot spot again as I just did a reset.
  • ini69ini69 Posts: 1 [New Seeker]
    i have my go 5200, wasn't used for good period of time and now when i open it i can see that is very slow and is not connected to the traffic, any idea why?
    not connecting to the internet or if is connecting to the internet will be for few min or sec
  • DougLapDougLap Posts: 6,368
    Superuser
    Hi @ini69

    Try a soft reset first. Start the unit and when going hold the ON/Off button down for about 20 second until you hear the drumroll sound. The unit will boot up again.

    If the unit does not connect to Wifi properly after this do a Full Reset Tap Menu, Tap Settings, Tap System, Tap Reset Device. This will put the unit back to factory settings and you will have to set it up including connecting to the Wifi and your account.

    If it has not been used for some time it may well need to be updated. There will be one file it will download when it is doing the other updates which helps it find the Satellites.

    Hope that sorts it.

    Doug
  • swconnellswconnell Posts: 8 [Apprentice Traveler]
    Just reporting back.
    I contacted Tomtom customer support and now the device services have now been changed over to Asia pacific. Just tested out the traffic and now all is good. The inbuilt sim card doesn't work for services but I already expected that however using the mydrive app and device blue-tooth services are now connected using my phone hotspot.
Sign In or Register to comment.

Who's Online in this Category0