Tomtom won't start up after update — TomTom Community

Tomtom won't start up after update

I know I've made a big mistake - I trusted Tomtom top actually produce something that works!!!

I connected my tomtom Live to my computer for the latest update.

It downloaded the application ok and then the tomtom restarted and now thats all it does.

It reboots and reboots and is now completely unusable.

I know this is fairly usual for tomtom - anyone know what I can do about it ?

I've logged a call with tomtom - will see how long it takes toi here anything.

TOMTOM - fun for the whole family ???? Really ??


  • NsyradNsyrad Posts: 17 [Master Explorer]
    This happened to me as well after the update. All is OK now after a reset, hold the on/off button down for at least 10-15 seconds until you hear the drum roll. should boot up OK then. Good luck.
  • callwatchdogcallwatchdog Posts: 183 [Renowned Wayfarer]
    I've tried switching it off and on but still rebooting.
  • dhndhn Posts: 33,355
    But did you hold the power button until you heard the drum sounds? That is what reboots the unit, not just turning it off and on.
  • callwatchdogcallwatchdog Posts: 183 [Renowned Wayfarer]
    Thanks it took 2 reboots to get it working.

    i had problems upgrading the last time as well.

    Suc h a shame they're not fixing these problems - tomtom used to be so good - years ago I bought 5 as presents - but not anymore.
  • IndyHawkIndyHawk Posts: 2 [Apprentice Traveler]
    I've now attempted the restart procedure (soft reboot) at least six times and it is still just cycling the restart .. no change, Any other suggestions?
  • IndyHawkIndyHawk Posts: 2 [Apprentice Traveler]
    Just spent some time with support tech on phone. Nothing worked.  Solution is to send it in for replacement.  Tech help certainly friendly enough and cooperative.  Disappointing but not complaining.
  • ByteRiderByteRider Posts: 1 [Apprentice Traveler]
    I'm doing a long drive tomorrow, thought I'd update the ol' tomtom... which I haven't done in about a year.

    During the update process, I got errors that "can't write to H:"" (H is the tomtom) for files like data.chk and some other file.  Tried to update several times, kept failing.

    And yes, I turned it on/off, waiting for the "drum roll" sound, etc.

    Now, when I boot the tomtom, I get the big red flashing "X" on the screen  and the thing is now completely useless. 

    I don't want a fix.

    I don't care to have it fixed at all.

    I'm just here to tell people that once your tomtom gets in this mode, you might as well throw it away.

    As for me, I'll be using my ANDROID PHONE AND ITS FREE SOFTWARE, so stick that in your SQA department's backside.


    Embedded Software Engineering Manager
  • edbwash5edbwash5 Posts: 7 [Legendary Explorer]
    I love my tomtom and this is the first time it has let me down. I updated the device now I'm stuck on start up, I've rebooted over and over again to no end. Is my tomtom dead ? Is it time for me to get a new one? Just what can I do, I would not have brought it if I didn't really need it now it has taken me half way to Florida and I don't know how to get where I'm going or how to get back home.
  • edbwash5edbwash5 Posts: 7 [Legendary Explorer]
    <font size="4">Ok, I got to the start up now I'm stuck again. I even took the pin and it the reset botton and all it did was turn it off for me since press the on off would not work either. Now I'm really pissed.</font>
  • jonstrongjonstrong Posts: 670 [Supreme Navigator]
    edbwash5 wrote:

    <font size="2">Ok, I got to the start up now I'm stuck again. I even took the pin and it the reset botton and all it did was turn it off for me since press the on off would not work either. Now I'm really pissed.</font>
    Which model TomTom do you have? There are a couple of different approaches for a full factory reset, depending on model. I believe that, for the devices with the reset pin you describe, holding it in for 15 secs till the device shuts down actually is the reset procedure, but there may be other alternatives as well. What kind of device do you have?
  • edbwash5edbwash5 Posts: 7 [Legendary Explorer]

       I have XL350 I think, it is in my car at this point in the trunk. There is a pin hole on the bottom that says reset so you insert a pin or tooth pick in the hole and it cuts it off. 

        Thank you for any help you have, I'm back to using my phone
  • jonstrongjonstrong Posts: 670 [Supreme Navigator]
    edbwash5 wrote:


       I have XL350 I think, it is in my car at this point in the trunk. There is a pin hole on the bottom that says reset so you insert a pin or tooth pick in the hole and it cuts it off. 

        Thank you for any help you have, I'm back to using my phone
    I haven't used that model, but if you search a bit there's a fair amount of discussion on the net about this. From what I'm seeing, the reset procedure takes a bit more than depressing that reset button. Also - if the reset procedure doesn't work, I've seen recommendations that you reinstall the device software -- AFTER you've backed up content.

    Suggest you read through the following thread and see if it makes sense to you -- a quick skim suggests to me that it covers your issue (hopefully...or something close) and provides links to detailed instructions re: backing up your content and reinstalling software:
  • MickRobsonMickRobson Posts: 1 [Apprentice Traveler]
    Tomtom was working fine but after latest update, though Ican manage device through Tomtom home it wont reboot despite several resets - I see on the forum that this is a common problem - does anyone know how to fix it - come on Tomtom, pull your finger out.
  • edbwash5edbwash5 Posts: 7 [Legendary Explorer]
    Ok, I have been on the phone with 2 reps from Tomtom they talked and I did what I was told. Nothing worked after I disconnected the device from the computer I still had the same problems STUCK  it will not turn itself off, I had  to stick a pin in the reset hole to turn it off . I held the the off button down for 30 seconds over and over ,that did not work either, I let the battery run completely down then recharged it, that didn't work either. A dead tomtom is no good to me, just tell me if there is no fix and you want me to buy a new one. I am retired and on a fixed income and this was a small investment for me. I can not afford another one
  • edbwash5edbwash5 Posts: 7 [Legendary Explorer]
    Well as you can see it has been months now that my XL350 tomtom has been down (stuck on stupid) and I have talked with you all online and 2 Reps from the company. I just don't know what else to do. Tomtom is no good to me in the box, I'm thinking about leaving my window down and putting it on the seat of the car so someone can take it cause I just can not make myself throw it away.
  • polsteadblackpolsteadblack Posts: 3 [Apprentice Seeker]

    This has just happened to me as well. It is perpetually cycling but won't actua;;y get to fully turn on or off. Totally useless. Why do I always update just before going on a journey and find that it completely wrecks the thing time after time after time. Why does this keep happening? You update a map, it stops working. You update Home, it stops working. I find the software excellent when it is working but these devices have caused me so much stress over the years. Please does anyone know the answer? It is 1am and I have been trying to get it to work for hours. I am up at 6am to get to this meeting and no TomTom. Fabulous!
  • vadersherovadershero Posts: 1 [Apprentice Traveler]
    This seems to be a problem with many. I never updated maps or anything since I got this. I finally decided to plug in and update. I downloaded Home2 and it offered some small updates for system. I did those and it worked great, including the backup of they system. Then the software suggested application updates. I started that and it just sat for a long time. I left if for a couple of hours. I came back the computer had gone to sleep (Which it couldn't do if it was working on something) and the TomTom was stuck on the start up screen. I held down the power button until the screen turned green and shut off. Then it did nothing. The power button no longer would work. I plugged it back into the computer and started it up. Home2 recognized it needed the application update still and so I select the "Update" button and Home2 crashes. I tried again. And again. So I figured I would "Cancel" instead. It didn't work. Home2 still crashes and no update done. So I have a unit that has worked fine for me for years and now is dead and the Home2 software used to even restore my backup crashes when the unit is plugged in. The software works fine if the unit isn't plugged in, but then you can't do anything with it so that really means nothing.

    I have an XXL with the model number starting with GL. Any ideas would be great!
  • ZsoltZsolt Posts: 36,012
    1. Save everything from the device/card, using Explorer (or Finder on Mac), include all the files (hidden as well). It is also known as a manual backup:

    2. Then format the internal storage (or memory card, depending which one you use) of your device. Use the COMPLETE format, not the quick.

    3. Go to TT HOME, Manage my "DEVICE", delete everything from the hard drive and try the update again (in the new TomTom HOME app it is on the second page). At this point you might have to disconnect the device a few times and switch it ON/OFF to enable it to setup some important stuff.

    4. Copy your voices and post codes back to the device (also the maps if that didn't download either).
  • jtov3968jtov3968 Posts: 1 [Apprentice Traveler]
    Think i foundthe answer to this annoying TomTom glitch, after hours of it being frozen on bootlogo with reset pin button my only option to power down, to then get the same problem... I reached a conclusion.

    I powered device down using pin button, opened tomtomhome app on computer.. plugged device in, powered it up, when tomtom app read that device was connected i went to manage my XL, basically my fix came from removing the application from the my device tab, erasing it completely.. then i went to install items from computer tab and installed the application identical to the one i just removed.. this seemed to work for me, hope this method works for others also. TomTom need to realise why so many people use google for satnav these days, free updates, reliable and free... wake up tomtom, lower your prices and better your service.... less problems would be nice.
  • mikeconcmikeconc Posts: 1 [Apprentice Seeker]
    Every time I connect my Tom Tom to my computer and install updates, it fails to reboot. This is thoroughly annoying. I would not buy Tom Tom again.

    I have to hold down the start button until it reboots and plays the drum sound, after which it will reboot correctly. This issue should have been addressed and rectified by the maker years ago.

    This is not a good and reliable product or service. Frankly I'm disappointed.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Mike,

    Welcome to the forum!

    I sounds like there's something wrong with your device. I'd recommend you to first factory reset your device as follows:
    - On the device, click Settings - Return factory settings. Please note, that this will delete your saved favourites, home location and recent destinations. You can save your favourites to your computer [Support FAQ - Save Favourites]
    - When you're prompted to choose a language, press and hold down the power button until you hear a drumming sound

    Should that not help you solve the issue, please set your device to recovery mode [support FAQ - Red X].

    Cheers, Mikko
  • Emma9219Emma9219 Posts: 8 [Master Explorer]
    Never buy a Tom Tom. It was great until I updated my maps. Now it won't turn on and won't recharge. It was working fine the day before. Support tells me the problem is with my device. All the videos I've watched are of no help for a unit that will no longer power on. Support says it was just a coincidence that it quit after the update. Like I believe that! REPEAT: DON'T BUY A TOM TOM UNLESS YOU PLAN TO NEVER UPDATE YOUR MAPS USING MY DRIVE CONNECT.
  • AlanRobertsAlanRoberts Posts: 12 [Legendary Explorer]
    I have the same problem. Tomtom Start 25. I managed to get the update intoit after a week of being told that the server is busy (by deleting Tomtom Connect and reinstalling it), and I'm now told that it's up to date. But it won't switch on. I get the splash screen and nothing else. There's no reset button and holding down the On button simply turns it on and then off again.

    All was well until a week ago when it simply froze. Now, I've just got a lump of useless electronics, and none of Tomtom's advice is having any effect at all. So I guess I'll have to start looking for a replacement, and NOT a Tomtom ever again.

    Alan Roberts
  • hatebeingcheatedhatebeingcheated Posts: 1 [Apprentice Seeker]
    edited November 2019
    Pleased I'm not the only one. I did the same thing updated for the first time in quite a few months...No warnings or anything and then it has never worked correctly since I am absolutely sure it was TOM Tom's deliberate intention to wreck my unit and try to force me to buy a new one at their "OFFER" price (Still way too dear) As suggested above, I will never ever buy another TOM TOM device...when its obvious they will play the same dirty trick again in a couple of years time. I am a pensioner and can't afford to throw money away or should I say let big companies scam me off... :#
Sign In or Register to comment.

Who's Online in this Category0