Mydrive Connect displaying webpage when trying to login

verlenverlen Posts: 3 [Apprentice Traveler]
edited January 25 in MyDrive Connect
Hi,

I'm using Win10 with Win Defender. I was able to update my Tomtom GO500 until today using Mydrive Connect.

When I start Mydrive Connect, it shows me the Tomtom website. It doesn't matter if my device is connected or not. If I try to log in, the webpage tells me I have an incompatible browser. I have Firefox (default) and Chrome, both with webgl activated.

I uninstalled MDC, restarted my pc, reinstalled it. Webpage...
Looked for the "Tomtom..." entry in network devices: nothing.
I uninstalled MDC, installed a downgrade, webpage...
Reset my device (pushing for 20-30 seconds the on/off button), connected to the pc, webpage...

This is the first time I see this. Before it was simple, clear, always like in the tutorial videos.

What can be the cause of this problem?

Comments

  • SerhioSerhio Posts: 9 [Master Explorer]
    I also have a web page. It means not only my glitch.
  • dhndhn Posts: 33,130 Superusers
    I'm starting to think there is a problem with the server for MyDriveConnect. Call support to assist:

    :flag_gb: United Kingdom
    02079 490 132
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • verlenverlen Posts: 3 [Apprentice Traveler]
    I called support. Apparently Tomtom has changed a few things in MDC, making the whole update process described on their webpage quite misleading.

    If there are no updates, you will get the website and there is nothing you can do. No information, no warning, nothing.
    If there are updates, a different page will appear and you can update your device.
    And this goes for maps too, not only for the device's software.
  • VikramKVikramK Posts: 7,271 TomTom Moderator
    @verlen @Serhio

    Could you guys explain a bit more about the process after opening MyDrive Connect that takes you to the webpage.

    Adding some screen shots could help us to recreate the issue and see if we encounter the same problem.

    Thanks
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • VikramKVikramK Posts: 7,271 TomTom Moderator
    Hi @Dr Berenyi

    I have moved your comment to a topic where our users are already discussing a similar problem.

    As mentioned above could you add some more info or some screen shots so we can try to reproduce this bug.

    At the moment I have the application installed and I am able to log in without any problems.

    Thanks
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • SerhioSerhio Posts: 9 [Master Explorer]
    e16fd525-929c-40e0-890a-d54c7b8e6b58.png
  • SerhioSerhio Posts: 9 [Master Explorer]
    This appears when you switch to certain languages in the settings (for example, Russian, Latvian and others.
  • st098st098 Posts: 3 [Neophyte Traveler]
    Having same issue....

    c9f97b6e-ffd0-4da2-b9ab-6560cc6d4772.png
  • mariaprisacarimariaprisacari Posts: 1 [Apprentice Traveler]
    I have same problem. Starting "my drive connect" and connecting my tomtom to PC I get same page as SERHIO and st098. It doesn't appear the menu as before.
    How to update the device?

    I can't get this page, searched everywhere in the new appearance of my drive connect
    e5f25063-9313-479f-ba8a-27d5efaa0737.png54f9cab8-6e92-4455-8dc5-ac5ee2a44a56.jpg
  • SilberpfeilSilberpfeil Posts: 309 [Renowned Trailblazer]
    Same Problem in Hungary :rolling_eyes:
    Win 10 PC with latest updates and Mydrive 4.2.3.3625
    ae54fa68-b6d1-4d11-aeb8-b1264e43fb63.png
    VIA 125, TMC, App 12.075, Lifetime Maps.
  • VikramKVikramK Posts: 7,271 TomTom Moderator
    Hello all

    Thanks for all the information you guys provided.

    We were able to reproduce the issue at our end.

    The problem has been reported so it will be fixed soon, in the meanwhile as a workaround you can change the country to UK and the application should work.

    Right click on MyDrive Connect icon on the taskbar> select setting > select UK

    Thank you again.

    Regards
    Vikram :)
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • SilberpfeilSilberpfeil Posts: 309 [Renowned Trailblazer]
    Thank you, the german Version works perfect for me. :relaxed:
    VIA 125, TMC, App 12.075, Lifetime Maps.
  • verlenverlen Posts: 3 [Apprentice Traveler]
    I confirm it too. It works.
  • SerhioSerhio Posts: 9 [Master Explorer]
    My country do not work corektly
  • SilberpfeilSilberpfeil Posts: 309 [Renowned Trailblazer]
    VikramK wrote:
    ...The problem has been reported so it will be fixed soon...

    Are you sure? :wink::zipper_mouth:
    VIA 125, TMC, App 12.075, Lifetime Maps.
  • SerhioSerhio Posts: 9 [Master Explorer]
    problem solved
Sign In or Register to comment.

Who's Online35

Red-Zeppelin
Red-Zeppelin
+34 Guests