G0 600 - device not starting or displaying a cross — TomTom Community

G0 600 - device not starting or displaying a cross

My GO 600 is having problems.

I've followed the instructions on the page headed

Navigation device not starting or displaying a cross

the restore completes but I still have the same error. In fact the device starts another restore automatically. I think its now on its fifth restore all of which have completed. Any other suggestions for what to do?




  • LAURE123LAURE123 Posts: 1,444 Superuser
    Hi @NeilMcd

    It's not obvious to help you or give you an advice.

    - Check if the process is not blocked by your antivirus or firewall or VPN.

    - With your device Not connected to the PC empty the MDC cache folder and check if both options are checked. See pictures.
    For that right click on the MDC icon in the taskbar next to the clock ==> Settings ==> "Downloads" tab ==> check the options ==> the "Empty download folder" button ==> confirm with the "Save settings" button.

    - Retry the procedure.

    If that still doesn't work contact TomTom Support for more help:
    :flag_gb: United Kingdom
    02079 490 132
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

  • NeilMcdNeilMcd Posts: 4 [Apprentice Traveler]
    Thank you for the suggestions. I'll go and try that
  • NeilMcdNeilMcd Posts: 4 [Apprentice Traveler]
    Looks like a phone call to TomTom. Thanks for the contact number.

    "Empty download folder" was greyed out on my PC, but I deleted the only file there using Windows explorer. Still did not complete a start-up. If I leave it plugged in to my PC, it simply goes on a continuous loop doing a restore, restarting then restoring continuously.

    I'll call TomTom.

    Thanks for the help though it was much appreciated.

  • LAURE123LAURE123 Posts: 1,444 Superuser
    Hi @NeilMcd

    Sorry for you. :slight_frown:
    I hope that TomTom support will solve your problem.
  • lampardlampard Posts: 4,481 TomTom Moderator
    Hi Neil,

    Welcome to the Community!

    Are you still facing this issue? I would advise you to let the battery of the device discharge completely and then charge it using the wall charger for 2-3 hours. Once this is done, make a soft reset on your device to turn it on and then connect to the computer to update it via MyDrive Connect.

    This can be related to the old software installed on your device and make sure to install the firmware first when updates are offered.

    Cheers, lampard
  • NeilMcdNeilMcd Posts: 4 [Apprentice Traveler]
    Yes I've still got the problem. I hadn't phoned TomTom yet. I'll try discharging
Sign In or Register to comment.

Who's Online in this Category1