Waiting for your device — TomTom Community

Waiting for your device

geedocgeedoc Posts: 1 [New Traveler]
edited January 2019 in MyDrive Connect
After over an hour of helplessly watching the updating my device connection showing me no progress, no action, no timescale..Nothing..well nothing but 3 clever little green dots with infinitely more patience than me...I'm about finished with Tom Tom.This is deplorable.I've looked on line and see that this isn't new,there's lots of complaints...……...and it's not being fixed.

Comments

  • lampardlampard Posts: 5,314 Moderator
    Hi geedoc,

    Welcome to the Community!

    I checked your device details and the South West zone of Europe map is installed successfully on your device yesterday. See this public FAQ for more information on downloading updates.

    Cheers, lampard
  • tucker68tucker68 Posts: 1 [New Traveler]
    hi im trying to update 4 updates to my go 510 but it seems to be hanging on waiting for your device for over 20 mins now ... any ideas ? ive got 3 tomtoms in my account as im a taxi driver , ive bought a 510 to replace my 5000 as i have free speed camera updates .. regards tom
  • WhatsinanameWhatsinaname Posts: 1 [New Traveler]
    At this moment , I have the same problem with my Start 25 I did connect it to the PC and it says "connected" but it doesn t transport the downloads to the device. Keeps saying "aan het wachten op je systeem" ( waiting for your device) Got again the message that"the servers are to busy"Just like some months ago. So i already downloaded Mydrive connect ...again.
    What else can i do?
  • Paul__SPaul__S Posts: 1 [Apprentice Seeker]
    Same thing with Start25. It says "waiting for your device" and that's the end.
  • VikramKVikramK Posts: 11,936 Moderator
    Hi Paul_S

    Welcome to the community!

    There could be different scenarios here-

    # The update is installing, but not properly reflected in MyDrive Connect.
    # The update is actually installing. Therefore, wait for the device to say when it's complete.

    Some users resolved the problem by disconnecting-reconnecting the device a few times.

    Regards
    Vikram
Sign In or Register to comment.

Who's Online in this Category0