Start 20 not starting !!

When I switch on my Start 20 I get the drum roll but then nothing!! just a blank screen and it doesn't connect to MyDriveConnect any ideas please?

Comments

  • dhndhn Posts: 33,186 Superusers
    When it is connected to the computer, do you still get the blank screen after boot up? Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds.

    Also, it may be a symptom of a failing battery.
  • Chris-NocChris-Noc Posts: 3 [Apprentice Traveler]
    Yes still get the blank screen when connected, I've tried resetting it connected and not connected. I would think that it may be a battery problem as it has been on charge overnight and still has the problem.... is it possible to change the battery ?
  • NiallNiall Posts: 10,549 Superuser
    @Chris-Noc

    In UK
    "AO">Start 20, 2GB + micro-SDHC, MyDrive Connect NAV3 Eol
    "AP">Start 20, 4GB + micro-SDHC, MyDrive Connect NAV3
    "AY">Start 20, 8GB + micro-SDHC, MyDrive Connect NAV3

    in US
    "AP">VIA 1400 / 1405, 4GB + micro-SDHC, MyDrive Connect NAV3
    "AY">VIA 1410 / 1415, 8GB + micro-SDHC, MyDrive Connect NAV3

    So unless the serial number of your START 20 does not start with "AO" (which is now obsolete ) then you can get a battery here
    https://www.newpower99.com/TomTom_Via_1400_Battery_Replacement_Kit_p/tomtom via 1400.htm
    or
    https://www.newpower99.com/TomTom_Via_1410_Battery_Replacement_Kit_p/tomtom via 1410.htm
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button 👍

    If someone answered the question you asked? Answer Yes to "Did this answer the question? Yes · No"
  • dhndhn Posts: 33,186 Superusers
    See here:

    [video]
  • Chris-NocChris-Noc Posts: 3 [Apprentice Traveler]
    dhn AND Niall many thanks for your help and advice. I'll try replacing the battery !!
    Thanks again
Sign In or Register to comment.

Who's Online28

Bembo
Bembo
Heintz
Heintz
+26 Guests