Lost City after last update- — TomTom Community

Lost City after last update-

Lost City: after last update, when I wish to drive to an address in St. Joseph MI, only way am able to enter street address is to enter zip code in lieu of St. Joseph, MI as St. Joseph MI does not exist any longer. It does exist if enter zip code.
Very inconvenient. Hope next up date fixes.

Comments

  • dhndhn Posts: 33,162 Superusers
    What model? Make sure in the address field that the flag is not set to USA but is set to MI.
  • vja357vja357 Posts: 4 [Neophyte Traveler]
    Via 1620
    flag is MI . . . all other MI cities have worked great with exception of St. Joseph. . . . am hopeful next update will find St. Joseph MI.
  • dhndhn Posts: 33,162 Superusers
    I just tried it with map 1015 on my Go Live 1535.

    I set the flag to MI.

    I typed: St Jos and, as soon as the 's' was typed, the city St. Joseph MI appeared.

    Notice that, when I typed, I did NOT include a period after 'St'.
  • vja357vja357 Posts: 4 [Neophyte Traveler]
    Thank you. I'll attempt again but I have tried typing St Joseph MI every which way I can think of . . . . all to no avail. granted I must be doing something wrong.
  • dhndhn Posts: 33,162 Superusers
    Support if necessary:

    877-757-7137
    Monday - Friday: 9:00 a.m. to 7:00 p.m. EST
  • vja357vja357 Posts: 4 [Neophyte Traveler]
    thanks much for the support phone number!
Sign In or Register to comment.

Who's Online53

DougLap
DougLap
Elchdoktor
Elchdoktor
firefighter1461
firefighter1461
GewO
GewO
jeanpierr
jeanpierr
Lochfrass
Lochfrass
normand.rouleau_un34
normand.rouleau_un34
qirky caz
qirky caz
Ralf H.
Ralf H.
TomDone
TomDone
+43 Guests