MyDrive stuck on Waiting for system

Azurin Registered Users Posts: 2
Apprentice Traveler
edited January 2019 in MyDrive Connect

I'm trying to update my TomTom Rider 400. It was trying to update it yesterday, but something went wrong and I ended up with a corrupt/broken map file according to the MyDrive program. My TomTom still works fine though.
After reinstalling MyDrive on my windows 10 laptop, I again try to install the updates.
The updates get downloaded to my laptop just fine, but then it should update them onto my TomTom, but nothing happens. I just get to stare at the screen with "Waiting for system". Been doing so for several hours now.
My TomTom says it's connected to the PC and that I can use MyDrive to change things.

Things I tried so far:
Reboot TomTom and laptop
Reinstalled MyDrive with everything removed from laptop
Reset TomTom to factory settings (It gets my saved locations back just fine)
Tried several USB ports and different USB cables

Please help, cause I have no ideas anymore and those on the Forum don't seem to help.


  • dhn
    dhn Posts: 33,385
    Maybe support can help?

    :flag_nl: Nederland (Holland)
    020 850 1007
    Maandag t/m vrijdag : 09:00 tot 17:30
  • Azurin
    Azurin Registered Users Posts: 2
    Apprentice Traveler
    Well, after trying via my husbands PC we got the update running again. It updated, though it ended in an error for some unknown reason.
    I decided to try again on my laptop and it updated without any problems this time.
    I have no idea why or how, but I'm glad it works again and I got all my updates on my TomTom Rider 400