Tom Tom Rider 420 sending me on a wild goose chase — TomTom Community

Tom Tom Rider 420 sending me on a wild goose chase

LincolnPeteLincolnPete Posts: 2 [Apprentice Traveler]
edited January 2019 in RIDER
I have a Tom Tom rider 420 and have used it fairly regulary for the year that I have owned it.I regularly check for updates and the navi came with free lifetime european maps and traffic cams as part of the deal. My last trip was taking me through Belgium and into Germany and on a previous trip also the navi sent me around some country lanes for absolutely no reason.The trip would have been worse if I hadn't realised it was sending me wrong and ignored it,has anyone else had these glitches?

Comments

  • tugmantugman Posts: 337 [Revered Navigator]
    If you did the planning during the winter months that may explain it as some roads are closed
  • LincolnPeteLincolnPete Posts: 2 [Apprentice Traveler]
    I planned the route 4 days before leaving and after the maps had been updated,my friend has a newer model which didn't have the same glitch.
  • Ste7iosSte7ios Posts: 753
    Superuser
    Check your settings (avoidances, etc). Both devices must have the same settings.
  • ztech6ztech6 Posts: 55 [Renowned Wayfarer]
    I've had a similar occurrence and concluded it was related to the 'Quickest route' setting. I my example it took a shorter route cutting the corner of the main road, I chose to ignore it as the time difference was marginal.
Sign In or Register to comment.

Who's Online in this Category0