How Do I Close MyDrive Connect?

VXeroVXero Posts: 48 [Renowned Trailblazer]
edited January 31 in MyDrive Connect
How do I close MyDrive Connect after I'm finished with it? There is no "X" or menu I can use to close it or even reduce it to get it off the screen. Sometimes the Taskbar won't pop up so I can go to another program; I have to open "Task Manager" and "End Task" to close MyDrive Connect.

I use Windows 7.


  • dhndhn Posts: 33,186 Superusers
    The Tomtom icon should be in the notification area of your computer. Right click on it and select 'exit'.

    If you are not seeing the icon, perhaps it is hidden. Do you see an up arrow icon there? If so, click on it and then you should see the tomtom icon.
  • VXeroVXero Posts: 48 [Renowned Trailblazer]
    The MyDrive Connect page blocks everything else on the screen. Even the taskbar will not pop up when I move the cursor to the bottom. There is no "-" or "X" in the upper right corner to reduce or close the MyDrive screen.
  • LAURE123LAURE123 Posts: 1,322 Superuser
    Hi @V Xero

    What is your OS? Do you sometimes connect your PC to a second screen?

  • VXeroVXero Posts: 48 [Renowned Trailblazer]
    I'm using Windows 7. I do sometimes use a second screen, although the problem occurs even if I am not connected to another screen.

    I did find that if I choose "The Smartest Route Planner" from the MyConnect screen, it goes to MyDrive Route Planner and I can navigate elsewhere from there. If I go back to MyConnect, I have to again open a MyDrive Route Planner screen to be able to get back control. I can not close the MyConnect screen except through "End Task" through "Task Manager."
  • LAURE123LAURE123 Posts: 1,322 Superuser
    @V Xero
    Try the keyboard shortcut ==> Windows logo key + P
    and choose "Computer only"
    Also check the resolution of your screen and choose the recommended one if possible.
  • VXeroVXero Posts: 48 [Renowned Trailblazer]
    I selected "Projector Only" but it just filled my other monitor with the MyConnect screen and I couldn't close it. What do you click on to close that screen? I don't see any options that say "Close."
  • LAURE123LAURE123 Posts: 1,322 Superuser
    Hi @V Xero

    Windows logo key + P
    This window closes automatically when you select a choice and validate it with a left-click or your keyboard.
    Otherwise to close it without having made a choice press the "Escape key" on the keyboard, ESC.

    You have a display problem that may be related to your shared display.
    You should have tried this function without your 2nd screen connected to your PC. Remove the cable or use its buttom on/off to turn it off.

    Restart your PC, use the keyboard shortcut Win + P "Computer Only" and use the default definition of your main screen.

    Screen Resolution ==> right click on Windows Desktop / Screen Resolution / Resolution / choose size "Recommended" / Apply / OK

    Now I may be wrong.
    Sorry, but I do not see anything else to help you.

  • VXeroVXero Posts: 48 [Renowned Trailblazer]
    I did try using MyConnect without the second monitor. Same problem; I don't see anything on the MyConnect screen to close it down. I must be missing something really obvious, but what do I click on to close the MyDrive page, the one with "My Device," "My Content," and "My Account" at the top?
  • dhndhn Posts: 33,186 Superusers
    Right click on the small tomtom icon in the notification area of your computer. One option is 'exit'. Use that.
  • LAURE123LAURE123 Posts: 1,322 Superuser
    @V Xero
    Did you do what I advised? A PC Resart, the screen resolution on "recommended", with only the first monitor. And now you have the taskbar? Please, answer me Yes or No to both questions.

    You can also try this, again a keyboard shortcut.
    To do with only one monitor in function when the MDC window is displayed too big without red cross.
    ==> Windows logo key + a directional arrow key, Left or Right

    If it still doesn't work.
    Uninstall MDC completely to make a clean installation.
    You can find the installation file here by going down in the page, the green button "Download for Windows":

    I cross my fingers for you.
  • VXeroVXero Posts: 48 [Renowned Trailblazer]
    That is the source of my problem: my taskbar is unlocked but, after popping up once or twice in MyConnect when I move the cursor to the bottom, it will no longer pop up when I try to access it. I don't have this problem with any other program. If that is not a problem for anyone else, it must be a quirk on my computer and probably not within my knowledge set to fix. I'll just live with it. Who knows, a Windows 7 update may fix it for me.
  • VXeroVXero Posts: 48 [Renowned Trailblazer]
    LAURE123-I did a restart and working from only the laptop screen with no other monitor connected I have the same problem. One time the task bar appeared a couple of times then wouldn't appear, another time it never appeared.

    I tried holding the Window key and using arrow keys, but there is no movement. I think I'm seeing the full screen because I can see all the small text at the bottom and an American flag in the top right corner.

    Do you have an "X" symbol in the top right of the screen to close the program?
  • LAURE123LAURE123 Posts: 1,322 Superuser
    @V Xero

    Yes I have the red X, as for all Windows programs.


    It's weird that the taskbar appears or disappears randomly and only with MDC. :confused:
    Windows + Left or Right arrow keys normally the window should move. But it doesn't work for you.
    I guess you've also tried Down (Minimize window).

    All that remains is to attempt to uninstall MDC for a clean reinstallation. Download it here:

    If with this file of the last version there is no improvement in the display you can try the backup version of MDC which works like the previous versions before January 2018.
    You can download it directly on the TomTom servers here:

    I admit, I despair a little in front your problem. :disappointed_relieved:

  • VXeroVXero Posts: 48 [Renowned Trailblazer]
    I opened MyDrive Connect yesterday and have the blue section at the top with the "X" to shut it down!

    I think LAURE123 was on the right track about what caused my problem. My secondary monitor is above my primary one. That top strip must have somehow gotten in no man's land between the top of my primary monitor and bottom of the secondary monitor, perfectly positioned so it appeared to be a full screen. Since the cursor has to be on the blue area to move the screen, I couldn't move it. I must have shifted it accidentally while going between the two screens. I don't know why holding the Windows key down and moving the screen with the arrow keys, as LAURE123 suggested, didn't work. It does now.
  • LAURE123LAURE123 Posts: 1,322 Superuser
    I did a little dance of joy on my castor chair after reading your message! :grinning:
    Very glad for you. :slight_smile:
  • Sprint.GTSprint.GT Posts: 1 [New Traveler]
    I have had the same problem since installing MDC, I've only got one screen and never been able to see the Menu Bar. Eventually I positioned the mouse cursor at the bottom of the MDC page as it didn't go right to the bottom of the PC screen. I then dragged the bottom of the page up so MDC got smaller, then when the scroll arrows appeared on the right hand side I clicked on them and the menu bar appeared, I then repositione MDC so the the menu bar was visible and it has remained visible since. I now have a scroll bar at the side at all times so I guess somewhere in the coding it couldn't cope with my screen size (19") and has been configured for a larger screen
Sign In or Register to comment.

Who's Online22

22 Guests