Have a Nexus 7 phone and can't login anymore on my TomTom GO App

rboudria
rboudria Registered Users Posts: 5
Neophyte Traveler
Hi add to logout of my account for my TomtTom GO App on my Android Nexus 7 Phone.

Can't login anymore and it seems there was not update since last year.

Don't even have access to my subscription which I paid for 3 years.

Thank you.

Comments

  • VikramK
    VikramK Administrators Posts: 14,060
    Moderator
    Hi rboudria

    Welcome to the community !

    Quickly looking at your account I see the subscription is still active.

    You mention about not able to log in, what kind of error you get?

    Could you add some more information?

    Thanks
    Vikram :)
  • rboudria
    rboudria Registered Users Posts: 5
    Neophyte Traveler
    Hi VikramK,

    All I get is 'Oops Something has gone wrong'.
    Then if I click 'OK' and I'm back to the login window and if I do it again it's always the same message.

    Thank your

    Richard
  • VikramK
    VikramK Administrators Posts: 14,060
    Moderator
    Hi rboudria

    Try some troubleshooting steps below:

    # Uninstall the app
    # Clear cache data for the following apps (note, going to Settings > Applications / Manage Applications, might not show them. Via the 'More link in the top right corner, enable 'Show System Apps')
    > Google Play Services
    > Google Play Store
    > Google Services Framework.
    # Set the time to "automatic"
    # Restart the phone (this is important)
    # Download a fresh copy of the app from the Google Play store
    # Once installed try to log in again.

    If the issue will persist then please report this to the customer service.

    Regards
    Vikram :)
  • rboudria
    rboudria Registered Users Posts: 5
    Neophyte Traveler
    Hi Vikram,

    Are you talking about 'Apps & Notifications' under settings and for which apps do I need to clear the cache?

    rboudria
  • rboudria
    rboudria Registered Users Posts: 5
    Neophyte Traveler
    Hi Vikram,

    Thank you for you help. It did work. They only thing is I lost all my 'My Places'.
    I'll have to start over but at least it's working.

    To clear my cache I had to:
    Open 'Setting'
    Tap 'Apps & notifications'
    Tap See all apps
    Via the 'More link in the top right corner, enable 'Show System Apps')
    and finally did the rest of your procedure.

    Thank you again.

    Bonne journée

    rboudria
  • rboudria
    rboudria Registered Users Posts: 5
    Neophyte Traveler
    Hi Vikram,

    Just notice that all my 'My Places' are back. I guess it took a little bit longer to update or maybe closing the app fixed it.

    Thank you again.

    rboudria