TomTom Cardio Multisport Problem

Nazhi Noor
Nazhi Noor Registered Users Posts: 4
Neophyte Traveler
edited January 24 in TomTom Sports
Hi guys,

Recently my watch has been having some battery and syncing issues. I've tried soft reset, hard reset, turning the watch off but to no avail. Basically after a full charge, the watch will work fine.But after and hour or so, the "hands" symbol will pop up every few mins or so and the watch start to lag in response. This basically drains the battery in an hour or two. Has anyone encountered this problem before. Is there a fix for it? I need my watch in the next few weeks as I got a marathon coming up.

Thanks in advance.

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,975
     Superuser
    At this point I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, select Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • Nazhi Noor
    Nazhi Noor Registered Users Posts: 4
    Neophyte Traveler
    tfarabaugh wrote:
    At this point I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, select Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.

    Noted. Thanks for the advise @tfarabaugh
  • tfarabaugh
    tfarabaugh Posts: 16,975
     Superuser
    Nazhi Noor wrote:
    tfarabaugh wrote:
    At this point I would suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, select Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
    Glad I could help. When you get a chance please mark my response as a solution so others with the same question can look for it.