Some Speed cameras not showing — TomTom Community

Some Speed cameras not showing

mossy65mossy65 Posts: 2 [Apprentice Traveler]
edited January 2019 in TomTom Services
My Start has stopped showing speed cameras on the opposite side of the road. Have purchased a new subscription but still only shows my side cameras. Any one know how to fix this?

Comments

  • BrianEBrianE Posts: 547 [Exalted Navigator]
    I didn't think they were supposed to show cameras on the opposite side of the road but I'm only guessing. There are two at Stourport on Severn, travelling to/from Kidderminster and both give a warning, which is incorrect because the camera on the other side of the road is only monitoring traffic from the opposite direction.
  • mossy65mossy65 Posts: 2 [Apprentice Traveler]
    I understand what you are saying but they can nick you traveling toward or away from the camera. Either way a camera on the opposite side of the road will still see your plate just a little further away. My sat Nov used to warn me before my last set of updates and it warn of cameras on side roads that are within distance??
  • NiallNiall Posts: 10,957
    Superuser
    Be aware that in the UK the Truvelo DCAMs have been given approval, see http://www.traffictechnologytoday.com/news.php?NewsID=57323
    The D-CAM’s approval for both front and rear images not only allows a single camera to be rotated to monitor two different sensor arrays, but also enables live enforcement in two directions at the same time; referred to by Truvelo as Simultaneous Bi-Directional (SBD) enforcement.
Sign In or Register to comment.

Who's Online in this Category0