Multisport Watch Factory Reset

jchill
jchill Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
I have had the Multisport watch for 2 seasons now and have really liked using this product. A few days ago it froze on me and it would display the time, but none of the buttons would work. I charged it overnight and it seemed to pull all of the data off the watch, but when I unplugged it it wanted me to reconnect it to my computer and asked to do a factory reset. I am now caught in a loop of it doing the factory reset and then going right back to wanting to do a factory reset. Is there any way to get out of this loop? I would appreciate any help. Thanks.

Josh

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,975
     Superuser
    I would try to perform a reset on your watch using the recovery mode, follow these steps (also in the link below):

    1. Place your watch in the dock before you connect the dock to the computer.
    2. On your watch, move DOWN but keep the button pressed.*
    3. Connect the dock to the computer. Keep pressing the button until your watch shows tomtom.com/reset.
    4. Release the button and wait for MySports Connect to show Update.
    5. Click Update in MySports Connect.
    * If the USB port on your computer is not easily accessible, connect the dock to the computer without the watch. Then move down from the clock screen while you slide the watch into the dock.

    If that does not work you should call Customer Support. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.

    How do I perform a reset?: https://uk.support.tomtom.com/app/answers/detail/a_id/17393
  • Koenraad
    Koenraad Registered Users Posts: 1
    Apprentice Traveler
    dear jchill, did you get the watch back to normal?
    I have the same problem...

    Thanks for your reply
  • quitorunner
    quitorunner Registered Users Posts: 1
    Apprentice Traveler
    Ummm, with all due respect, how the heck am I supposed to do what you suggest if the button is completely unresponsive???
  • Santiago_Dunne
    Santiago_Dunne Registered Users Posts: 1
    Apprentice Traveler
    I experienced exactly the same issue as "Jchill" on my Multisport Cardio.
    the rocker stop working last week and the watch got stuck on the time page.
    today I finally got lucky and the watch sync to my PC.
    I started the "Factory Reset" procedure, and I never passed the first stage.
    now I'm stuck on the same reset loop. I can not get into the reconfiguration stage.

    Did Tom Tom Tech-Support sorted out a solution for the above problem?

    I've been searching the web and the rocker issue is well known.

    Thank you,
  • Sezza_B
    Sezza_B Registered Users Posts: 1
    New Seeker
    Afer doing a factory reset on my Runner GPS Watch I keep being asked to register my device but when I click the link to do this I am directed to Internet Explorer which is obviously nolonger relevant - is there a way to login in Chrome or Firefox to complete this process. At the moment my watch constantly has the full battery symbol on the screen and no obvious way to bypass this to use the watch.
  • tfarabaugh
    tfarabaugh Posts: 16,975
     Superuser
    Sezza_B wrote: »
    Afer doing a factory reset on my Runner GPS Watch I keep being asked to register my device but when I click the link to do this I am directed to Internet Explorer which is obviously nolonger relevant - is there a way to login in Chrome or Firefox to complete this process. At the moment my watch constantly has the full battery symbol on the screen and no obvious way to bypass this to use the watch.

    It should be using whatever the default browser for your system is, it does not choose a browser. My does it using Chrome and Edge depending on what computer I am on. Edge does have IE built into it as a compatibility mode so that might work. I would suggest first checking that Chrome is the default browser is on your machine and then try again. If it continues to try and find IE that is some kind of a glitch so I would uninstall and reinstall the Sport Connect software with Chrome as your default and see if that fixes it.