Asks to connect TomTom VIA 1515 when it's connected — TomTom Community

Asks to connect TomTom VIA 1515 when it's connected

Hello,

I'm trying to fix my friend's TomTom VIA 1515. He bought it used from another person.
To update the maps on the device, I download MyDrive Connect on my Windows machine, created a new account. When the account got activated, I add the device. Device was successfully added and I can see its name. Available updates and downloads are also shown but I can't download them, the download button is disabled and when I hover over it, it says: "Connect your device".
I also noticed that at the top of the page there's a line that says: "Connect your device to see the latest status and available updates". Here are two pictures from the MyDrive Connect:
6695f35f-08b6-4e0c-adb3-683db1900e19.jpg

3ae7f392-96fb-4013-9ab7-eecbdd6eace0.jpg

The device is connected. The memory is even shown in the picture. I tried different scenarios, turn off, turn on again, start app before connecting or vice versa. The device is even able to trigger the app to start, but still it's not recognized.

I tried to check the device drivers in the Device Manager and it shows TomTom correctly and when I try to update the drivers, they're up to date.

Do you have any suggestions on how to solve this?

Comments

  • OthmanOthman Posts: 2 [Apprentice Traveler]
    I solved it!
    I just had to make sure the device is ON before connecting it to my pc.
Sign In or Register to comment.

Who's Online17

Elchdoktor
Elchdoktor
Lepre
Lepre
Lost_Soul
Lost_Soul
Nigel A
Nigel A
+13 Guests