Traffic receiver - spinning cog!

BedsRed
BedsRed Registered Users Posts: 19
Outstanding Explorer
edited December 2021 in Devices using MyDrive Connect
I bought a traffic receiver cable last Christmas for my Start 25 and all seemed to be working ok until some weeks ago when all I get now is the spinning cog wheel. Is there a reset or is it a TomTom issue? I have read all the posts here regarding remedies but I am reluctant to do any hard or soft resets unless instructed to do so. Also as it's still under guarantee should I be doing anything? Hope you can help. Thanks.

Edit: just done a restart/drum roll and still the same - no traffic receiver!

Comments

  • dhn
    dhn Posts: 33,385
     Superuser
    When you say no traffic receiver, are you trying this while the device is connected to the car charger?
  • BedsRed
    BedsRed Registered Users Posts: 19
    Outstanding Explorer
    Yes. Whilst I am travelling the SatNav is working fine and the Traffic Receiver is plugged into the dashboard aux socket but not working as it did before. Just the spinning cog.
  • BedsRed
    BedsRed Registered Users Posts: 19
    Outstanding Explorer
    Solved! After a telephone call to the support line I was told that there was no current provision in my account to receive the traffic receiver updates which was essential to solve my problem. This was corrected and they then sent me the update which I installed following the instructions below.

    "After 30 minutes, request you to logout from MyDrive application and log back in and connect the device. Wait for 2 minutes and the update will start automatically. Once the device is updated , restart your device and check the traffic."

    Now all working perfectly.