Samsung Galaxy S9 - Oreo App not working

BFury Registered Users Posts: 2
Apprentice Traveler
I know there are a lot of posts on the app hanging but what I would like to know is if tom tom are creating a fix for the Samsung S9 running Oreo. I have tried every suggestion on here and cannot get the app to work. Not good when you've paid the subscription fee.


  • Asprin
    Asprin Registered Users Posts: 271
    Supreme Pioneer

    What I do not understand is did you test the free version first??

    Before I buy any app I test it on what ever phone or tablet I want to use it on.

    With TomTomGo you can use the free version as long as you want to make sure it works on your Smartphone or Tablets running Android Oreo.

    But buying a subscription first without testing and knowing that there are problems with many phone manufacturers running Android Oreo I would not of done that.

    TomTom will come up with a fix for Android Oreo.
    But by the time there will be a new version on Android out there to cause more problems.

    Not just TomTom but most if not all android apps have this problem with Android Oreo versions 8.0 and 8.01.

    I read a lot of the comments in the Google Store about many apps having to be updated because of Android Oreo versions 8.0 and 8.01 are causing lots of problems.

    It is a cat and mouse game with Google. Why they do not give more warnings to phone manufacturers about possible problems that could come up.
    Before they release of a new Android version is the big question.
  • John9
    John9 Registered Users Posts: 2
    Apprentice Traveler
    I removed the SD-card, and then reinstalled TomTom GO. Then it worked on my S9+
  • BFury
    BFury Registered Users Posts: 2
    Apprentice Traveler
    John9 - thank you very much. I will try this solution. Appreciate the advice.

    Aspirin624 - No surprise you have aspirin in your username, probably help to save the headaches you give to people. I came on the forum asking for help not to be patronized. The issue I have is that I had the app on my S8 and it worked fine. Now I have the S9 it doesn't work, so the issue seems to be with either the phone or the Oreo system. Your saying why would I not try it for free as if we should all bow to your wisdom is not helpful but condescending. I suggest you come on the forum with a view to helping people rather than dictate what you believe their faults to be.
  • Asprin
    Asprin Registered Users Posts: 271
    Supreme Pioneer
    How is that patronizing when testing should be number one with any new phone or android version.
    Just because it worked on an older phone and does not mean it will work on an newer phone.
    There are many user's a google store who have the same problems that you have.
    I am sorry that you find it condescending to test first as to not test is better.

    I am not dictating anything to anyone just applying first trouble shoot by testing with the free version to deal with apps that might work or may not work on a new phone or tablet running Android Oreo versions 8.0 and 8.01.

    Before I buy or transfer my license over to that new phone or tablet.

    I stand by test first....

    If you are offended by that what can I say.
  • [Gelöschter Benutzer]
    [Gelöschter Benutzer] Posts: 5,321
    Supreme Navigator
    I have no problems with TomTom Go Mobile and Android 8 - Oreo (no Samsung).
  • scarytutor
    scarytutor Registered Users Posts: 3
    Apprentice Seeker
    I have a Samsung S8 and had no problems until I updated to Oreo firmware, we post in this forum for advice not smart comments, an old saying may help you in future "if you have nothing nice to say - dont say anything" hopefully Tom Tom will soon update the app.
  • nigel sutherwood
    nigel sutherwood Registered Users Posts: 3
    New Traveler
    tomtom on samsung s9+ just hangs! FIXED

    as john9 has already mentioned.
    the fix that worked for me was,
    Uninstall tomtom from phone.
    turn phone off and remove sd card.
    power phone on
    install tomtom from app store.
    run when completed. tom tom opens it may give you some messages read them and press reset it then works download your map, and your good to go.
    turn phone off and re insert sd card.

    i dont know if this fixes all later models but it works for s9+

    regards nigel
  • DIC
    DIC Registered Users Posts: 1
    Apprentice Traveler
    I had the same problem - or thought I had - with my new S9. It turned out to be lack of familiarity with my phone.
    It is so obvious in retrospect I wonder if it is the solution for everyone...
    It turns out that dragging the top window down and selection 'Bluetooth' and 'make phone visible' is not sufficient. Also making it wifi hotspot didn't work (and would be hopeless on the road...)
    I went into Settings/connections/, and checked Bluetooth and Phone visibility are checked. That allowed it to pair. (I don't yet know if I can now turn off 'phone visibility')
    But then select and then select ,Bluetooth tethering>

    And it now connected traffic to the GO 50.

    The top drag-down window does contain 'Hotspot' but does NOT contain 'tethering'.
  • YemblePhone
    YemblePhone Registered Users Posts: 13
    Apprentice Traveler
    TT Go v1.17.7 (build 2129) certainly works with Oreo 8.1 on Moto G5S+, when installed on device storage, rather than extSD. No issues noted!