No connection with Sports Connect

mjbentsmjbents Posts: 4 [Apprentice Traveler]
edited January 11 in Runner & Multi-Sport
I bought a new laptop running windows 10 for the home. Its up to date, my browser cache is empty. I downloaded the my sports connect to my new machine, but, it won't open when I connect my device. I have a tom tom runner/multisport. Thanks in advance

mjbents

Comments

  • tfarabaughtfarabaugh Posts: 15,660 Superusers
    Are you getting any error messages when you plug the watch in or is it being recognized at all? Does the clock face change to a battery charging icon (which indicates it is getting power so there is a partial connection). A few things to look at (and I apologize if some are very basic but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB plug free of any debris or blockages?
    5) Is the Connect software actually running (is there an icon for it in the notification area)?
    6) Did you install MySports Connect, not MyDrive Connect? It is downloaded from tomtom.com/123
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?

    In particular, make sure it is fully snapped into the cradle. If it does not have a full connection it will charge but it will not be recognized by the computer. It seems simple but this is generally the issue. It needs to fully click into the cradle and it may help to take it out of the band to do so. Also check that none of the pins on the dock are bent or pressed in, as that will prevent a connection.

    If nothing above helps you may have a bad dock or there may be computer setting blocking it. At that point I would suggest calling Customer Support and seeing what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, click Contact at the bottom of this page, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • mjbentsmjbents Posts: 4 [Apprentice Traveler]
    This was helpful. I was able to get it to connect with holding firm pressure with the device to the dock. I have contacted customer support.
  • tfarabaughtfarabaugh Posts: 15,660 Superusers
    mjbents wrote:
    This was helpful. I was able to get it to connect with holding firm pressure with the device to the dock. I have contacted customer support.
    Glad I could help. When you get a chance please mark my response as a solution so others with the same question can look for it.
Sign In or Register to comment.

Who's Online54

ipho4
ipho4
TomDone
TomDone
+52 Guests