Software version Rollback requests | Battery issues | Runner & Spark watch series

16364666869105

Comments

  • Teebobeebo
    Teebobeebo Registered Users Posts: 8
    Master Explorer
    Hi there - could you please roll my Spark back to 1.3.255 - this was the most recent software where I had no battery issues. Thanks
  • Quang
    Quang Registered Users Posts: 1
    Apprentice Traveler
    Hi @lampard ,

    Can you please be asked to roll back my Runner 3 back to previous firmware version? It is very annoy when I cannot pair my phone (Android 6.0) with new firmware version which is "1.7.64"

    Thank you so much for helping to solve this "very long" problem.

    RG,
  • yhelizondo
    yhelizondo Registered Users Posts: 1
    Hi there, my watch no longer connects to my phone. i have uninstalled & reinstalled app. Not sure why it stopped working. any ideas?
  • scanepa
    scanepa Registered Users Posts: 3
    Neophyte Traveler
    I have android 7.0 and spark 3 with 1.7.64, cannot connect after upgrading the watch.
  • lampard
    lampard Administrators Posts: 5,966
    Moderator
    @Teebobeebo Have you tried a factory reset on your watch?This fixes the battery issues in most cases. If it doesn't help, let me know and I'll put you back on the version 1.3.255

    @HGB Can you please try a factory reset on your watch using the Sports Connect software & let us know if it fixes the issue after that?

    @sutter @scanepa I've linked your account to the firmware version 1.7.64, please connect your watch to computer and Sports Connect will offer the software.

    @Quang The latest software 1.7.64 resolves an issue which in a few cases, could prevent the watch from pairing with a phone (except Huawei P8/P8 lite). So I would advise you to follow the steps in the public FAQ here to troubleshoot the pairing issues by removing the existing Bluetooth connections from your smartphone: Android

    Cheers, lampard
  • scanepa
    scanepa Registered Users Posts: 3
    Neophyte Traveler
    Thanks @lampard, I'll do at soon as possible.
  • scanepa
    scanepa Registered Users Posts: 3
    Neophyte Traveler
    @lampard it worked.
  • Christiaan
    Christiaan Registered Users Posts: 3
    Apprentice Traveler
    Hi @lampard ,

    Can you also please be roll back my Runner 4 to previous firmware version? Since the latest update I’m not able to sync and factory reset did not help.

    Thanks!
  • Kriexi
    Kriexi Registered Users Posts: 3
    Neophyte Traveler
    Hi @lampard, Thank you, but unfortunately I still cannot sync watch with phone and it's giving the same problem of pin appearing and then just disappearing.
  • nromein
    nromein Registered Users Posts: 2
    Apprentice Traveler
    Hi,

    I've updated my Spark this week, but now my Spark is being unresponsive or extremely lagging when pressing the jogs. I'm not sure it's related to the upgrade, but that would be my wild guess. I did a factory reset, but that doesn't change the result of being unresponsive or lagging.

    Can i go back to an older version of the firmware?
  • sutter
    sutter Registered Users Posts: 3
    Apprentice Traveler
    it is working - thx a lot @lampard
  • gesteve
    gesteve Registered Users Posts: 3
    Apprentice Traveler
    Hello,

    I have a Huawei P8 Lite and my Runner 3 does not synch after a factory reset, which keeps the watch at 1.7.64. Could you please rollback my version to a previous working one?

    Thanns in advance
  • cogs19
    cogs19 Registered Users Posts: 9
    Apprentice Traveler
    [h3]Roll me back to VERSION 1.7.53 please.[/h3]
  • lampard
    lampard Administrators Posts: 5,966
    Moderator
    Hi All,

    Yesterday, we released the software v1.7.64 for the TomTom Spark, Spark 3, Runner 2, Runner 3 & Adventurer watch which resolves the pairing issues with the watch and the smartphone (except Huawei P8/P8 lite). You can simply connect your watch to the computer and Sports Connect will offer the software.

    We're still investigating the battery issues and mostly, factory reset does the trick. If still no joy then just leave a comment here and we'll put you on the 1.3.255 software version as a workaround.

    Cheers,
    lampard
  • cogs19
    cogs19 Registered Users Posts: 9
    Apprentice Traveler
    I can assure you 1.7.64 has NOT resolved the pairing issue. My phone and watch will not pair using this software.
  • tfarabaugh
    tfarabaugh Posts: 16,943
     Superuser
    cogs19 wrote:
    I can assure you 1.7.64 has NOT resolved the pairing issue. My phone and watch will not pair using this software.
    Try a factory reset to clear out all the old pairing codes and then try it.
  • Weary
    Weary Registered Users Posts: 5
    Master Explorer
    @lampard I factory reset to version 1.3.255 and charged the watch overnight. This morning, I unplugged it and the empty battery icon appeared on the watch screen after 15 seconds. I really wanted to use the watch this weekend (the gps on my phone is a poor substitution). Do you have any other suggestions please? Battery life was well over 6 days last month and I could easily record a whole morning on the bike. Now I can't even get off the driveway! I appreciate your help.
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,215
    Community Manager
    Weary wrote:
    @lampard I factory reset to version 1.3.255 and charged the watch overnight. This morning, I unplugged it and the empty battery icon appeared on the watch screen after 15 seconds. I really wanted to use the watch this weekend (the gps on my phone is a poor substitution). Do you have any other suggestions please? Battery life was well over 6 days last month and I could easily record a whole morning on the bike. Now I can't even get off the driveway! I appreciate your help.
    Try another factory reset. Hopefully that can fix it. If not then it is a defect.
  • DouglasFF84
    DouglasFF84 Registered Users Posts: 6
    Master Explorer
    cogs19 wrote:
    I can assure you 1.7.64 has NOT resolved the pairing issue. My phone and watch will not pair using this software.

    Here after update for 2 times to *.64, at second time was upload the activity. At four time that activity was not upload anymore. The connection backs to drop at 20%...
    :/
  • cogs19
    cogs19 Registered Users Posts: 9
    Apprentice Traveler
    tfarabaugh wrote:
    cogs19 wrote:
    I can assure you 1.7.64 has NOT resolved the pairing issue. My phone and watch will not pair using this software.
    Try a factory reset to clear out all the old pairing codes and then try it.


    Already did this. Doesn’t work.
  • fionad
    fionad Registered Users Posts: 9
    Apprentice Traveler
    I would agree. Have done a factory reset, removed and re instated app, turned off and on Bluetooth and am still having the same pairing issues. You said contact customer support how do you do that?
  • HGB
    HGB Registered Users Posts: 10
    Legendary Explorer
    Hi
    i have fixed this, I found that the iPhone was still linked by Bluetooth to the watch. Once i removed this (in phone, forget this device) then both the all worked ok
    thanks for help
  • cogs19
    cogs19 Registered Users Posts: 9
    Apprentice Traveler
    HGB wrote:
    Hi
    i have fixed this, I found that the iPhone was still linked by Bluetooth to the watch. Once i removed this (in phone, forget this device) then both the all worked ok
    thanks for help

    Yep this worked for me. Thanks!
  • HGB
    HGB Registered Users Posts: 10
    Legendary Explorer
    lampard wrote:
    @Teebobeebo Have you tried a factory reset on your watch?This fixes the battery issues in most cases. If it doesn't help, let me know and I'll put you back on the version 1.3.255

    @HGB Can you please try a factory reset on your watch using the Sports Connect software & let us know if it fixes the issue after that?

    @sutter @scanepa I've linked your account to the firmware version 1.7.64, please connect your watch to computer and Sports Connect will offer the software.

    @Quang The latest software 1.7.64 resolves an issue which in a few cases, could prevent the watch from pairing with a phone (except Huawei P8/P8 lite). So I would advise you to follow the steps in the public FAQ here to troubleshoot the pairing issues by removing the existing Bluetooth connections from your smartphone: Android

    Cheers, lampard
    Hi lampard
    I had already tried this several time, and did not work but what did find is the iPhone was still linked to my watch after this factory reset which seemed to lock out the watch.
    once I had cleared this ( forget this Bluetooth device) then all worked ok. Thank you for advice
  • nromein
    nromein Registered Users Posts: 2
    Apprentice Traveler
    nromein wrote:
    Hi,

    I've updated my Spark this week, but now my Spark is being unresponsive or extremely lagging when pressing the jogs. I'm not sure it's related to the upgrade, but that would be my wild guess. I did a factory reset, but that doesn't change the result of being unresponsive or lagging.

    Can i go back to an older version of the firmware?
    [h3]@lampard Please roll me back to 1.3.255[/h3]
This discussion has been closed.