Software version Rollback requests | Battery issues | Runner & Spark watch series

16162646667105

Comments

  • LFWBCH
    LFWBCH Registered Users Posts: 1
    New Seeker
    On my watch (serialnumber HRxxxxGxxxxx) runs version 1.7.62.
    On the site Releae info I can see that ther is already a version 1.6.64 but I can't find the option of updating my watch.
    Former releases gave an updat option in TomTomSports Connect
    I would like to because version 1.7.64 could solve my connection problem.

    Mod edit: Please do not any personal information on a public forum!

    How do I update??
  • Weary
    Weary Registered Users Posts: 5
    Master Explorer
    @lampard Since the unwanted upgrade to 1.7.62 (I connected my watch to my pc by mistake, not realising I would get an automatic update which would render my watch useless), my battery drains within the hour. I have tried a factory reset to no avail. It seems very strange to me that I cannot manually choose to roll back the software to a previous working version. Surely having to respond to individual forum requests is not a good use of your time!
    Please can you roll my account back to the previous version (I think it was 1.7.60) where my Runner 3 worked perfectly well.
    Thank you for your help.
  • Mandy379
    Mandy379 Registered Users Posts: 1
    Apprentice Traveler
    Hello @lampard [user=93]Jürgen[/user] please can tou help link my account to version 1.7.64 too? I just upgraded to 1.7.62 and now nothing will sync I cant pair my watch to my phone same issue as lots of others are having, the pin shows up for 2 seconds on the watch and when I enter it on my ohone it doesnt connect. I have done Forget my device, still no luck. Thanks in advance!
  • tom.lungu
    tom.lungu Registered Users Posts: 3
    Neophyte Traveler
    tom.lungu wrote:
    @lampard May you please link me to the 1.3.2555 version. I have the same battery draining and connectivity issues as everyone else. I'm currently using 1.7.62 on a runner 2. I have tried a factory reset and it doesn't work.
    Thanks in advance.
    Or perhaps link into 1.7.64 if it fixes the problem @lampard
    Thanks
  • Peachycheek
    Peachycheek Registered Users Posts: 1
    Apprentice Traveler
    Hi I just got my watch and sadly I cant pair it with anything :( Im on version 1.7.62. I see there is an update to 1.7.64 thats fixes som pairing issues, how do i update to the latest in hope of getting it to work?
  • Eric Huskes
    Eric Huskes Registered Users Posts: 1
    I have a adventurer but after a update I had problems pairing it with my phone (IOS and Android). I saw this is a knows issue and that 1.7.64 solves it: actually I have 1.7.62... can you unlock it for me? Thx in advance
  • jwkyle
    jwkyle Registered Users Posts: 1
    Apprentice Traveler
    @lampard Just bought a Spark 3 yesterday and firmware is 1.7.62 which wont allow me to link to my iphone (watch shows PIN for less than a second, phone never reacts). Can I be updated to 1.7.64 to see if that fixes the issue?
  • sdegelaen
    sdegelaen Registered Users Posts: 1
    Apprentice Traveler
    Took my Spark 3 out of the box last week, connected it and saw it updating to 1.7.62 ... and guess what, no bluetooth connection possible.
    Congrats to TomTom for a wonderful first use experience... what a disaster. Thinking of returning it or fixing it with a hammer myself whilst documenting my "fix" online (and even spending some ad cash to make sure everyone considering this piece of crap sees what the customer experience is like).
  • tc893205
    tc893205 Registered Users Posts: 1
    Apprentice Traveler
    Mine is the same i had a notification today saying update required. I was quite excited because since 1.7.62 came out i have to force pair my watch and phone after each run i do which is very frustrating. But once i plugged into the pc for tomtom sport connect same thing as happend to you guys no update displayed i tried to reinstall the desktop app and the phone app and reset my watch to try to force it to recognise need for update but still nothing really need to sort this out i need my watch and phone to pair properly again
  • boscoreli77
    boscoreli77 Registered Users Posts: 1
    Apprentice Traveler
    @lampard hello, I ask for help please, from the update in my runner 3 cardio to 1.7.62 it does not let me link with phone or with the tablet. the last update is 1.7.64 but when connecting the clock with the pc it stays in version 1.7.62 without giving the option to go up to 64 ... I am very disappointed and it is assumed that a brand like tomtom should not commit

    hola,le pido ayuda por favor, desde la actualización en mi runner 3 cardio a 1.7.62 no me deja vincular con teléfono ni con la tablet. la ultima actiualizacion es la 1.7.64 pero al conectar el reloj con el pc se queda en versión 1.7.62 sin dar la opción de subir a 64... estoy muy decepcionado ya quye se supone que una marca como tomtom no deberia de cometer estas cagadas.
  • alga921
    alga921 Registered Users Posts: 4
    Master Traveler
    Hello again @lampard - a little update - unfortunately, nothing has changed on 1.7.64.
    So, maybe could You rollback my watch to any previous version of firmware?
    I heard that the 1.3.255 version is the most stable for spark 3.

    Thank You in advance, alga921
  • Sammiibris
    Sammiibris Registered Users Posts: 2
    Apprentice Seeker
    @lampard how do i arrange for the 1.7.64 upgrade, my connect tells me I am still on 1.7.62. Up until 2 days ago I was able to sync and now its just not working I have a HTC Ultra. Hope you can hlep thanks.
  • lampard
    lampard Administrators Posts: 5,966
    Moderator
    @Sinnedje @Inverno @oliviera9 @Nguyen Quang @BombCyclone @AdamP187 @Militaru_Andrei @ilary.sedda @Stickwood1 @McJoe @LFWBCH @Weary @Mandy379 @tom.lungu @Peachycheek @Eric Huskes @jwkyle @sdegelaen @tc893205 @boscoreli77 @Sammiibris @Ski4ever I've linked your account to the firmware version 1.7.64, please connect your watch to computer and Sports Connect will offer the software.

    @Thilivren @fionad You already have the version 1.7.64 installed on your watch.

    @alga921 I've now put you on the version 1.3.255, please make a factory reset again and the update will be offered to you in Sports Connect software. Let me know!

    @matti56 Which smartphone are you using? We currently have issues with Huawei P8/P8 lite phones with no workaround available but I would advise you to follow the steps in the public FAQ here to troubleshoot the pairing issues by removing the existing Bluetooth connection form your smartphone: iOS

    Cheers, lampard
  • N8b5150
    N8b5150 Registered Users Posts: 2
    Apprentice Traveler
    @lampard I am on 1.7.62 and can't connect or sync via the mobile app on Android. Can you link me to 1.7.64?
  • fionad
    fionad Registered Users Posts: 9
    Apprentice Traveler
    I do have 1.7.64. It is still not pairing. Same issue.
  • danniiwhincup
    danniiwhincup Registered Users Posts: 1
    Apprentice Traveler
    @lampard I am on 1.7.62 too and can't connect or sync via the mobile app on Android. Can you link me to 1.7.64? Thank you. Dannii x
  • alga921
    alga921 Registered Users Posts: 4
    Master Traveler
    @lampard - I did a factory reset - so far so good :) Although my watch works a little bit slower now than on the 1.7.62&1.7.64 (it reminds me my old runner), the sync works very good and fast - finally :)

    Thank You for Your help :)
  • Zeldaqueen
    Zeldaqueen Registered Users Posts: 2
    Apprentice Traveler
    Hi.....
    I found this forum and hope someone might be able to help!!
    I’ve had my Tomtom watch a few months now and never been able to connect the Bluetooth to my phone - reading this it seems like there is a firmware issue!
    My watch has firmware 1.7.64, so is there anyway I can change it to get it onto a firmware that will sync with my phone?

    Many thanks in advance.
  • Jurassicc
    Jurassicc Registered Users Posts: 1
    Apprentice Traveler
    Hi can you make the 1.7.64 update available to my runner 3 please, its not showing.
  • oliviera9
    oliviera9 Registered Users Posts: 2
    Apprentice Traveler
    @lampard Hi Lampard, thanks for releasing 1.7.64 for me. I updated the watch and now it had success pairing it with my iPhone 6s. Many thanks!
  • fyn1000
    fyn1000 Registered Users Posts: 1
    Apprentice Traveler
    Hi @lampard
    I updated my watch at the weekend to 1.7.64 and now it wont connect to either my phone (Nokia 6), my Tom Tom headphones or my Tom Tom heart monitor. Basically the bluetooth appears to failing. No problems with the previous version that was running on the watch with any of the above bluetooth devices.
    Therefore would you mind doing the rollback for my Runner 3 so I can connect everything back up.
    Thanks
  • Thilivren
    Thilivren Registered Users Posts: 3
    Neophyte Traveler
    You wrote: "Thilivren You already have the version 1.7.64 installed on your watch."

    I know I'm on 1.7.64. That's why I asked for a rollback to an earlier firmware version (due to sync issues on my current version).

    Regards,
    Thil
  • Zeldaqueen
    Zeldaqueen Registered Users Posts: 2
    Apprentice Traveler
    oh actually I just noticed I’m on 1.7.62......so can I manually upgrade to 1.7.64? As it doesn’t automatically do it when I connect the watch to the laptop :-)
  • richardhaupt
    richardhaupt Registered Users Posts: 2
    Apprentice Traveler
    Hi. I'd also like the 1.7.64 update please. Having the same mobile syncing issues.
  • TUS001
    TUS001 Registered Users Posts: 2
    Apprentice Traveler
    I'd also like to request 1.7.64 or whatever version that will make my watch able to pair via bluetooth with my iPhone again. It haven't been able to pair it for several months already...
This discussion has been closed.