Sports band isn’t charging

sophg
sophg Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
I charged my TomTom sports touch cardio and body composition band. It then worked for roughly a minute and then switches off so it doesn’t work then shows a message ‘*charger icon* tomtom.com/123’.
I’ve tried this link however does not help. This band is second hand so could be broken however as anyone experienced this?

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,953
     Superuser
    You may want to call Customer Support to ask them about it, but I would try a factory reset first in case it is just an issue in your firmware install. To do a factory reset, make sure the Connect software is running and dock the device to your computer. The Connect window will open; press the gear at the top right and select factory reset from the next screen. Follow the steps provided and when prompted to register or sign in to MySports, select sign in and use your existing account credentials. It is fairly straightforward and should take less than 5 minutes.

    To get the number for Customer Support, choose Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.