Disgusted with TomTom — TomTom Community

Disgusted with TomTom

Live Services stopped working on my Via Live 120 after the last update. When pressing the live services button it told me that information sharing needed to be switched on. There is not option on the device for this. Having searched the web for instructions, I was told to click on the 'Me and My Device Button' under 'Settings'. This button is not on my device and so I called TT support. After two failed attempts to resolve by sending new files to my account I called a third time; I was asked to send screen shots and it would be escalated to third line support. After no contact for 24 hours, I called again only to be told that the problem is the SIM card and the device is too old to repair. I don't believe the SIM card suddenly failed as when I placed a response on a question yesterday, I was told that the SIM card needed reactivating, so obviously something has been done to deactivate the card.
It only started after the last update which I was prompted into doing after getting an email encouraging me to download an 'important update'.
I am convinced the update has nobbled my device and I now have subscriptions to map updates and live service for a device that is no longer fit for purpose - TomTom's response? - Sorry
I appreciate that devices can't be supported for ever, but there was no warning about my device becoming obsolete, has I known I might have been encouraged to buy a new device - but not now. I'm utterly disgusted by TomTom's attitude. I've asked for a refund of my map updates and live services. I will have to buy a new device, but it will definitely not be a TomTom, not after this experience and complete lack of customer respect.

Comments

  • fransysfransys Posts: 3 [Apprentice Traveler]
    As I said in the thread I posted for the same issue...
    So...
    it seems I solved. With map 6 (if I remember well) the button on menu for sharing information (me and my device ) was not present, I changed the map with a lighter one (in terms of MB) ans I was able to share info... the bar with traffic again present. I didn’t used yet for a travel but it seems OK.

    I hope This should help who has the same issue.

    Let me know if this works also with you.
  • YamFazManYamFazMan Posts: 17,762
    Superusers
    Hi
    To share information using a NAV3 Device....
    From the main menu
    Tap (Settings)
    Left Cursor once for next page
    Tap (Me and My Device)
    Tap (My information)
    Tap 'Yes'
    Follow on-screen prompts to exit

    ATB YFM
  • IggyPIggyP Posts: 5 [Apprentice Traveler]
    Thanks Fransys (& YamFaxMan),
    After the last update I lost the 'Me & My Device' button, so couldn't turn on Info Sharing. Neither did I have access to any other map rather than Europe, however, when calling TomTom support for the fifth time (this time to find out where my refund for services I can't use was), I again explained how disappointed I was that after being a TomTom promoter over the years and paid continuous Live Services subscriptions, to have my device effectively nobbled by an update only to be told tough luck it's too old for a repair. I mentioned that forum advice suggested that the SIM card needed reactivating and that TomTom support had advised that the SIM card couldn't be repaired.....

    An hour or so later I got a phone call back from TomTom advising that they'd sent a copy of Western Europe to my account and to try and load that to see if the 'Me & My Device' button reappeared. Lo and behold, followed the instructions, the button was there enabling me to turn on Info Sharing - normal service has been resumed and I was then able to reload Europe - faith restored (almost) in TomTom, just a shame I had to jump up-and-down.

    Thanks everyone for their help
  • VikramKVikramK Posts: 10,466 Moderator
    Thanks IggyP

    Glad to know that this has been resolved.

    We had sent a heads up to the customer service yesterday to try the suggestion that 'fransys' gave above.

    So a big thank you @fransys, all credit to you...

    All good now:)

    Cheers,
    Vikram
  • IJHIJH Posts: 1 [Apprentice Traveler]
    I have a Go Live 1000 which has lost the 'Me & My Device' button and has lost the live services. The website tells me that my system is no longer supported so how do I get the services back? or is it time to go to another manufacturer.
  • YamFazManYamFazMan Posts: 17,762
    Superusers
    Hi
    Have you tried a Drum roll restart on the device ????

    https://uk.support.tomtom.com/app/answers/detail/a_id/6965//session/L2F2LzEvdGltZS8xNDI2NjM0NDUyL3NpZC9EQTdTVHpobQ

    Charge the device for at least 2Hrs "OR" have the device plugged into a power supply
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles......

    If possible, for the for the first Satellite fix, go outside with a clear view of the Sky

    ATB YFM
  • [Gelöschter Benutzer][Gelöschter Benutzer] Posts: 5,321 [Supreme Trailblazer]
    IJH wrote:
    I have a Go Live 1000 which has lost the 'Me & My Device' button and has lost the live services. The website tells me that my system is no longer supported so how do I get the services back? or is it time to go to another manufacturer.
    https://en.discussions.tomtom.com/news-and-announcements-37/end-of-life-for-tomtom-devices-with-2gb-internal-memory-1031975
  • Dave DaleDave Dale Posts: 2 [Apprentice Traveler]
    I have the same issues (no "me and my device" button and no live services) when I have the latest full Europe Camper v10.10 map installed on my Go Live 1005/GoLive Camper and Caravan device (ST serial). There is 2073MB free, so space is not an issue. If I choose to install any of the zones, rather the full map, the "me and my device" button is available, and I can use the live services. I have repeatedly tried to download the full map, but no improvement. My subscription is due for renewal in August, but if I cannot get this issue fixed I will probably buy a new Garmin, and certainly not renew my subscription,
  • dhndhn Posts: 33,313
    Superusers
    Seek support assistance then:

    :flag_gb: United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    But first, try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds. See if that helps...
  • YamFazManYamFazMan Posts: 17,762
    Superusers
    Hi
    @Dave Dale

    Check....
    From the main menu
    Tap (Settings)
    Right Cursor Once for next page
    Tap (Network)
    Is the Network... Showing as connected ???

    Are the MCC/MNC:
    SIM ID:
    IMEI:
    And Model: Information all available

    Follow on-screen prompts to exit
    ____________________

    Check....
    From the main menu
    Tap (Live Services)
    Tap (My Live Services)
    Check if your Live Traffic subscription is still valid
    Follow on-screen prompts to exit
    ____________________

    The RF shielding on my PC sound system is not very good, and I can hear the Tomtom SIM Data exchange and the Card logging in/out

    Also If you have a small portable AM Radio set to around 800kHz you can hear the SIM card Data exchange and the Card logging in/out

    ATB YFM
  • Dave DaleDave Dale Posts: 2 [Apprentice Traveler]
    Thanks for replies:
    drum roll reset does not fix the problem
    When full map is installed, no SIM details, although there is 2073MB free space, when only a zone of the map is installed SIM details are shown and all is OK
    I have confirmed that my Live Traffic is still valid until September.
    I have contacted TomTom support, and will report any progress.
Sign In or Register to comment.

Who's Online in this Category0