TomTom Go Live 1000 "Flashing Function" doesn't work anymore

Since one week I don't receive the indications of approaching fixed flashers anymore (no pictogram and aural alert). I haven't tested the traffic control flashers yet but I assume that the problem will be the same. I have an annual contract for flashers updates wich is valid till Jan 2019. I've already taken following actions in order to resolve my problem:
1. Via My Drive Connect:
a. I Installed the most recent updates;
b. I de-activated and then re-activated the flasher system;
2. On my navigation system in the car:
a. I checked that all parameters for flashers are set i.a.w. TomTom user manual;
b. I performed a reset of my product i.a.w. the TomTom user manual;

My problem remains unsolved.

Has someone in the community faced the same problem? How was it fixed?

I've also tried to transmit my questions to TomTom via the foreseen support link but the link isn't working. A direct communication with TomTom isn't possible neither.

Can someone help me out? If TomTom employees are following this forum, can I get an e-mail where I can send my questions directly to?

Thanks for your support!


  • dhndhn Posts: 33,155 Superusers
    Not sure what you mean by 'flashing function' but support:

    du lundi au vendredi de 09h00 à 17h30

    Maandag t/m vrijdag van 09:00 tot 17:30
  • Richard SinnaeveRichard Sinnaeve Posts: 3 [Apprentice Traveler]
    Thanks for your reply, I'll try to contact TomTom using the tf numbers you gave me. When I'm talking about the flashing function I mean the TomTom service through which the user is informed (pictogram on the screen and an aural alert) when the car approaches a fixed flasher on the road (traffic lights, ..). Of course only if this service is activated via My Drive Connect (and payed through an annual license).
  • Richard SinnaeveRichard Sinnaeve Posts: 3 [Apprentice Traveler]
    I've contacted the TomTom Support Team using the telephone number that you provided. After several up and down conversations the problem is solved applying a hard reset of my navigation system. Thanks again for your support!
Sign In or Register to comment.

Who's Online37

+35 Guests