Software version Rollback requests | Battery issues | Runner & Spark watch series - Page 9 — TomTom Community

Software version Rollback requests | Battery issues | Runner & Spark watch series

16791112102

Comments

  • starfleetyajstarfleetyaj Posts: 42 [Legendary Explorer]
    FWIW, I am running 1.7.53 and it's synching fine. However, I'm still on iOS 10.3.3 and have not updated yet to 11.0.3 so I'm sure that's part of it. I also had trouble with QuickGPS not updating correctly after the update, but that was fixed by resetting the watch.

    One item I've not seen mentioned anywhere is the connection to BT headphones (mine are SoundBot 556). That has stopped working for me.
  • JürgenJürgen Posts: 5,053 Community Manager
    Jacco_NL wrote:
    Jurgen, please set me also back to the older firmware version.

    Thanks in advance!
    You can now return to the old software by doing a factory reset.
  • ou999ou999 Posts: 74 [Prominent Wayfarer]
    Do we have an insight which phones (+firmware) work correctly with which Spark model 1.7.53?
    I have iOS 11.0.3 on an iPhone 6. Should I expect my Spark 2 Cardio + Music to work correctly once I update it?
  • Sidhartha AnireddySidhartha Anireddy Posts: 10 [Master Explorer]
    Hello Jurgen,

    I have connected my watch to the phone and did the factory resetting. However I am still at version 1.7.53, please advise what am I missing here? Your quick response will be appreciated Thank you.

    Best Regards,
    Sid
  • JürgenJürgen Posts: 5,053 Community Manager
    ou999 wrote:
    Do we have an insight which phones (+firmware) work correctly with which Spark model 1.7.53?
    I have iOS 11.0.3 on an iPhone 6. Should I expect my Spark 2 Cardio + Music to work correctly once I update it?
    The issues should not be related to any particular phones. It is very unlikely that you run into any trouble if you update.
  • JürgenJürgen Posts: 5,053 Community Manager
    Hello Jurgen,

    I have connected my watch to the phone and did the factory resetting. However I am still at version 1.7.53, please advise what am I missing here? Your quick response will be appreciated Thank you.

    Best Regards,
    Sid
    Hi Sid,

    I assume you want to return to the old build. This only works after we have manually linked your account to the old build. I have done that now.

    Regards,
    Jürgen
  • Sidhartha AnireddySidhartha Anireddy Posts: 10 [Master Explorer]
    Dear Jurgen

    Thank you very much I was able to downgrade to a lower version. Hopefully the next release will fix the issue and give us the opportunity of using the new features (VO2 MAX, fitness age etc.) offered by 1.7.53.

    Thanks,
    Sid
  • James_0121James_0121 Posts: 15 [Legendary Explorer]
    Hi please revert me to the previous firmware. I am trying to do a marathon on Saturday and this is not correct that the connection stops working very disappointed. Thnaks
  • James_0121James_0121 Posts: 15 [Legendary Explorer]
    I must add I've never seen such poor customer service, Im now back from a run spending another hour trying to link my watch to my phone (the app says connect for first time (yet the watch says connected) So I must now delete the bluetooth connection in IOS, re try to sync the watch via the app and pair it again (the waiting code then comes up as incorrect on the app) so I then go through same process again and again. This is just one issue with this software and happens each time I run. Ive emailed tomotm facebook and get no reply also. Very sad as I loved this product now like others I've lost hope of it being fixed!....
  • JürgenJürgen Posts: 5,053 Community Manager
    James_0121 wrote:
    Hi please revert me to the previous firmware. I am trying to do a marathon on Saturday and this is not correct that the connection stops working very disappointed. Thnaks
    You can now do a factory reset to return to 1.3.255.
  • ou999ou999 Posts: 74 [Prominent Wayfarer]
    Jürgen wrote:
    The issues should not be related to any particular phones. It is very unlikely that you run into any trouble if you update.
    Hi Jürgen,
    Do I understand you correctly that you think that most users do not suffer from the bugs that people are mentioning here? So it is still quite safe to upgrade? What are the risky configurations in your opinion?
  • James_0121James_0121 Posts: 15 [Legendary Explorer]
    Thanks but now when I go to connect the watch to my iPhone the watch quickly give the bluetooth pin then slides back again when I try to put in it says 'incorrect pin' this is awful I cant even use the watch now. Can you please refert the watch back to the new Firmware like I had before I will just need to keep trying to get it working again. Thank you.
  • Jacco_NLJacco_NL Posts: 4 [Apprentice Traveler]
    Jürgen thanks. Firmware downgrade succeeded. Bluetooth works again.

    I hope next firmware update with fix will follow asap.
  • eMeLeMeL Posts: 2 [Apprentice Traveler]
    Hi Jürgen,
    Can you restore the previous WORKING version on my watch as well please?

    Thanks
  • madmausmadmaus Posts: 65 [Prominent Wayfarer]
    Hi Jürgen, can you please link my account to 1.3.255 (havent updated yet but i am not planning to update due to this massive problem).
  • dbirddbird Posts: 4 [Apprentice Traveler]
    dbird wrote:
    Ever since my spark 3 was updated to the 1.7.53 firmware, it takes 10 seconds for it to wake up before doing anything. Like, when I plug it into the USB port, it takes 10 seconds for the mysports app to come up and start looking at it, and from the clock display, if I haven't messed with the watch for a while, it takes 10 seconds for it to respond to a click on the control button. After the 10 seconds, it's awake so I can look and set the different configurations. But, if I leave it alone it goes back to sleep and just tells time. Then it will take 10 seconds again to wake up.

    Is anyone else having this problem?

    All of these issues have disappeared. The firmware level is the same. The only thing that seems to have changed is that I discovered that one of the apps on my system had been doing a backup of a bunch of files to the watch. I deleted all the extra files, and stopped the app from doing this, and the watch has recovered fine. Battery life is now normal, it isn't hard to wake up because it doesn't go to "sleep" as described above, and now syncs OK as long as I have sync set to "ON".

    My only beef now is that the sleep functionality still sucks. It gives mostly wrong values for overnight sleep as well as naps. Sometimes it gives zero, sometimes it detects sleep when there is none, and it give wild numbers everywhere between. I really wish you guys would put some serious effort into the sleep functionality. Fitbit has you beat in this department hand down.
  • madmausmadmaus Posts: 65 [Prominent Wayfarer]
    madmaus wrote:
    Hi Jürgen, can you please link my account to 1.3.255 (havent updated yet but i am not planning to update due to this massive problem).

    I figured out that I wanted to try the update first before shooting it.
    So dont place me on the previous firmware yet.
    Thanks.
  • veloblurveloblur Posts: 4 [Apprentice Traveler]
    madmaus wrote:
    I figured out that I wanted to try the update first before shooting it.
    So dont place me on the previous firmware yet.
    Thanks.

    So does it work for well for you?

    Regards.
  • madmausmadmaus Posts: 65 [Prominent Wayfarer]
    veloblur wrote:
    madmaus wrote:
    I figured out that I wanted to try the update first before shooting it.
    So dont place me on the previous firmware yet.
    Thanks.

    So does it work for well for you?

    Regards.

    It does seem to work for now.
    I can still sync and notifications are working (needed to reinstall sports app).
    I don't need notifications so I switched it off.
    Haven't tried running yet but do far do good.
  • veloblurveloblur Posts: 4 [Apprentice Traveler]
    madmaus wrote:
    It does seem to work for now.
    I can still sync and notifications are working (needed to reinstall sports app).
    I don't need notifications so I switched it off.
    Haven't tried running yet but do far do good.

    I just updated my wife's brand new Spark 3 to 1.7.53 (since the TomTom program refused to do anything until the watch got updated). It took several tries to pair with a Moto G4 Plus, mainly because when the phone discovered the watch and the watch showed the pin code, nothing seemed to be happening. It just suddenly paired and managed to sync properly.

    So I'll keep monitoring to see if it experiences battery drain as well as difficulty in syncing as reported by others here.
  • Remo11Remo11 Posts: 4 [Neophyte Traveler]
    Hi Jürgen,
    Can you restore the previous WORKING version on my watch as well please?

    Thanks
  • Mark AllegrettiMark Allegretti Posts: 3 [Apprentice Traveler]
    Jürgen I have been having issues with my Spark 3. Could you link my account to the previous build so when I factory reset the old build will be installed?
  • paddyrumpaddyrum Posts: 4 [Apprentice Traveler]
    Hi Jürgen, I'm also experiencing sync issues. When pairing, the watch displays the code but the app doesn't enter the screen where you can type the code in. Please link my account to the previous build & I'll do (another) factory reset.
  • ushidushiushidushi Posts: 3 [Apprentice Traveler]
    Hi Jürgen, i'm also having issues with the V. 1.7.53 update on my spark. Watch is unable to BT connect to my phone. Can i also get a rollback to the previous 1.3.255? Thanks in advance.
  • KuunlanKuunlan Posts: 6 [Master Traveler]
    Jürgen wrote:
    Godoy, Cidraque, Pascal,
    If you now do a factory reset you'll return to 1.3.255.

    could you reroll me too please, having the same issue.
Sign In or Register to comment.

Who's Online43

ArjenP76
ArjenP76
Elchdoktor
Elchdoktor
GO Mobile iOS
GO Mobile iOS
Jim07
Jim07
Jopi1956
Jopi1956
Justyna
Justyna
miketorcy
miketorcy
MJH48
MJH48
NOG
NOG
ploum115
ploum115
RJ45
RJ45
Rostyslav_Moroziuk
Rostyslav_Moroziuk
+31 Guests