MyDrive Connect and Windows 10 display scaling (15'' 4k display) — TomTom Community

MyDrive Connect and Windows 10 display scaling (15'' 4k display)

ZappAstrimZappAstrim Posts: 4 [Neophyte Traveler]
edited January 2019 in MyDrive Connect
Hello TomTom. I have a TomTom Go 5000 and recently bought a new Dell XPS 9550 laptop. It's a lovely machine and has a 4k display integrated into it.

Unfortunately the TomTom Mydrive Connect App doesn't seem to understand display scaling in Windows 10 and the text is miniscule. Attached is a screenshot of my issue.

Could you please look into this, as it's quite hard to update my device with the teensie buttons and text. Version number is


  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi ZappAstrim,

    Thanks for reporting this!

    We've received similar feedback and are looking into it. I'll log your feedback for the product team to consider.

    Could you also mention the resolution you're using in your screenshot, please?

    Cheers, Mikko
  • ZappAstrimZappAstrim Posts: 4 [Neophyte Traveler]
    Hi, thanks for getting back to me. The resolution is 3840x2160 pixels.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Thanks, ZappAstrim!

    I'll add that to the ticket.

    Cheers, Mikko
  • VikMinVikMin Posts: 2 [Apprentice Traveler]
    Exact same issue but on a 27" monitor.
  • berndirelandberndireland Posts: 1 [Apprentice Traveler]
    I have the same trouble with a Lenovo Yoga 910, are there any news for that issue?
  • gardenigardeni Posts: 3 [Neophyte Traveler]
    Same issue here. Please add zoom - cannot be that hard.
  • Sir DancelotSir Dancelot Posts: 2 [Apprentice Traveler]
    Me too. 8 months later...MyDrive Connect I have the same resolution issue, still using a loop to read my screen! :(
  • Michael99Michael99 Posts: 1 [Apprentice Traveler]
    One More! TomTom, its beyond time to resolve this issue. Many of the same tech minded customers who buy tomtom products also buy 4k monitors. As of now, we're all using a magnifying glass to update our products. I know its somewhat inconvenient to update your products, but most have already got it done. Why are you asleep at the wheel? 4k is far from cutting edge tech.
    I'l be buying a 3rd GPS unit within the next month or two, and this defect will likely prevent me from purchasing another tomtom.
  • Penray4Penray4 Posts: 2 [Apprentice Traveler]
    It took only a couple of hours for me to write a patch to automatically resize the forms on software that I have written to work with a 4K screen. Actually it requires only one setting in the IDE and Windows will take care of it for you, but I chose to do it myself. If TomTom is not going to fix this, then I guess I will have to find a company that will.
  • vincedovyvincedovy Posts: 5 [Master Traveler]
    I have the same issue, I see the thread was started a year ago, why hasn't this been fixed?
  • LAURE123LAURE123 Posts: 1,632
    edited June 2020
    Hi all,

    It's just a workaround that I can't check myself, I don't have a 4K screen. But maybe it will work, it doesn't cost anything to try. You understand I'm not sure of the result.

    Edit of June 08, 2020

    You can try this:
    1/ Close and Quit MyDrive Connect:
    Close the MDC window then Right-click on the MDC icon in the taskbar next to the clock, if necessary click on the symbol ^ to find the MDC icon, choose "Quit".

    2/ Open Windows "Task Management" and check if there is still a MDC process in background to stop it:
    ==> In your taskbar / Right-click in any open place / Task Management / "Processes" tab / if you find "TomTom MyDrive Connect.exe * 32" ==> Right-click / "End Process"

    3/ Change MDC compatibility properties:
    - On the MDC launch icon ==> Right click/Properties/Compatibility tab/ check 'Override high DPI scaling behavior, scaling performed by:'/ in the list, select 'System (enhanced)'/Apply/OK

    4/ Restart MDC again.

    See if this brings an improvement to the MDC display.


    former message of April 01, 2018
    - On the MDC launch icon you are using (Windows desktop, Start menu, taskbar)

    For Windows 10:
    - Right click / Properties / Compatibility tab / check Override high DPI scaling behavior, scaling performed by: / in the list, select Application / Apply / OK
    - Restart MDC again.

    For Windows 7 SP1 and Windows 8.1:
    - Right click / Properties / Compatibility tab / check Disable display scaling on high DPI settings / Apply / OK
    - Restart MDC again.

    This will be repeated at each new installation of MDC.

  • YamFazManYamFazMan Posts: 19,680
    Good find... 'I hope it works'

  • LAURE123LAURE123 Posts: 1,632
    @YamFazMan I hope too.
  • vincedovyvincedovy Posts: 5 [Master Traveler]
    Thanks. Tried it again just now, doesn't work. I have tried multiple settings in the compatibility tab and no joy. :disappointed_relieved:
  • LAURE123LAURE123 Posts: 1,632
    Really sorry for you that it doesn't work. :disappointed:
  • Sir DancelotSir Dancelot Posts: 2 [Apprentice Traveler]
    It's probably the 'after' part of 'aftersales' that is the culprit here... Typical fix: "The new Rider doesnt need the sw any longer, so why don't you all just buy it?" (!)
  • Sam and PhilSam and Phil Posts: 6 [Master Explorer]
    right TomTom, it's time you fixed this issue. Scaling an app is child's play, yours is quite simply the only one I use that is unable to keep up with improved monitor resolution.
    My laptop is "meh" quality but I cannot see the text on my connect because you are incompetent. There is no other reason.

    For all the other affected users, here is a simple work around
    (Tom Tom this is not sufficient for you to continue to ignore this issue - get it fixed or lose customers)

    Go to "display settings" and change resolution to something like 1600x900 (yes back to the stoneage), use my connect, go back to the display settings and revert to your original resolution.
  • PhunkyPhishPhunkyPhish Posts: 1 [Apprentice Traveler]
    Funny how so many of these other threads are closed?!
    To be honest, 1 year and no resolution (Excuse the pun) is NOT customer service.
    I for one will not buy another TomTom unit again, and neither will my business which has a decent size fleet.
    Garmin, come take my money!!
  • janetnz60janetnz60 Posts: 2 [Apprentice Traveler]
    I have the same problem and have tried various settings - nothing works. This is really frustrating. I installed an update to MyDrive today and was asked if the display was correct. I answered no, it then asked again and when I said no, said I needed a different version of MyDrive, which I downloaded. Still the same issue, which appears to have been going on for a year. Come on TomTom - fix it please!!!
  • Victor VellaVictor Vella Posts: 1 [Apprentice Traveler]
    I have the same problem with the Tom Tom My drive software on my new Dell XPS. so what is the fix.
  • MEL6MEL6 Posts: 3 [Neophyte Traveler]
    I have same problem even with glasses on I can barely read the login window and update pages
    This makes it hard to update my Tom Tom, I use Windows 10 on a Dell XPS laptop with high resolution monitor.

    Have tried a few settings but can not find anything on the My Drive software that can be modified to correct this problem
    Can any body help
  • NiallNiall Posts: 10,959

    There is an outstanding incident "Font size of MyDrive Connect CCARE-2673" that I started back in May 2017 :(
  • DripLeBuk120DripLeBuk120 Posts: 14 [Outstanding Explorer]
    The suggestion by LAURE123 to enable the Compatibility mode’s Override high DPI scaling behaviour works better when the ‘System (Enhanced)’ option is selected. The main MyDrive Connect display to maintain your device is now much larger, but this mode prevents you accessing the MyDrive Connect ‘Settings’ menu item. To access this you will need to revert the above change. I have tried this using MyDrive Connect with all three Graphics modes now available.
  • LAURE123LAURE123 Posts: 1,632
    Hi @DripLeBuk120

    Thank you for trying my suggestion and for your feedback. :slight_smile:

    So, it's better like this:

    For access blocked to "MDC settings" after "Override high DPI scaling behavior", it was using the "flag" at the top right of the MDC window?
    Have you tried to access the "MDC Settings" by right-click the MDC icon in the Windows taskbar next to the clock?

  • DripLeBuk120DripLeBuk120 Posts: 14 [Outstanding Explorer]
    I tried only via right-click the MDC icon. I get a blank white window appearing in the preview when highlighting the icon in the Taskbar, but it won't expand on the desktop when selected.
Sign In or Register to comment.

Who's Online in this Category0