Go 5100 not connecting to Surface Pro 4 — TomTom Community

Go 5100 not connecting to Surface Pro 4

I have just purchased a Tom Tom Go 5100. However it keeps disconnecting from my Surface Pro 4 after 15-seconds. This is very annoying. I have just read somewhere that Tom Toms are not compatible with Surface Pro 3’s and 4’s. Is this true or is there any easy fix to this? If no fix is available, this £200 piece of kit is getting returned.

Comments

  • YamFazManYamFazMan Posts: 14,958 Superusers
    Hi
    It's not the Tomtom device that's the problem, its Microsoft & the Surface Pro 3 & 4

    The Computer Manufacturers appear to be setting "USB Selective Suspend" to ON as default
    Especially Laptops, maybe to improve the look of the battery life

    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu
    You have to edit the Registry for the USB Selective Suspend menu to show

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work

    See….. http://discussions.tomtom.com/t5/GO-and-START-40-50-60-series-GO/Random-Disconnects-on-Surface-3-Pro/m-p/970071#M21680

    See..... http://discussions.tomtom.com/t5/TomTom-Traffic-LIVE-and-other/Microsoft-Surface-Pro-3-Not-compatible-with-Tomtom/m-p/970834#M21038

    See….. https://en.discussions.tomtom.com/rider-51/update-fail-tomtom-rider-410-on-a-microsoft-surface-pro-3-windows-10-1025704?postid=1177921

    ATB YFM
    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon
    ____________________________

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
    ____________________________
  • Driver1980Driver1980 Posts: 4 [Apprentice Traveler]
    It’s not TomTom with the problem, it’s the Surface Pro?? Please... ?

    The TomTom is getting returned to the shop tomorrow. None of my other devices have had this issue in the 2 years I’ve had my Surface Pro 4. Clearly TomTom can’t be bothered to fix a problem which seems to have been reported many years ago. Oh well, back to Garmin I reluctantly go.
  • bigbig Posts: 1,552 Superuser
    Another option in addition to the easy fix noted in the above threads is to exchange your 510 for the equivalent WiFi enabled model (the Go 520 in your case). Then you don't need a computer at all to update.
  • Driver1980Driver1980 Posts: 4 [Apprentice Traveler]
    @big The 5200 is possibly the answer. Will have to review costs of that vs Garmin and take it from there. The 5100 is definitely getting returned though. Messing about with my registry and impacting other functions on my computer isn’t worth the hassle. Surface Pro users beware!
  • YamFazManYamFazMan Posts: 14,958 Superusers
    Hi
    Driver1980 wrote:
    Messing about with my registry and impacting other functions on my computer isn’t worth the hassle. Surface Pro users beware!
    Really :?
    I've been using the Registry Mod on my Surface Pro 3 and Win10 Linx 10/10 Tablet for around 18 Months without a single glitch

    ATB YFM
    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon
    ____________________________

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
    ____________________________
Sign In or Register to comment.

Who's Online49

blader
blader
Elchdoktor
Elchdoktor
peter_n
peter_n
Pinki
Pinki
tallpall
tallpall
tgold
tgold
+43 Guests