Sparks 3 Battery completely empty, not showing charging picture on screen

ronaelle
ronaelle Registered Users Posts: 2
Apprentice Traveler
edited January 24 in TomTom Sports
I went on holidays for two weeks without my sparks 3 and have come back wanting to go for a run. The battery is completely emptied (I assume, after two weeks) and when I connect it to a power source (plug point or computer) it shows the battery with a slash but it does not show that it is charging. Has anyone else experienced this? Do I just leave it plugged in and hope for the best?

Comments

  • tfarabaugh
    tfarabaugh Posts: 16,948
     Superuser
    I would check the dock and make sure it is fully engaged and that none of the pins are bent. If that doesn't work, plug it into a computer a do a factory reset. If it does not respond to being plugged in it is likely the dock is bad if it worked before. To do a factory reset, make sure the Connect software is running and dock the device to your computer. The Connect window will open; press the gear at the top right and select factory reset from the next screen. Follow the steps provided and when prompted to register or sign in to MySports, select sign in and use your existing account credentials. It is fairly straightforward and should take less than 5 minutes.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • ronaelle
    ronaelle Registered Users Posts: 2
    Apprentice Traveler
    Thanks for the advice. The pins are fine. The contacts on the watch itself are bit of colour so I tried rubbing them a bit and now it is happily charging. Coincidence or not, who knows. Is it normal that the contacts go slightly black?
    The watch is now updated and charging but I cannot sync it so one problem solved, the next already here...
  • tfarabaugh
    tfarabaugh Posts: 16,948
     Superuser
    The black is a buildup of dirt and sweat. You should wipe the back of the watch off (contacts and LEDs) after each use. I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.