New activities not updating for a long time — TomTom Community

New activities not updating for a long time

BobCatMaxBobCatMax Posts: 22 [Master Traveler]
Runner 2 Cardio/Music on firmware 1.3.255. not had a problem until a week or so ago (although I haven't been using the watch much, so it could be as much as a couple of months that this has been happening)

The watch syncs fine, it says so on the app, but the activities don't appear in the phone app or website for a very long time, at least a few hours if not more.

Does anyone have any ideas about what might be causing this? And no, id' rather not update the firmware just yet after reading about all the fun everyone is having with it!



  • charlesrrcharlesrr Posts: 67 [Outstanding Wayfarer]
    Phew, not just me then! It started happening to me yesterday. I thought I had lost the data because it didn't appear immediately as normal, but it appeared (and synced to Strava) a few hours later. Same thing will happen today I think - it spend a few minutes uploading the data from the watch and now nothing is appearing. Fingers crossed it's just a temporary lag.

    I did get downgraded to 1.3 a couple of days ago, but on that day, the sync upload to the Sports app and Strava was speedy as usual, so I suspect it's unrelated to the version and is just a temporary server queue thing.
  • charlesrrcharlesrr Posts: 67 [Outstanding Wayfarer]
    Yep, the activity eventually appeared.
  • BobCatMaxBobCatMax Posts: 22 [Master Traveler]
    Yeah, it does eventually. Thursdays took a little over 3 hours, and this mornings turbo session took 35 mins. I guess it depends on how busy the tomtom servers are?
  • ChampionAdamChampionAdam Posts: 12 [Legendary Explorer]
    Mine NEVER updates until I either force stop/restart the app, or restart the phone. After you're SURE that the phone/watch has synced, try restarting the phone. You might need to wait a few senconds after starting the app (after phone restart), but in my experience this works every time.
  • charlesrrcharlesrr Posts: 67 [Outstanding Wayfarer]
    How bizarre. That actually worked. Have you tried "force stop" in settings / apps, rather than reboot?
  • ChampionAdamChampionAdam Posts: 12 [Legendary Explorer]
    Yes, that's what I wrote. Either force stop/restart app or restart phone.

    It's actually quicker (on my phone at least) to restart the phone. Force stop/restart app is way more taps.

    I've reported this is support a million times via their auto bug-reporting thing, but they just come back with 'uninstall/reinstall' the app which makes no difference at all.

    If you want to drill down deeper, the file that is transferred from the watch to the phone during sync is put in a temporary folder (I can't remember what it's called) on the phone. The phone is then presumably supposed to send this on (sync) to the Tomtom cloud to sync with the main online record of your runs. For whatever reason, the file makes it as far as your phone but the app doesn't seem to read it from it's own storage, but rather than the cloud storage, and because the file doesn't get uploaded (as it should) it doesn't show your recent run.

    When you restart the app/phone, the file is discovered in the temporary folder (by the app) and uploaded (as it should have been when you synced). The app then (after a few seconds) can read the file from the cloud and shows your run.

    That's what I reckon anyway.

    It's pretty poor.
  • charlesrrcharlesrr Posts: 67 [Outstanding Wayfarer]
    Sorry, missed that! Just back from a run so was a bit spaced.
  • BobCatMaxBobCatMax Posts: 22 [Master Traveler]
    and as if by magick, the last two activities have synced within minutes! no restart needed. it's *almost* like someone was listening.....
Sign In or Register to comment.

Who's Online in this Category1