Bug with latest update

patpalloon Registered Users Posts: 106
Prominent Wayfarer
edited January 24 in TomTom Sports
I have spotted a bug with the latest firmware update (I have the Spark). Now the star system has replaced the badge - when charging the watch the star is displayed, not the battery icon so you can't tell when it is fully charged.


  • tfarabaugh
    tfarabaugh Posts: 16,948
    It is not doing it on mine. I still get the battery icon.
  • MikeW410
    MikeW410 Registered Users Posts: 4
    Apprentice Traveler
    On my Tom Tom Spark I still get the battery icon but since the upgrade it will no longer charge on my USB hub. I have changed cables, plugged into a different port on the hub but still will not charge. Battery icon comes on a a few seconds then disappears. All my other devices (headphones, mobile phone, iPad) charge fine from the hub but now the Spark watch will not charge. Up until the last update a few days ago it charged on the hub. In fact I have used the hub to charge the Spark for over a year. Spark still charges fine from the USB port on the computer though.