GPS is 100 miles adrift on my Mazda 5

Raspening
Raspening Registered Users Posts: 2
Apprentice Traveler
edited January 2019 in Built in car navigation
I have an integrated Satnav in my Mazda 5. My TomTom Live contract recently expired so I have just paid up and updated the SD Card. However, despite uploading the Quick GPS fix, the car now thinks that it is about 100 miles away from where it actually is. On my way back from work today, I have apparently driven most of the way through the hills, rivers and villages of Wales. I've not be anywhere near Wales.

How has this happened and how can I fix it?
Thanks

Comments

  • Niall
    Niall Posts: 11,140
    Superuser
  • Raspening
    Raspening Registered Users Posts: 2
    Apprentice Traveler
    Brilliant Niall.
    It works.
    Thanks
  • Niall
    Niall Posts: 11,140
    Superuser
    @Raspening

    Glad that you found that helpful
  • VikramK
    VikramK Administrators Posts: 14,298
    Moderator
    Hi Raspening

    I’m glad to hear you got it sorted! :)

    When you're satisfied that your question has been answered, please mark your topic as solved [How to FAQ] so that others with a similar question may find the answer easier.

    If you have further questions, don't hesitate to post back here :D

    Regards
    Vikram
  • MB3
    MB3 Registered Users Posts: 83
    Renowned Trailblazer
    Interesting. I've just had exactly the same with my Mazda 5. On Saturday the GPS was all over the place. When I went to the GPS settings option to show the number of satelites, it was jumping all over the place.

    On Sunday I got in the car and the GPS worked fine for 30 minutes, but then completely lost it. After an hours driving, the GPS thought I was over 100 miles away in the opposite direction.

    I tried the reset option from the main menu, but that didn't make any difference.

    Just updated the SDCARD with the latest quickstart GPS data and will try that.

    Failing that, will try the hard reset as shown in the manual.
  • MB3
    MB3 Registered Users Posts: 83
    Renowned Trailblazer
    I did the hard reset as described above and the gps location appeared to be fixed.

    Unfortunately a couple of days later and gps location completely wrong again. :-(