TomTom- No GPS Signal 2019 | Week Number Roll-Over | TIMER Reset 00.00 | Error-"You cannot use this map"

TomTom won't connect to my computer anymore



  • vblanche3vblanche3 Posts: 14 [Outstanding Explorer]

    I recently tried on another pc, at work, it worked immediately, so I don't have any issue with cable, or plug as I used everything as at home.

    I noticed that at home, everytime I plug the tomtom and that mydrive tries to connect, I'm getting a OS windows offering to do an autoplay on a newly installed drive under the letter I:, with the name "system reserved", saying general options: "open folder to view files..." as if the tomtom was a new hard disk.

    Can someone explain me what's happening?


  • NiallNiall Posts: 10,491 Superuser
    Hi Vincent

    Suspect that your PC at home is 64Bit and MyDrive is tricking Win7 into viewing the System drive which is normally a hidden drive, this is a known side-effect of My Drive. Also are you sure that you are not using a USB3 port.
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button :thumb_up:
    If someone answered your question? Answer yes to "Did this answer the question? Yes · No"
  • Dant3Dant3 Posts: 1 [Apprentice Traveler]

    I have VIA 280 ,and got the same problem.  Thank you notmeatall2 the procedure here works for me.  I also updated the adobe which I always ignore most of the time, and Im not sure if it had a relation to this problem..
  • vblanche3vblanche3 Posts: 14 [Outstanding Explorer]
    Hi, thanks for your help. So, what should I do then?


  • NiallNiall Posts: 10,491 Superuser

    Check in your system info part of your computers configuration pannel to see if you do have a USB2 port and try and connect to that.

    As to the "system reserved" drive, ignore it, no harm will be done.
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button :thumb_up:
    If someone answered your question? Answer yes to "Did this answer the question? Yes · No"
  • vblanche3vblanche3 Posts: 14 [Outstanding Explorer]
    OMG :$

    problem solved: peerblock was blocking....OMG what a story, anyway, it's solved. When I think that Tomtom wanted me to send it for repair and pay 105euros (just for a quote)...

    Thanks everyone for your help.
  • MarneeMarnee Posts: 4 [Master Traveler]
    I have the same problem with my windows 7 PC and this was the same before I upgraded from Vista. My wife has an XP computer and it works fine on that one. I just can't get it to work on my Win 7 PC or my Win 7 laptop, no matter what I try. Strangely though, it would work on my Win 7 PC when I first upgraded from Vista - and I was in France at the time, so don't think being in France has any bearing on it not connecting. Very frustrating but I now just have to use my wife's PC!!!!!
  • YamFazManYamFazMan Posts: 13,985 Superusers

    Some suggestions .....  [url="; target="_blank]Hopefully they will get you up and running.[/url] ..... is it win7 64bit

    World phone numbers to contact Customer support ............... [url="; target="_blank]Phone-numbers.[/url]

    Phone Lines dedicated  to New GO 4/5/600 & GO 5/6000 ..... [url="; target="_blank]Phone Numbers[/url]

    Other ways to contact TomTom Support ................................. [url="; target="_blank]How-to-Contact-support.[/url]

    Thanks to User Niall for the phone number info

    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > Thumb's Up Icon

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
  • MarneeMarnee Posts: 4 [Master Traveler]
    No Win7 32bit!
  • Furiously HuntedFuriously Hunted Posts: 2 [Apprentice Traveler]
    Hi every one, hopefully someone can help. I have tried each of the above suggestions and so far no final connection to "My Drive" with my GO 6100 navi. I have no problem getting connected to the computer with the USB (the tones with connection and disconnection sound each time ) and "My Drive" notices and starts to try connecting to the Navi that is attached by USB cable but cannot connect together. I have checked the usb ports and no warning notices. Tried a hard reset and of course changed out the cable with two others that I use for mine and my sons handy's each time everything the same still no connection. If someone needs a bit more info just let me know and asap I will add it to here. Oh yes, I have had the GO 6100 for 3 months now and every time a update was shown I connected the navi and with no problem update was completed. Today I hooked the navi up to the computer for the newest update and no connection so for the past 5 hours I have tried all the above suggestions and hopefully someone has a good suggestion that will work. Thanks in advance for any helpful hints.
  • dhndhn Posts: 33,100 Superusers
    Have you rebooted the computer lately? Also what happens if you connect the device while off to the computer and THEN turn it on? Is it recognized then?
  • Furiously HuntedFuriously Hunted Posts: 2 [Apprentice Traveler]
    Hi dhn, it turned out it was the computer after all (and yes I had tried restarting the computer with and without the navi attached). I had turned the computer on and was using it most of the day then a popup from tomtom that new updates were available so I hooked up the navi with the usb cable and the computer registered that the usb was in use and *My Drive* was started automatically, but then was stuck at looking for the navi till it counted out and returned a error that the device could not connect. Tried doing all the suggestions with the computer and the navi and was at it for over 5 hours then all of a sudden other programs on the computer would not start. I then started to try troubleshooting on the computer ( win 8.1) and for another hour or two nothing, then I wrote in this forum asking for help. Well to finish this off quickly I tried registry checker from windows and it found some problems so I had them fixed and then some how troubleshooting from windows had a popup during one of the restarts of windows that files were damaged and should be repaired so they were fixed and the computer was turned on four more times each time finding and fixing problems till suddenly the GO 6100 and the computer connected and updated. I did another couple of checks and restarts of the computer and finally no more problems were found and both tomtom and windows was updated and I hope working correctly now. Now a day later everything is still working and another update was quickly installed by *My Drive* and the computer. So for me it was my computer that had some problems and after the damaged files were fixed it worked correctly with *My Drive* and the GO 6100 navi.
  • dhndhn Posts: 33,100 Superusers
    Thanks for your feedback and perseverance. Glad things are sorted.
  • AhmetZAhmetZ Posts: 2 [Apprentice Traveler]
    I'm using a TomTom go live1005 and until recently, everything worked fine. Since a couple of days, there is no connection possible between my computer (windows 7) and this tomtom. The tomtom recognizes it is connected to a computer, says I need to go to there states I should connect my tomtom.Mydriveconnect does not see the tomtom, says I should connect it. I tried to reinstall mydriveconnect, which now no longer says I should connect my tomtom go 1005, but just wants me to connect any tomtom. I even went so far as to a complete factory reset on my tomtom, which lost me all my hours of hard work going through the settings and perfecting all my sound warnings, but still no connection between tomtom and the computer. Tried different USB ports, no success. Could someone PLEASE help me out, as there are updates available for my tomtom and I really like to keep up to date, and just be able to connect the two.

    just sorted the problem out. I dont know how it works for different systems but I have windows 7. So ; all is fine, cables, devices, my drive programme. do not play with any of these. go to device&printers and you will see tomtom as unspecified, troubleshooting needed etc. right click and go for troubleshooting, but let windows do everything, there will be a display to select options, select yes for windows to update all drivers etc. and troubleshooting will start and finish in 2-3 minutes, then it will show that troubleshooting fixed drivers and they are installed. so the tomtom navi device will connect automatically. (4000 was set in the settings/connection). then you will see your tomtom device next to your other devices on devices&printers (ie. computer and tomtom) .I have printscreen views but couldnt upload them.
  • RuanRuan Posts: 1 [Apprentice Traveler]
    My tomtom also did not want to connect and I went to control panel selected hardware and sound option. Then I went to device manager in side hardware and sound. Search for the tomtom icon under network adapters open it up go to driver and see if the device is enabled. Your tomtom should now be connecting.:D
  • GazzSGazzS Posts: 10 [Outstanding Explorer]
    Everything seemed fine with updates until I upgraded MyDrive to the new version ( now although I can get the connected symbol & I get the message from the device telling me to get connected to go to This is on two different machines, two different operating systems using two different cables & on both machines MyDrive insists that the device is not connected.

    This is incredibly frustrating as I have tried all the above suggestions and nothing seems to work.
  • dhndhn Posts: 33,100 Superusers
    Try uninstalling MyDriveConnect completely using the freeware version of Revo Uninstaller (get it here: Then get a fresh copy at and try again.

    If no luck, call support when open:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • 1515User1515User Posts: 1 [Apprentice Traveler]
    VIA 1515m with Windows 7 Pro - unable to connect to computer
    I have had a similar problem that was not hardware related.
    I downloaded Mydrive connect as instructed by Tomtom to be able to update my GPS. Once installed I tried to connect to my 1515M and got a message that it was NOT compatible with Mydrive and that I would have to download Tomtom Home. I downloaded home and it installed with no errors. When I tried to connect there was a message No Device Connected on the Home screen. On the GPS was a small computer monitor icon showing it was connected to the computer, and the Tomtom showed up on the computer under Control Panel, Device Manager, Network Adapters. The driver is up to date for the device and there are no problems shown. Also in Control Panel under Network and Sharing Center the LAN connection the GPS was under is displayed, but when I ran the diagnostic program it returned the error "Local Area Connection 2 does not have a valid IP Configuration". Even a tech at Microcenter's knowledge desk could not figure it out.

    The solution was to uninstall Home and download and reinstall Mydrive connect. When you get the message that Mydrive Connect it is not compatible with your device and to install Home, IGNORE that message. There is a link on that window to add another device or change device or something like that. Click on the link and follow the instructions to delete whatever other device that comes up and install the GPS you have. Once I did that everything connected properly and after 7 or 8 hours my Tomtom GPS had finished updating and all was working correctly. Tomtom needs to add clear instructions on the Mydrive Connect page and in the user manual how to work around this kind of error and that it may be due to a previous unit being connected to your computer in the past. Hopefully this will help other users with this problem.
  • gertmansgertmans Posts: 1 [Apprentice Traveler]
    So here I find dozens of people coming up with different solutions and none of them works for me. And no I don't want to uninstall and reinstall, reset my computer, run USB diagnostics, or buy a new computer. Come on Tomtom, it's 2017 and you still haven't got your devices connecting properly. I'm a Garmin user since decades and no matter what they run and connect flawlessly. I bought this Tomtom for my dutch clients whom I thought would be more comfortable using something they know from home. Couldn't be more sorry. Tomtom was and still is inferior to Garmin. I still don't understand how they can have the market share that they have. Not for the quality of their products, not for the intuitiveness of their interfaces and certainly not for getting things like these sorted. It's a mistery to me. Its back to Garmin I go
  • John.TheratJohn.Therat Posts: 1 [New Traveler]
    I'm guessing that this problem has been solved a 1000 times by different people but just in case, this is what was preventing my Tom Tom from connecting to my Windows 10 Pro PC.
    Under Device Manager, Network Adaptors, Check that the tom tom adaptor is "Active"
    If you can't find the device manager simply type the name into the search bar.
    I hope that this helps you.
Sign In or Register to comment.

Who's Online3

+2 Guests