Hanging on Loading App screen — TomTom Community

Hanging on Loading App screen

fm2000fm2000 Posts: 1 [New Traveler]
Hi

I have purchased Tomtom subscription. The biggest problem with this app is it hangs on Loading App screen after several days of using the app and these no way to fix it other than reinstalling and re-download of all maps etc. It's very annoying and data intensive specially if roaming.

Can you fix this issue asap? So many people in the forums are complaining about this for over a year and your technical team isn't fixing it yet.

Can you please fix this and it's most problematic issue you have specially if the customer is not able to even start the app in the most critical time.

Comments

  • RGM71RGM71 Posts: 363 [Renowned Trailblazer]
    Since version 1.12 sometimes I have the same issue.
    On my device it helps when I force the GO Mobile app to stop. After forcing the app to stop, I can start and use it (until after some time the app hangs on the loading screen again). Maybe this also works for you.

    The option to force an app to stop can be found in Application management of your device; just open the app that gives problems and touch button "Force to stop".
  • box2k2box2k2 Posts: 34 [Outstanding Explorer]
    Similar problem here (https://en.discussions.tomtom.com/tomtom-go-mobile-and-navigation-for-android-156/go-mobile-android-v111-and-112-crashes-on-startup-1007563). Get on to support. While they don't have a solution, you can help add weight to the issue.
  • TinkerBurtTinkerBurt Posts: 8 [Apprentice Traveler]
    Mine randomly hangs on the loading screen, major pain it takes around 5 minutes some times.
  • Johanb2Johanb2 Posts: 3 [Neophyte Traveler]
    Few days ago I experienced the same problem with v1.12, application hangs on loading. Tried to force-stop the app but no luck. Also switching between mobile data and Wifi connection did not help.
    Been using the mobile app on Android for years and it worked fine every day.
    Is there a way to go back to v1.11 ?
    Back to Google maps for now :(

    Samsung Galaxy A5 (2016) running Marshmallow 6.0.1
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for reporting this!

    A couple of things might be causing this. One is if you have the app/map installed on an SD card formatted to exFat and another if you're using dual SIM cards.

    In the first case, please reformat your SD card to FAT32. In the second case, try with the other SIM card and report to Customer Service for capturing the details.

    Cheers, Mikko
  • TinkerBurtTinkerBurt Posts: 8 [Apprentice Traveler]
    Mines doing this since the new version came out, i've logged a ticket in the hope they fix it asap.
  • Johanb2Johanb2 Posts: 3 [Neophyte Traveler]
    Hi

    The app. is stored on device memory, but the West EU map is stored on SDcard (Sandisk ultra microSDHC) formatted in FAT32.
    The phone does not have dual-SIM option.

    Cheers.
    J.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for the info!

    I've reported this to the product team. Meanwhile, I'd recommend you to report this also to Customer Service as they'll be able to gather the required details for further investigation.

    Cheers, Mikko
  • Johanb2Johanb2 Posts: 3 [Neophyte Traveler]
    Issue was solved by following the steps provided by the support team, namely force-stop the app., then clear cache, and clear data:

    - Delete the data folders (check both SD-card and Internal memory):
    - Android/data/com.tomtom.gplay.navapp
    - Android/obb/com.tomtom.gplay.navapp

    I did re-install a smaller map afterwards.

    Thanks.
  • box2k2box2k2 Posts: 34 [Outstanding Explorer]
    Johanb2 wrote:
    - Delete the data folders (check both SD-card and Internal memory):
    - Android/data/com.tomtom.gplay.navapp
    - Android/obb/com.tomtom.gplay.navapp

    I'd be interested to see if this provides a long term solution as I'm not convinced it's related. I have both those folders, but only one is populated. If I delete the empty one, the app recreates it on the next run.
  • exonexon Posts: 3 [Apprentice Traveler]
    I have been using v1.12 on my Samsung Galaxy S5 (G900F) with Android M 6.0.1 with my maps (Germany, Austria, Switzerland), installed to the phone's internal storage. The app worked fine for multiple days, but all of a sudden it was hanging on the loading screen. Shutting down the phone completely did not help, neither did clearing the application's cache.

    I am very disappointed and have uninstalled TomTom for now. I will not consider buying it, even though I like it very much, until this annoying bug is fixed.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi exon,

    Did you try the steps Johan shared above? If you need help with those, please contact Customer Service. They can help you further with this :D

    Cheers, Mikko
  • exonexon Posts: 3 [Apprentice Traveler]
    I did not try the steps mentioned above because I do not want to download a gigabyte of map-files every few days because the app crashes eventually. I uninstalled the trial version for now.

    I really like your app, but I wil not buy it until this annoying bug is fixed. Of course oding is complex, but such thing should not happen to a company like yours, which is market-leader in terms of navigation. Just saying.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    If you already haven't could you also state the phone model and Android version here so we can try to assess which devices are affected, please?

    Thanks, Mikko
  • RGM71RGM71 Posts: 363 [Renowned Trailblazer]
    SM-G901F (Samsung Galaxy S5+), Android 6.0.1
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Here are some tips to troubleshoot this issue:

    Turning your phone to flight mode and back helps to overcome this issue in some cases. The following has also helped many to solve this:
    • In the phone, go to Settings > Apps > GO > Storage and tap Clear data
    • The start it again and download the map
    • Once downloaded the map, do not enable MyDrive sync
    • If existing, delete the folder /Android/data/com.tomtom.gplay.navapp from the SD-card
    • If existing, delete the folder /Android/obb/com.tomtom.gplay.navapp from the SD-card

    Some progress has been made regarding this issue, but unfortunately this can't yet be addressed in the soon to be released v1.3. I'll keep you posted.

    Cheers, Mikko
  • FunkyronsterFunkyronster Posts: 8 [Legendary Explorer]
    Mikkok - are you saying it WILL be fixed in 1.3 or can NOT be fixed in 1.3?

    I have just spent 2 days installing and configuring and loading POI's, to be confronted with a re-install today.

    Rather than complain, I prefer to be pragmatic. I think it would be of great use if you could explain the problem in technical terms. This would help those of us who have technical skills.

    Could you detail the area that causes the problem? From what you say it appears that Mydrive sync is the problem. I can do without that - I switch it on after a re-install, let it load my POI's over the internet, then disconnect MyDrive - will that help?

    Can you describe the best conditions that will minimise the problem - what should we NOT do?

    About re-install - is there not a way to avoid constantly downloading the UK map of 800mb? Couldn't I have it on my laptop and load it manually after each re-install? I am on mobile data most of the time and it's slow and expensive.

    Help us and we will help you!

    Regards

    V1.12 (1641) Samsung SM T-705 16gb Android 5.0.2
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi funkyronster,

    Welcome to the forum!

    Unfortunately, any eventual fix for this issue won't make it to the next (v1.13) release. I also don't have any further information about this issue to share. I'd recommend you to contact Customer Service for further assistance.

    Cheers, Mikko
  • foxhunter2foxhunter2 Posts: 17 [Outstanding Wayfarer]
    try this : Enable network in background setting. On a s7 edge its in battery settings !? https://en.discussions.tomtom.com/tomtom-go-mobile-and-navigation-for-android-156/solution-app-loading-hang-on-s7-edge-1027021
Sign In or Register to comment.

Who's Online44

BLIU
BLIU
Dorub
Dorub
DougLap
DougLap
kumo
kumo
marco.reusel
marco.reusel
Margreider
Margreider
noldi
noldi
tfarabaugh
tfarabaugh
TomDone
TomDone
+35 Guests