Spark not charging

Annagesiena Registered Users Posts: 2
Apprentice Traveler
edited January 24 in TomTom Sports
My watch went blank this morning. When I tried to charg it I get only 2 hands. What is wrong? My watch stays blank.


  • tfarabaugh
    tfarabaugh Posts: 16,948
    I would try to perform a reset on your watch using the recovery mode, follow these steps:

    1. Place your watch in the dock before you connect the dock to the computer.
    2. On your watch, move DOWN but keep the button pressed.*
    3. Connect the dock to the computer. Keep pressing the button until your watch shows
    4. Release the button and wait for MySports Connect to show Update.
    5. Click Update in MySports Connect.
    * If the USB port on your computer is not easily accessible, connect the dock to the computer without the watch. Then move down from the clock screen while you slide the watch into the dock.

    If that does not work you should call Customer Support. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • Annagesiena
    Annagesiena Registered Users Posts: 2
    Apprentice Traveler
    Thanks for your answer.
    Today after a view day's suddenly the watch started to charge. I have been looking at the pins of the charger. I did it before but now it worked. Your solution did not work because the watch was complete empty.