No Data Connection to TomTOm TRaffic and Speed cameras — TomTom Community

No Data Connection to TomTOm TRaffic and Speed cameras

davea66davea66 Posts: 7 [Apprentice Traveler]
I rasied a support ticket for this, but have had no reply, I wonder if someone here is able to help please?

I have not used Tomtom Go Mobile fpr a few months, but i can get no data connection at all. I get no traffic or cameras, I logged out, which caused the app to crash but when I try to log back in I just get 'Oops something has gone wrong'. When I first load up the app it says connect to the internet to see if there are any more free miles. So - no data connection. The connection on my phone is fine, everything else works fine!
Any advice please?


  • xtrapnelxtrapnel Posts: 3 [Neophyte Traveler]
    LIkewise, the Go Mobile isn't delivering on the one thing I buy it for - the live traffic updates and speed camera lists. Been this way for several weeks now.

    I've got 4G coverage with EE, which is probably the best in the UK for overall coverage. A brand new Google Pixel phone. I've today done a "factory reset" on the application (which a bit of research showed me was a possible fix) and now I can't even re-enter my details to "upgrade" (i.e. make the app usable with my subscription data).

    Without this functionality working, I might as well use Google Maps to be honest; and claim a refund for my subscription.

    Any response from TomTom would be appreciated !
  • tgoldtgold Posts: 2,187 [Revered Voyager]
    xtrapnel wrote:
    Any response from TomTom would be appreciated !
    This is a user forum. The best way to reach TomTom Support is here:
    United Kingdom
    020 7949 0134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for flagging this!

    I'll forward this to our technicians. Could you also state your phone model and Android™ version, please? Could you try if it works with a Wi-Fi® connection?

    Thanks, Mikko
  • davea66davea66 Posts: 7 [Apprentice Traveler]

    My phone is an HTC One M8 and the Android version is 6.0

    many thanks
  • davea66davea66 Posts: 7 [Apprentice Traveler]
    Also, no, it does not work on WiFi or 3G/4G
  • xtrapnelxtrapnel Posts: 3 [Neophyte Traveler]
    Hi there.

    I've uninstalled, wiped all files, re-installed, I now get a "This app cannot connect to TomTom. Check your phone's internet connection".

    This happens regardless of whether I'm on WiFi or mobile 4G.

    Phone: Google Pixel. O/S: Android 8.0.0 build OPP4.170623.014
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for the info!

    This is a known issue and I'll add your info to the ticket. Meanwhile, the following steps have helped many get this sorted:
    • Uninstall the app
    • Clear cache data for the following apps (note, going to Settings > Applications / Manage Applications, might not show them. Via the 'More link in the top right corner, enable 'Show System Apps'):
      Google Play Services,
      Google Play Store,
      Google Services Framework
    • Set the time to "automatic"
    • Restart the phone (this is important)
    • After the phone restarts check and make sure their internet browser has access to the internet with wifi and/or 3g/4g
    • Download a fresh copy of the app from the Google Play store
    • Install and test

    Should this not help you get this sorted, please contact Customer Service for further assistance.

    Cheers, Mikko
  • xtrapnelxtrapnel Posts: 3 [Neophyte Traveler]
    OK, tried the above steps. When trying to run TomTom, got the "not enough memory" error...went in, cleared data and cache. Still the same issue persists when it did run, i.e. claiming I have no connection to the Internet, happens on both 4G and WiFi. :-( thanks for your help anyway...
  • Orion1951Orion1951 Posts: 6 [Neophyte Traveler]
    Solution was to open port 443. To achieve this i installed app "pare feu sans root", allow Go and a rule to open port 443.
  • tgoldtgold Posts: 2,187 [Revered Voyager]
    @Orion1951: had you installed firewall software on your device? If so, what brand?
  • Orion1951Orion1951 Posts: 6 [Neophyte Traveler]
    Yes. As i wrote, I installed the app "parefeu sans root" The problem is that for some reason port 443 is locked and need to be open for tomtom go. Suspect this could be after an android update. I use a Galaxy S4 android version 5.0.1, security 17/03/01
  • tgoldtgold Posts: 2,187 [Revered Voyager]
    I don't follow any of that. An add-on firewall app can not open ports that are closed by the OS, it can only open ports that were otherwise to be closed by the firewall itself. If plain Android closed TCP/IP port 443 then devices would have no access to any https:// web sites (which is plainly not the case). If your adding that firewall app cured a lack of network data then the reason does deserve investigation by TomTom.
  • garaetschgaraetsch Posts: 3 [Neophyte Traveler]
    I have the same problem (no traffic, no maps showing for download, not possible to log in...) with all my devices with v1.16.1... when I update to v1.17 everything is working again... but I don't like this... I don't want to get blackmailed to update to the latest version... what's currently wrong with v1.16.1 ???
  • Orion1951Orion1951 Posts: 6 [Neophyte Traveler]
    I agree with you but the solution works! With this firewall and port open for tomtom, I got traffic informations. As soon I stop firewall i lose trafic info and this can be repeated. This appli is able to open port without root access. I come to this solution when I saw that tomtom tried to reach internet usîng secured port 443.
  • AsprinAsprin Posts: 271 [Supreme Pioneer]

    Show me a screen shot of the port 443 open when using this app "Firewall sans Root"
    and a screen shot when the port 443 you say is not open when this app "Firewall sans Root" is not in use .

    I have never run into any problems with TomTom GO with having to use a firewall to get it to work with traffic.
    Even with non roots phones and rooted phones
    Plus any version of Android.

    Why would port 443 be locked??? as tgold pointed out:

    I quote:
    "no access to any https:// web sites (which is plainly not the case)"

    This app "Firewall sans Root" has not been updated since 30 November 2014.

    Info on Port 443

    http protocol over TLS/SSL

    This port is used for secure web browser communication. Data transferred across such connections are highly resistant to eavesdropping and interception. Moreover, the identity of the remotely connected server can be verified with significant confidence. Web servers offering to accept and establish secure connections listen on this port for connections from web browsers desiring strong communication security.

    Once established, web browsers inform their users of these secured connections by displaying an icon — a padlock, an unbroken key, etc. — in the status region of their window.
  • garaetschgaraetsch Posts: 3 [Neophyte Traveler]
    Orion1951 wrote:
    Solution was to open port 443. To achieve this i installed app "pare feu sans root", allow Go and a rule to open port 443.

    I also just installed "pare feu sans root"... but no success regarding TomTom... what exactly did you configure in this App regarding Port 443?
  • Orion1951Orion1951 Posts: 6 [Neophyte Traveler]
    You have to create a specific rule for tomtom. To achieve this allow Go to access wifi and data by checking go in application tab. Then click at same place the go appli. This will open a new page where you need to create a specific filer as : *:443
  • garaetschgaraetsch Posts: 3 [Neophyte Traveler]
    OK, I did it exactly this way... does not solve the issue...
  • tgoldtgold Posts: 2,187 [Revered Voyager]
    You are creating a rule to allow an app's data to tunnel through the firewall. That would be useful to someone who has some other need for the firewall but it makes no sense as a solution for anyone who is not already using a firewall.
  • Orion1951Orion1951 Posts: 6 [Neophyte Traveler]
    Sorry to hear that this is not working for you configuration.
  • Orion1951Orion1951 Posts: 6 [Neophyte Traveler]
    The solution I described is définitively working on my device. The use of the firewall appli is just one way to open port 443 for tomtom. Reason why tomtom is not allowed is thé real problem.
  • AsprinAsprin Posts: 271 [Supreme Pioneer]

    Quick test:

    Without your Firewall on can you from your phone or tablet access TomTom forum???

    In the upper left hand of your browser you should see a Green Padlock also https: in green

    If so port 443 is open.

    With you having to change things on your phone or table to get "TomTom Go" to work there are other problems you are having.
    Being that of your phone or an app that you install that is blocking port 443.

    But if you can access this forum with out your firewall on "TomTomGo" is not the problem.

    Then the question comes to where are you trying to connect?
    At HOME
    Over a data connection with your provider.
    Are you roaming and connected to another provider.
    At work
    In a hotel
    Coffee shop
    Or some hotspot.

    Then there is a fact that you did not install TomTomGo correctly and need to start over again with a clean install.

    But Like I said before show us some screen shots of what you are doing.

    PS that goes for anyone else why can not get traffic to work.

    Details Details Details
  • RobertOosterRobertOoster Posts: 3 [Apprentice Traveler]
    Finally, this worked
    Xiaomi Redmi 1S
    LineageOS 14.1
    Android 7.1.2
Sign In or Register to comment.

Who's Online in this Category0