Having to Login EVERY time — TomTom Community

Having to Login EVERY time

arichardarichard Posts: 319 [Supreme Navigator]
edited January 14 in Forum feedback
My login used to last for months before having to be repeated.
Then I had to log in every few days
Now I have to login every time

This is very tedious. How can I make my login last longer?

Comments

  • tgoldtgold Posts: 2,068 [Supreme Pioneer]
    I have seen no such change. Are you doing something new that is causing the relevant browser cookies to be cleared?
  • arichardarichard Posts: 319 [Supreme Navigator]
    No have not cleaned cookies for a long time. It would also be "customer helpful" if Windows was allowed to remember the login and fill it in automatically like other websites but I suppose that would be asking TomTom too much.
  • tgoldtgold Posts: 2,068 [Supreme Pioneer]
    Using Windows 7 and Firefox I cannot remember how many months it has been since I last logged into this site.
  • arichardarichard Posts: 319 [Supreme Navigator]
    I use Windows 10 with MS Edge, just checked settings and preferences - I can find nothing to cause this inconvenient behaviour.

    I would like my Login to last.
  • tgoldtgold Posts: 2,068 [Supreme Pioneer]
    I do not believe this is a site issue. I notice that Edge has an optional setting to clear cookies on exit https://www.onmsft.com/news/how-to-automatically-delete-your-microsoft-edge-browsing-history

    Anyway if no Edge users can help you with this then you might give Firefox a try.
  • arichardarichard Posts: 319 [Supreme Navigator]
    Thanks I did make sure that Edge clear cookies was unchecked. You never know what MS forces on us with each update but last year I did not have this problem.
  • SteveDukSteveDuk Posts: 21 [Apprentice Traveler]
    I don't think it's a Windoze problem. I use Linux and Chromium browser and have to log in everytime as well
  • tgoldtgold Posts: 2,068 [Supreme Pioneer]
    SteveDuk wrote:
    I don't think it's a Windoze problem. I use Linux and Chromium browser and have to log in everytime as well
    We were later told in another thread that this was not a problem but a feature:
    MikkoK wrote:
    Hi all,

    The change in the login behaviour is from TomTom's side. It's a company wide security requirement as we have Single-Sing-On login on the tomtom.com domain and your accounts contain personal information, e.g. regarding your purchases.

    Cheers, Mikko
  • SteveDukSteveDuk Posts: 21 [Apprentice Traveler]
    LOL

    It's a website about satnavs for god's sake.

    Not MI5.

    ISTM that some companies take themselves far too seriously.

    ETA And NO way am I singing to get into a website :cool:

    ETA 2 And if that's the case why do I have to sign in again if I click through from here to the main website?
  • dhndhn Posts: 33,167 Superusers
    It's a pain, isn't it............
  • YamFazManYamFazMan Posts: 15,083 Superusers
    Hi
    Yes, it's a Pain !!!
    I use Firefox with the Tomtom site login info stored
    I have setup a Desktop Shortcut pointing Here.....
    https://uk.support.tomtom.com/app/utils/login_form/redirect/community_redirect/community_path/52Fhttps53A52F52Fen.discussions.tomtom.com52Fsso52Freturn53Freferer53Dtoken526url53D52F526

    First login of the day... I Double Click on the shortcut -> Firefox opens at the login page with Email & Password already entered
    Click Login -> the Forum Homepage opens logged in OK -> Click the browsers minimise button to minimise the page to the TaskBar...
    Don't close this page it keeps the forum session logged in

    For the Rest of the Day, I either double click on the Shortcut Icon to open the forum Home Page
    Or Click on the links in my Email inbox to open the individual threads

    ATB YFM
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Sorry for my late reply here!

    A while ago we've implemented a company wide security measure that forces a log out from all sites on the tomtom.com domain upon closing the browser. I understand that this can be annoying for active Community members like yourselves, but unfortunately we can't change this behaviour for the forum.

    Nevertheless, there are a couple of things you can do about this. First, make sure your browser doesn't automatically delete cookies. What works for me is that I don't turn my laptop off but put it on standby. This keeps the browser open and me logged in.

    Cheers, Mikko
Sign In or Register to comment.

Who's Online5

5 Guests