TomTom GO Mobile on Android O (Android 8) — TomTom Community

TomTom GO Mobile on Android O (Android 8)

donald23donald23 Posts: 1 [New Traveler]
I upgraded my phone to the latest public beta (yes, I know, beta software so issues are bound to happen) of Android 8 (Android O).
From that moment on I cannot retrieve traffic information. Per troubleshooting here on the forums, I logged out of the app and cannot log in anymore.

Then I tried to completely deinstall the app, clear the cache, reboot the phone, install a fresh copy from the playstore and get the notification that I cannot even start the app anymore since it cannot reach TomTom. Internet works fine on my phone and it happens on both WiFi and 4G.

This is very probably caused by the new Android version. And this topic is mainly to make TomTom aware. I'm a bit clueless as to why the app can no longer use the available internet connection on my phone. Other apps have no problem using internet.

If there is a beta available for TomTom for Android 8 that I can try, I'm willing to do so :) Otherwise this can function as a warning for other users contemplating an upgrade to the Android beta.


  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Donald,

    Welcome to the Community!

    Thanks for flagging this! We indeed don't support beta releases and therefore can't help you much with this. However, I'll forward this to the product team. I'm sure it helps them testing on the new OS to be ready for the public release.

    Cheers, Mikko
  • tvkanterstvkanters Posts: 10
    We're aware of this issue and working on fixing it. The next release should have full Android O compatibility!
    Until then, the app will not be able to communicate with our back-end, which unfortunately also blocks anyone from starting the first-run flow.
  • MarkACMarkAC Posts: 2 [Apprentice Seeker]
    Android 8 was installed today, Nexus 5 (not beta), and I now have no traffic, and I can't log back in.
  • Rimmer100Rimmer100 Posts: 5 [Apprentice Traveler]
    I also have the same problem on a Nexus 6P - Interestingly this release of the app states it has Android O support. Doesn't seem that this was tested thoroughly!
  • rob.morabitorob.morabito Posts: 15 [Outstanding Explorer]
    The same problem. Nexus 5X with official Android O release
  • wjamie2340wjamie2340 Posts: 3 [Neophyte Traveler]
    Experiencing the same problem.
    App unable to connect to network - received no traffic updates, unable to access account information.
    Tried resetting app - unable to login due to no network connection, unable to claim free miles.

    This does not work on when connected to either the Mobile Network or WiFi.
    I was able to access the internet on my phone on other Apps at the time, so there was definitely a network connection.

    Device : Nexus 6P
    Android Version: 8.0.0
    App Version: 1.17
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Those of you having problem logging into TomTom Services, please reset your TomTom account password here and try again.

    Cheers, Mikko
  • wjamie2340wjamie2340 Posts: 3 [Neophyte Traveler]
    Hello Mikko,
    Thank you for your response.
    To clarify - i am able to log into my TomTom account in the browser, so my credentials are correct.

    I am only unable to login on the TomTom GO android application on my phone.
    This appears to be because the TomTom GO android application cannot connect to the internet on Android 8.0.

    Please see the attached screenshots.
    The screenshot with "Oops something has gone wrong" occurs when i try to log in.
    I have included the last screenshot of a speed test application to show that my phone had a good internet connection at the time the TomTom GO application was unable to connect to the internet.

    Do you still want me to reset my password?

    Thanks, Jamie
  • JohnclaassensJohnclaassens Posts: 1 [Apprentice Traveler]
    Same problem here. Nexus 5x with official release Android 8.0.0 and since update no live traffic information.! Please fix this a.s.a.p.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Jamie and John,

    Thanks for the confirmation! I'm afraid we'll need to wait for the next release as my colleague mentioned above.

    Cheers, Mikko
  • MarkACMarkAC Posts: 2 [Apprentice Seeker]
    Ok, so just to clarify. Unable to use traffic, unable to re-login on device, and your reference goes back to a comment for a fix that is now 3 months old. Is there any indication when this update may become available. I rely on "traffic".

  • [Gelöschter Benutzer][Gelöschter Benutzer] Posts: 5,321 [Supreme Navigator]
    There are reports in the German-speaking forum that a complete uninstallation and reinstallation of the app has fixed the issue.
  • Rimmer100Rimmer100 Posts: 5 [Apprentice Traveler]
    I had raised this with support and got the following response which worked for me!

    I did reboot my phone between the installation and re-installation. Also when I downloaded the app again it seemed to stall at 32% for a while before continuing - but that may not be anything:

    Step 1 : Reinstall the Go Mobile app

    1. GO in the phone in Settings > Apps > GO and tap on Force stop.
    2. Delete the data folders (check both SD-card and Internal memory):
    - Android/data/com.tomtom.gplay.navapp
    - Android/obb/com.tomtom.gplay.navapp
    3. Uninstall the app : Uninstall steps on Google Support.
    4. Reinstall the app. For steps see the Download previously purchased apps steps on Google Support.
    5. Download the map again, if required.

    Step 2 : Restore the subscription on your Go Mobile app.

    The only thing that you have to do now is to login into the Go Mobile app with your TomTom account details which will activate the subscription on your application.

    You can follow the below mentioned steps to login into the Go Mobile app.

    1 : Open the Go Mobile app.
    2 : Tap on the button on the bottom right side of the screen.
    3 : Scroll to the right side and tap on button.
    3 : Select MyTomTom Account and log in to your MyTomTom account again
  • Rimmer100Rimmer100 Posts: 5 [Apprentice Traveler]
    That should have read uninstallation and re-installation.

    Interestingly the icon is now showing as square rather than round as it was previously
  • wjamie2340wjamie2340 Posts: 3 [Neophyte Traveler]
    Full uninstall and re-install has also worked for me.
    Thank you for your help everyone.
  • edoardedoard Posts: 16 [Outstanding Explorer]
    Nexus 6P - uninstall + reboot + reinstall did the trick for me too.
    Without reboot in between not enough instead.
    Thanks everyone
Sign In or Register to comment.

Who's Online in this Category1