Can't Log in to MyDrive Route planner online — TomTom Community

Can't Log in to MyDrive Route planner online

RobertShaw66RobertShaw66 Posts: 16 [Master Explorer]
Whenever I open Mydrive and click "Log In" the square box appears but before it finishes opening it disappears so I can't log in. It continually does this.

Only working occasionally

I'm using Chrome

Comments

  • VikramKVikramK Posts: 8,270 TomTom Moderator
    Welcome to the community:)

    We are coming across similar reports from the customer service and also on the community. The issue looks seems to be related to browser compatibility. Our technical team is working hard to get this resolved.

    In the meanwhile could you try clearing cookies, browser history you are using and see if the website loads? Perhaps you can also try using a different browser.

    Apologies for the inconvenience caused.

    Regards
    Vikram
  • RobertShaw66RobertShaw66 Posts: 16 [Master Explorer]
    Yes I've tried all those things. I'm now forced to use Microsoft Edge if I want to use MyDrive.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Robert,

    Welcome to the Community from my behalf as well!

    We've release an update to MyDrive yesterday to fix some of the issues Vikram mentioned. Could you try again and post back here, please?

    I'd also recommend to clear the cookies and browser history once more.

    Cheers, Mikko
  • gdpmusicgdpmusic Posts: 1 [Apprentice Traveler]
    How do I change browser?
  • bigbig Posts: 1,573 Superuser
    @gdpmusic The easiest thing to do would be to download a different browser to have on hand when you need it. For example, if you go to http://firefox.com and press "Download" the Firefox browser will download. You can use that when you need to.
  • popotlapopotla Posts: 9 [Apprentice Seeker]
    I am encountering this same problem on 19-08-18 so it seems that despite the above, TT hsn't yet solved it. Very frustrating.

    I'm using Firefox, will now try Chrome.
  • VikramKVikramK Posts: 8,270 TomTom Moderator
    @popotla

    This topic was started last year and the issue discussed was sorted then.

    Today tested it using Firefox and it worked for me...

    Could you try again, may be it was a temporary issues with the website.

    Regards
    Vikram
  • Tag1956Tag1956 Posts: 1 [Apprentice Traveler]
    This problem is still occurring. "Whenever I open Mydrive and click "Log In" the square box appears but before it finishes opening it disappears so I can't log in. It continually does this." I'm using Safari on a MacBook Pro. When I use Safari on my iPhone or iPad it works fine.
  • bigbig Posts: 1,573 Superuser
    Hmm, works ok on Safari on a MacBook for me. Any chance for Firefox?
  • MrMMrM Posts: 148 [Exalted Navigator]
    Same thing here. Login failes in the way mentioned above, using Chrome on Windows 10.
    Using Microsoft Edge is ok.
  • MrMMrM Posts: 148 [Exalted Navigator]
    I see that the tag "solved" is an attribute on this topic.
    Please take it off? Or should I create a new topic?
  • philhtcphilhtc Posts: 3 [Apprentice Traveler]
    white box for login appearing and quickly disappearing for me too win 10 64bit any new answers to the fault
  • DougLapDougLap Posts: 3,370 Superuser
    Hi @philhtc

    I occasionally get that happening on Safari on a Mac. It usually sorts itself out later but in the meantime if I switch to another Browser that usually works normally whilst Safari isn't. In my case I use Firefox..

    Doug
  • philhtcphilhtc Posts: 3 [Apprentice Traveler]
    i have just updated java on my desktop, now it works, Maybe thats what my problem was all along
  • tupacamaru73tupacamaru73 Posts: 3 [New Seeker]
    Hello,

    I cannot connect from the website:
    Page error
    Sorry something seems to have gone wrong. The webpage you are looking for is temporarily unavailable, which may be due to planned maintenance. Please come back later.

    And also via My Drive Connect: so I cannot update my device.

    Could you please help me?

    Thank you,
    Alessandro
  • DougLapDougLap Posts: 3,370 Superuser
    Hi @tupacamaru73

    Just checked My Drive Connect software and My Drive website both running okay.

    Suggest you try again and if still having trouble with My Drive Connect then delete the software then restart your PC and reload the software from the Tomtom website.

    Doug
  • tupacamaru73tupacamaru73 Posts: 3 [New Seeker]
    Hi @DougLap ,
    I followed your hints, but nothing since Sunday I cannot connect to My Drive Connect.
    I can login on the website, but then I cannot see my profile.
  • tupacamaru73tupacamaru73 Posts: 3 [New Seeker]
    I solved the issue by creating another account with another email address.
  • psiho051psiho051 Posts: 1 [New Seeker]
    Page error
    Sorry something seems to have gone wrong. The webpage you are looking for is temporarily unavailable, which may be due to planned maintenance. Please come back later. Never again tom tom navigator !!!
  • DougLapDougLap Posts: 3,370 Superuser
    Hi @psiho051

    Just tried to open My Drive webpage with Safari on MacBook Air would not open. Tried it with Firefox and opened straight away|

    Doug
  • Steve RawcliffeSteve Rawcliffe Posts: 13 [Master Explorer]
    Doesn't work on Chrome for me, but works fine on Firefox. Lazy programming.
  • YamFazManYamFazMan Posts: 15,248 Superusers
    edited September 11
    Hi
    @Steve Rawcliffe

    Win 10 Dell Desktop.....
    Chrome Login... Works (Quickest screen redraw)
    Firefox Login... Works
    Microsoft Edge Login... Works
    Microsoft IE11 Login... Works (But almost unusable, screen redraw is like watching paint dry)

    ATB YFM
  • wsmc81wsmc81 Posts: 2 [Apprentice Seeker]
    Trying to get my travel computer set up for a 3 week vacation in EU. Just bought Rider 550 and working through connection issues with Iphone and Bluetooth helmet connections. I have not updated to ios13 ... one issue at a time is enough.

    Travel laptop is SurfacePro 4 running Windows 10 ...

    Using Google Chrome I am getting the same login in issue where the popup login is blank and then the popup disappears. Can't login.

    Works fine on Internet Explorer, though it seems like it is running slower.
  • wsmc81wsmc81 Posts: 2 [Apprentice Seeker]
    Sorry .. Make that MS EDGE , not Internet Explorer.
Sign In or Register to comment.

Who's Online27

Bembo
Bembo
Elchdoktor
Elchdoktor
Jopi1956
Jopi1956
Margreider
Margreider
Naivling
Naivling
TomDone
TomDone
Vulkan
Vulkan
YamFazMan
YamFazMan
+19 Guests