Fitness tracker turns off and won't come on mid workout — TomTom Community

Fitness tracker turns off and won't come on mid workout

Cynbarr2963Cynbarr2963 Posts: 9 [Neophyte Traveler]
edited January 2019 in TomTom Touch
Hello. I have the fitness tracker and am a fitness instructor usually doing my classes right along with them. I always wear my watch but the last 2 classes, when I went to check stats on it, it wouldn't respond. I have found - like doing a body composition reading, my finger pad must be "moist" so that the button reacts. But I got nothing today! I took it off and wiped my arm and the back of the band and still nothing. It finally came on about 30 minutes later and of course it had stopped my activity. Am I sweating too much and causing it to turn off? Any suggestions? Fully charged and functional up until then. Thanks for any advice. Cyndy

Comments

  • tfarabaughtfarabaugh Posts: 16,386
    Superusers
    It sounds like it may be a problem with the firmware, going through a crash loop. Try performing a factory reset and if that does not help I suggest calling Customer Support to see what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to tomtom.com/support, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    To do a factory reset, make sure the Connect software is running and dock the device to your computer. The Connect window will open; press the gear at the top right and select factory reset from the next screen. Follow the steps provided and when prompted to register or sign in to MySports, select sign in and use your existing account credentials. It is fairly straightforward and should take less than 5 minutes.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • Cynbarr2963Cynbarr2963 Posts: 9 [Neophyte Traveler]
    Thank you so much for your fast and thorough response. Like you said, it took less than 5 minutes to restore to factory settings. I'll give this a go and see how it works. Thank you again!! Cyndy
  • tfarabaughtfarabaugh Posts: 16,386
    Superusers
    Glad I could help. When you get a chance please mark my response as a solution so others with the same question can look for it.

    And if it continues to have problems, definitely call Customer Support as it may be a defect in the device itself.
Sign In or Register to comment.

Who's Online in this Category0