Activity sync failed

jonmo Registered Users Posts: 2
Apprentice Traveler
edited January 24 in TomTom Sports
I went for a ride, came home, put watch by phone, went for shower.
Come back 10 mins later my TomTom sports app on my phone says "up to date", but the activity isnt there.
I have connected my phone to my PC and searched for the ttbin file. It doesnt exist. Not in the failed folder, not in the uploaded folder.
I have connected my watch to my PC and loaded TomTom Sports Connect. The activity is not there and there is no option to "retry". There is no mention of any failed sync or missing activity.
I have turned off my watch via Tomtom Sports Connect. This did not solve anything. I have not "reset" it.
I have uninstalled the Tomtom ap on my phone and reinstalled. No luck.
I have unpaired my watch from my phone and repaired.

I can still see the activity on my watch (see attached pic), there just doesnt seem to be a way to get it to my phone or my PC.

Tbh, ever since I was forced to "upgrade" the ap on my phone I have been having difficulties. Similar to this difficulty in fact, but in the past activities have just mysteriously appeared after 10-15 mins. Not so this time.

What can you suggest?

Please don't tell me that the sync failed and the detailed activity data doesnt actually exist on my watch anymore.
If it turns out that you have designed software to delete data before confirming successful transfer to another device I think my head might explode.

Many thanks,



  • Stuart McDonald
    Stuart McDonald Registered Users Posts: 759
    Exalted Navigator
    Neither the mobile App or Sports Connect delete the the data until it is stored either on your phone or computer. If they didn't show any attempt to upload an activity then I can only assume the watch did not write it so any changes to your phone or the app will not affect that. I would definitely recommend a factory reset since that's where any problem would be.
  • jonmo
    jonmo Registered Users Posts: 2
    Apprentice Traveler

    Thanks for your reply. The activity eventually showed up on the ap about 3 hours after I first tried to sync. The phone was next to the watch throughout that period, BT was turned on, as was Android notification on the ap, so why it took 3 hour, I am not sure.

    Then, I went out again yesterday and had a similar problem. I that I solved it by forgetting another (non-tomtom) device which my phone was also connected to by BT. This seemed to fix it. But even when the other device was connected to my phone BT, the watch would show the phone icon to indicate it was connected, the ap would say "preparing to sync", and then change to "up to date", as though it connected, searched, and then found nothing, which I found odd.

    In fact, when I think about it, the first activity didnt sync while I was at home (connected to the other device). It was when I went out of the house (moving out of range of the other device) that the activity eventually synced.

    If forgetting the other device is the workaround I need to sync activities then so be it, but I would repeat that this problem did not exist until I was forced to "upgrade" a few weeks ago.

    Also, when you say do a "factory reset" do you mean on my watch? I definitely dont want to do that on my phone unless completely necessary.

  • tfarabaugh
    tfarabaugh Posts: 16,948
    I meant the watch, not your phone. As to the other device, many devices (Garmin ones in particular) lock up the BT connection on your phone and will not allow other devices to connect, so the only way to release it is to close the other app or shut off the device.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
This discussion has been closed.