Sync issue between TomTom Multi-Sport Cardio and iPhone/laptop

Thierry F
Thierry F Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
Hello. I Have a problem of synchronisation between my GPS TomTom Multi-Sport Cardio and my iphone and/or laptop. The activity is on the watch but whatever I do, I cannot see the activity online. An idea for force the synchro ? Thx for your help


  • tfarabaugh
    tfarabaugh Posts: 16,948
    If you are using an app has the watch been synced to the phone and does the phone recognize it? If using an app to upload, the app needs to be open and active. Also make sure you do not separate the watch and the phone during the sync process. Best bet is to put the watch on top of the phone and leave it there. If you get out of BT range it will fail. Make sure you have strong signal on the phone (Wi-Fi is even better). A weak signal will slow the process and can cause failures. I recommend using the computer to sync as it is much more reliable and much faster.

    On the computer, are you getting any error messages when you plug the watch in or is it being recognized at all? Does the clock face change to a battery charging icon (which indicates it is getting power so there is a partial connection). Have you first installed the Connect software and is it running when you try to sync by computer? The software must be installed and running prior to plugging in the watch. If you are using the phone app, once you have synced by phone you cannot also sync by computer, it is either/or. Once the watch thinks it has a successful upload it clears the memory (what you are seeing in the History is just summary data points, the actual activity is deleted once synced). When you press down from the clock and go to About and look at the storage bar are any bars lit up? If not, it means there is nothing on the watch. if so, it means there are activities left to upload.

    A few things to look at (and I apologize if some are very basic but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB plug free of any debris or blockages?
    5) Is the Connect software actually running (is there an icon for it in the notification area)?
    6) Did you install MySports Connect, not MyDrive Connect? It is downloaded from
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?

    In particular, make sure it is fully snapped into the cradle. If it does not have a full connection it will charge but it will not be recognized by the computer. It seems simple but this is generally the issue. It needs to fully click into the cradle and it may help to take it out of the band to do so. Also check that none of the pins on the dock are bent or pressed in, as that will prevent a connection.

    If nothing above helps you may have a bad dock or there may be computer setting blocking it. At that point I would suggest calling Customer Support and seeing what they can do. They are able to more deeply investigate and diagnose problems than we can here on the user forum. To get the number for Customer Support, go to, choose Contact, enter the product name and click Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • aegetswil
    aegetswil Registered Users Posts: 2
    Apprentice Traveler
    Were you able to fix the issue? I am asking, because I have the same problem. I followed all the 10 recommendations - but none have fixed my issue. Initially the synch to my Windows10 PC worked, but 2-3 days later - nothing synchs anymore. (and I do not have the mysports app on my mobile phone).
    So how did you go about fixing your synch issue?
  • aegetswil
    aegetswil Registered Users Posts: 2
    Apprentice Traveler
    F I X E D !
    Please allow me to report that my 'TomTom Multi-Sport Cardio GPS Watch' now synchs correctly again!
    The issue was: Wrong PC app installed. You need to work with 'MySports Connect'. (see Nr. 6 above, which I miss understood).
    Note: I had both 'MySports Connect' and 'MyDrive Connect' loaded on my Windows10 PC. But for what ever reason, the wrong app prevented the correct app from working. I manually started 'MySports Connect' and everything then worked. I've now deleted 'MyDrive Connect' from my PC.
    Special thanks to TomTom UK support (George!) for detecting this error. Very professional and very fast! Bravo! :$
This discussion has been closed.