Multisport joystick not responding

claireG Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
Hi everyone, I'm panicking right now. I'm due to take part in my first double Olympic distance triathlon next Saturday and my Tomtom multisport watch stopped working on Monday night while I was swimming. The time and date is still working but there is no response from the joystick and the watch won't even charge/connect when I plug it in. I hope someone will be able to help me! thanking you in advance!


  • tfarabaugh
    tfarabaugh Posts: 16,990
    Sounds like the button is jammed. You can try gently probing under it with a pin to try and unstick it or use compressed air, but it may not help. Other than that your only option is to call Customer Support who can look to a replacement if it is under warranty. In that case you will be out of luck for Saturday. i am surprised the watch will work for the triathlon considering its fairly short battery life.

    To get the number for Customer Support, go to, choose Contact at the bottom, select the service required and the product name and click Contact Customer Care and then Phone Us. It will give you the phone number for the country your account is registered under (this can be changed by clicking the flag icon in the bottom right corner of the screen).

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • EttoreTri
    EttoreTri Registered Users Posts: 7
    Legendary Explorer
    Incredible, occurred the same also to me, I used it yesterday to swim with no problems. Today before start a run, the joystick didn't work, also if the click seemed to work, I tried to plug TT in the laptop (luckily in the car) but charge/connect didn't work, only time was working. After more or less 2 hours I retried again the joystick and it worked. Very strange, I'm concerned that can occur again, but still happy of my TT.
  • MiguelFerreira
    MiguelFerreira Registered Users Posts: 1
    Apprentice Traveler
    It happened to me Today. It seems the joystick is always pressing the right arrow. The watch blocks and it can only be unlocked when connecting to the computer. It happened when I was finishing my swim workout... :(
This discussion has been closed.